General discussion

Access RAW partition of Lacie drive from Windows


I have a Lacie Ethernet Disk drive that has a failed enclosure. It's out of warranty so I took the drive out and attached it to my Windows machine. It is a single 500 gb Seagate Barracuda. In reviewing many postings about similar issues, I did manage to read the disk using Ext2 File System Driver (Ext2Fsd version 0.42). Here is my problem. The Linux Ext3 partitions all show up fine and I can read them. However, the partition that houses the user data is a 464 gb RAW drive. Is there any way to get to the user data on the RAW partition, or has something bad gone wrong and I'm basically out of luck. I know that Lacie used Linux as it's mini OS and the only way to configure the drive was via the web interface. I'm wondering if there's any way to salvage the partition with all the data on it. The data is all personal stuff, my family photos and mp3's. I would hate to lose this stuff if anyone knows a way to get the data without having to send it off ($$$). Thanks.

Discussion is locked

Reply to: Access RAW partition of Lacie drive from Windows
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Access RAW partition of Lacie drive from Windows
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
I'd skip Windows for this.

I'd look at the LIVECD's that Linux offers that run without installing. Ubuntu for example.
Ext2Fsd is a work in progress so likely to be a dead end.

- Collapse -
Windows Skipped - SOLUTION FOUND - THANKS!

Thanks R. Proffitt. Your suggestion was taken and a correct one at that. I used Ubuntu and was able to access the RAW partition with ease.

I wanted to add this to my posting in hopes that it will help someone else in the same position as I was. Here is what I did to retrieve my data. Note that in my case the drive was functioning but that I just could not access the RAW partition of the drive.

1. Attach target drive to machine. In my case a 500mb Seagate SATA drive.
2. Download ISO image of UBUNTU Desktop edition. It's open source and free (and cool).
3. Burn ISO to 80 minute CDR.
4. Set computer to boot from CDROM.
5. Boot from the Ubuntu CD and select to boot without installing the OS.
6. Once Ubuntu loads you will have access to all the drives on your system. At least, in my case I had access to NTFS WinXP drives and the target Seagate drive that was Linux.
7. Open the partition and copy all your files from that partition to one of your NTFS drives/partitions. NOTE that you will have to have enough space on your other drive(s) to copy everything over.

That was it. I now have all my data on my NTFS drives.
Thanks for the others who communicated on this thread.

- Collapse -
You made it sound easy.
- Collapse -
How to fix?

Any way you can simplify this for us less computer savvy? I am not able to acess my windows at all- after attempting to scan and then restart, am now getting the "Disk read error, ctrl alt del to restart" and that just loops and loops-

Anything I can do to fix this?

- Collapse -
Re: How to fix

I'm no disk expert, but it sounds like your disk is messed up (technical term) at the master boot record or right where Win is trying to read the loader. Anyways, if part of your drive is readable then booting through Ubuntu would be helpful at least to determine whether you can even read the drive. My drive was not corrupt, just the enclosure died and it was a Linux partition.
Here's a couple of questions:
1. Do you have a USB drive that you can hook up to your computer to pull data off if you get it up and running with the Ubuntu LiveCD?
2. Do you know anyone who can create the CD for you since your PC seems to be kaput?
3. Are you familiar with going in to your computer's BIOS at boot up to change the order of boot up drive specifications?

I will try to help you out if I can. Let me know the parts of my last post that are cryptic to you and I will try and explain.

- Collapse -
Thanks a lot - this is the way to go!

I had a LaCie external network disk ( NAS ) - the controller and power source failed. Thanks to this tip I was able to restore the data!
1)I opened the LaCie case and connected the HDD to a usb SATA harddrive connector which is around 20€ in any computer shop
2) Booted the computer with bootable Ubuntu install on a USB Stick (Ubuntu can as well be installed on a USB stick - even easier than burning a CD. )
3) Plugged in the external USB SATA reader with the LaCie harddisk
4) Ubunto recognized teh drive instantly
5) Copying the data from the LaCie disk to another usb harddrive was super easy.

Dont be afraid of the Ubuntu Linux part of this fix - it is easy, friendly - and saves your day (and Data)

- Collapse -
This was rally the way to go.

I did have an issue with getting to the personel directories.

I found that if you go to Terminal application, then change directory to /media (cd /media) you can get to the main drectory. From there I was able to drill down and use the super user command to change the permission on the directory to be able to copy all my files. (sudo chmod 777 MyLibrary).

Hope this helps.

- Collapse -

This and the last post will come handy, bookmarked for future reference!

- Collapse -
You are a life saver

Songs should be written about you! Your birthday should be a national holiday!

I had the same problem as the OP and was at my wits end. Ubuntu saw the drive and its contents instantly and gave me no trouble moving things around.

I don't have to explain to my wife why all of our pictures, movies, etc are not available any more.

- Collapse -
Try the usual datarecovery programs.


Find them with google, and give them a (free) try. However, drives with more than 1 partition seem to be a problem sometimes.


- Collapse -
THANK you Kees Bakker!


WOW do I owe you a debt of gratitude. I was trying to move all my wife's photos off her enV3 to an SD card because her phone was full. After moving the photos, somehow the SD card got corrupted and windows would only view it as a RAW format volume, and the enV3 would not see the pictures anymore if I put the card back in. I tried BitPim, USB Storage Mode, everything. I knew the data was still there.

Tried Zero Assumption Recovery and BINGO. Everything was in one folder, so I didn't even need to buy it, but if I ever need this utility again, I will definitely buy it because it's worth the price for what it does!!

THANK YOU for your recommendation!!!

(I registered on CNet just to say thanks) Happy

- Collapse -
Two LaCie quadra dead the same day !

I have (had) two 2To LaCie big quadra.

One fine one of the LaCi'es goes toast (the Led turns red/blue). As I have only one power cable, I try the other one. Same problem. Furious (months and weeks of Adobe premier and After Effects not withstanding the huge amounts of souvenirs) lost, I contact LaCie.

They propose to repair them but all my files would be lost.

I contact the LaCie recovery center. They propose to repair for a down payment of 1000 x 2 euros for both (Both LaCie's were on Raid 0).

Hopes lost, I try all forums. Dead LaCies complaints are a profusion.

As advised, in this forum, I buy Icare recovery, connect one the LaCie to a PC via Sata connections.

ICare recovers some files but they are totally unexploitable.

Back to forums again.

I read an interesting thread on AnandTech.

The files are split between two disks when connected in Raid 0 as opposed to Raid 1 where each file is mirrored.

So even I recover files, they would be only part of a jigsaw puzzle.

On another forum, a guy proposes a script to connect files saved in Raid 0.

I give up.

Lessons learned

* if your file are in Raid 0, it is practically impossible to recover them (unless you pay the cost of a DSLR).
*do not be desperate like me, to buy any software that you might regret later.
*do not buy LaCie.


- Collapse -
How to fix?

In Reply to: Windows Skipped - SOLUTION FOUND - THANKS! by DeadLacie

Any way you can simplify this for us less computer savvy? I am not able to acess my windows at all- after attempting to scan and then restart, am now getting the "Disk read error, ctrl alt del to restart" and that just loops and loops-

Anything I can do to fix this?

- Collapse -
For now, find a friend that can read and use the above.

Not all of us are car techs or brain surgeons so when we are in over out heads we get more help.

I like the solutions above but when it's too deep, get others to read it and try.

Usually it only costs a pizza or two.

- Collapse -
You made it sound easy.

It's dated but you see why this advice is given.
Thanks again,

CNET Forums

Forum Info