Attention: The forums are currently placed on Read Only.

Thank you for visiting the CNET forums. Our site is currently undergoing some maintenance. During this period (6:30 AM to 8 PM PDT,) you can read the forums content, however posting in the forum will not be available. We apologize for this inconvenience. Click here to read details

Laptops forum

General discussion

A service installation section in the INF is invalid

by Richard N / June 15, 2007 11:13 PM PDT

My son has an iRiver H10 20GC MTP player. His laptop _(Dell Inspiron Windows XP home; SP2) has stopped recognising it; but my desktop recognises it fine.

In the Device manager on his laptop there is a yellow exclamation mark.
It has no drivers (code 28) and when I attempt to install them I get an error message:-

?A service installation section in the INF is invalid.?

I contacted iRiver who sent me Firmware and said that would sought out the problem; but it has not (nor did I think it would as the H10 workd fine on my desktop.

I then followed this thread from the Dell forum?.

Just a detection issue and your pc just needs to recognize it again ..... Like I said on your thread in the Dell forums:
Just wanted to make sure that you did the following steps:
Connect the 'bad' Ditty Open up Device Manager
Locate the 'bad' Ditty, right click and seled Properties On the Driver tab click on Update Driver
Depending on how many updates you have for Windows a message may appear saying to connect to Windows Update, select No, not at this time and click Next Choose the option for Install from a specific location (Advanced), click Next Choose the option to Don't search. I will choose the driver to install, click Next Click on Have Disk
Browse to: C:\WINDOWS\inf

Here I was able to browse to C:WINDOWS\inf but not within the folder so I could not execute the rest.

Click on wpdmtp
Click Open
Choose MTP Device Click on Next
It will install the necessary stuff and hopefully your Ditty will work ...

So I went on to do this ? but to no avail?.
Otherwise you can go into the registry:
From the Properties window of the 'bad' Ditty click on Details From the drop-down menu select Hardware ID's
Write down the first line which appears. Eg mine says:
USB\ Vid_041e&Pid_ 4132&Rev_0100
Remove the following: USB\Vid_ &Pid_ &Rev_ so your left with: 041e41320100
Open up your Registry (Start Run regedit)
Browse to: HKEY _LOCAL_MACHINE\SYSTEM\CurrentControISet\Contro I\UsbFlags\
Find the number that you have above, so I would be looking for 041e41320100 Delete this key, the whole folder.
Connect the 'bad' Ditty and see what happens.

The Device ?details? in Device Manager on both machines is ?

The driver on my GOOD desktop is wpdusb.sys

As a said, there is no driver on my son?s BAD laptop and whenever I attempt to install one using the Device Manager Troubleshooter I get the same?

?A service installation section in the INF is invalid.?

Please can you help?

With thanks and best wishes,


Discussion is locked
Collapse -
I could fix this problem
by tushar43 / June 20, 2007 5:00 AM PDT

I had similar problem while installing USB network device on my machine with windows XP. I was getting same error "a service installation section in this inf is invalid"

What i did was i opened the .inf driver file, went to "XP" section of the driver skipping 98,ME, 2000 portions and then saw a line "ServiceBinary = %12%\usb8023.sys" when i went to windows\system32\drivers folder, i saw that there was an existing file usb8023x.sys so i replaced the line in the .inf driver file which i had (of course backed up original one) and changed the line to usb8023x.sys from usb8023.sys and then tried providing the same driver again and Wooohaaa.. it worked. Right now my devices works awesome.

This is 100% working fix, let me know if it works for you which i am sure will.

Collapse -
woked for my issue - "service installation section invalid"
by destoo / July 1, 2007 10:38 AM PDT

Worked for me.
I'm using a "stripped to the bone" version of XP Pro, and it's been happening on my camera driver. (Kodak C633 Easyshare)
It was looking for usbscan.sys.
I had copied it to the /system32/ folder, but the %12% stands for /system32/drivers

worked like a charm. (for my problem. Thanks!)

Collapse -
Kodak Easyshare
by moon_angel6 / August 16, 2009 3:37 AM PDT


What exactly did you do to get your kodak easyshare to work? When I try and plug in my camera, it says ?A service installation section in the INF is invalid.?

Collapse -
How do I open the .inf file for the driver
by tstewar / January 28, 2008 2:48 AM PST

How do I open the .inf file for the driver?

Collapse -
Open .inf file
by onzey / February 2, 2008 6:04 AM PST

Right click on the file and then click Open.

Collapse -
A service installation section in the INF is invalid
by Richard N / February 15, 2008 10:49 PM PST
In reply to: Open .inf file

I first posted this problem in June; tried a few fixes but have been away from it for six months - apologies! My son's return home has reignited my interest (and exasperation!).

tushar43 seems to hold the solution but tushar you ar egoing to have to go more slowly for my non-agile mind.

I opened the foler Windows\inf - a "hidden folder" (yes?)

I could not see anything called .inf driver but there was

The PNF files ask for a programme to open then with; the other two open in the usual way (right click and then open from the drop-down menu).

In my windows\system\system32\drivers folder there is a file usb8023.sys AND usb8032.sys

However in neither drvindex nor drvmcdb could I see either or the entry "ServiceBinary - = %12%\usb8023.sys" which tushar43 referred to in his/her posting.

Am I doing somehting wrong??

Please advise; thanks in advane. Richard

Collapse -
by memoanal / May 10, 2008 1:55 AM PDT

i have a problem 2 with A service installation section in the INF is invalid...but now its worst cuz i dont know where the inf file is..and i cant reinstall the me plz

Collapse -
Check the contents on the .inf file...
by OSOD / September 8, 2010 8:15 PM PDT

I had a problem with a 2 RS232 PCMCIA card not installing - it used to install perfectly. It turned out the following line was wrong in the .inf file.

ServiceBinary = %12%\oxser.sys

The file this refers to was in capitals in the installation folder. I wouldn't have thought it would matter but I changed the file name and I'm back up and running the card.

Collapse -
This worked for me!
by GatesDA / June 9, 2008 1:03 PM PDT

Installing this framework worked for me. My 2GB Sansa Express worked fine out of the box, but randomly started giving me the same error. After installing this, not only did it work again, but it now shows up as a portable device instead of just a removable disk. Bonus!

Collapse -
Worked like a charm
by nanakeet / December 14, 2008 12:30 AM PST
In reply to: This worked for me!
Collapse -
Worked like a charm
by rolg / January 25, 2009 2:18 AM PST
In reply to: Worked like a charm

Thanks for the link Nanakeet! It was very useful. Both my Zen and Sansa MP3 players are now working perfectly. I appreciate you sharing your helpful information very much. Thank you! X

Collapse -
Samsung YP-K3 MTP
by IAMKLOOT76 / April 26, 2010 6:43 PM PDT
In reply to: Worked like a charm

I have just had this problem arise on the above player after upgrading PC and I followed your link and voila....perfect! Old post but wanted to express thanks. Happy

Collapse -
Great Help......
by smuppart / March 6, 2012 2:30 PM PST
In reply to: Worked like a charm

Hi Buddy,

Thank you very much for the link provided,
I was struggling with my new Sony Walkman not being detected in my XP,
after installing the same issue got solved!!!

Thanks once again:)

Collapse -
Thanks allot
by free2fall117 / June 29, 2012 3:01 AM PDT
In reply to: Worked like a charm

Just tried to connect my Samsung Galaxy S3 to my PC and was getting this error. After a bit of searching and getting more frustrated by the minute i found this thread.
Installed the framework and it now works fine! Happy

Thanks allot

Collapse -
Thankyou So Much
by kennjame622 / October 11, 2009 1:09 AM PDT
In reply to: This worked for me!

Thanks. I have a coby mp-863 4g and I could not get it to work. Their customer support had me on hold for over an hour just to speak to someone, and all they said was "Oh, Its defective, return it" which tells me they know absolutely nothing, because the problem was not with the player, it was with the computer. I spend over 4 hours on the computer before coming accross your solution that worked. Thanks, now I dont need to return it.

Collapse -
This REALLY works!!!
by abmx / August 1, 2010 11:26 AM PDT
In reply to: This worked for me!

If you have tried to connect your portable device and it has failed to install with the error: "A service installation section in the INF is invalid", just download and install this file, (which i did) and then re-connect your device. IF it stills fails, then go to Device Manager, select your device (which should have a yellow mark on it) and click on Update Driver, just follow the prompts and it will finally be recognized and correctly installed. It has worked for me. I have been trying to connect my Samsung Vibrant (Android phone from T-mobile) to my PC (windows xp sp3) to the Kies (Media sync software) and was always getting this error, now , after installing the mentioned file it works!!!
Here is the link again:

Good luck!!!!

Collapse -
(NT) Samsung Yp-
by cassiometro / February 7, 2011 7:45 AM PST
In reply to: This worked for me!
Collapse -
Samsung YP-P3
by cassiometro / February 7, 2011 7:47 AM PST
In reply to: Samsung Yp-

Been battling for ages on this problem. GatesDA solution works fine. Many thanks.

Collapse -
This worked for me!
by A-Bee-Jet / January 30, 2012 9:57 PM PST
In reply to: This worked for me!

I have been trying to find this solution for a long time now for my Samsung to work with Kies. But I have faced an issue while downloading the It has given me the following error:
"Wudf01000Set-up...Access Denied"..... Then give me another pop-up: "Wudf01000 installation did not complete."

Need to understand what to do to get the INF error resolved. I'm at my wits end!!!

I have Windows XP.

Collapse -
Re: inf error
by Kees_B Forum moderator / January 30, 2012 10:16 PM PST
In reply to: This worked for me!

There's no mention of any inf error in the message you give. It's not even clear access to what is denied?

Are you sure you're running this program as an administrator? And that you don't have any security software running that might interfere with changes in the registry?

By suggestion: try it in Safe Mode, logged in as a user that is administrator.


Collapse -
by prasannarathi / June 12, 2013 10:24 AM PDT
In reply to: This worked for me!

Follow the instructions on this link to get rid of wudf01000 error. Then go to Device Manager (Control panel - system) and right click to update the drive of the MTP. It will pick up automatically.

Link -


Collapse -
Not able to browse inside Windows\INF?
by divadrummer / July 5, 2008 10:38 AM PDT

If you were not able to browse files inside C:\Windows\inf, you may not have selected the right options in the Hardware Wizard... at least, that was my problem the first time I tried this.

After choosing to "Install from a specific location (advanced)", choose "Don't search. I will choose the driver to install".

On the following screen, click the "Have Disk" button. Browse to C:\Windows\inf and choose the file marked "wpdmtp.inf"

I can't believe the generic players have such crappy support when so many people have this problem! I think the Windows file problem might be caused by "compressing old files" when you do a disk cleanup.

Collapse -
Not able to browse inside Windows/INF
by Richard N / July 5, 2008 8:19 PM PDT

Many thanks for this divadrummer. In fact I inadvertently solved my problem when I did what iRiver told me not to - and loaded the up-to-date version of WMP. That presmuably did enter the appropriate file into the INF folder which made the driver happy once more.
As you say the support desk did not give good service. Those who replied seemed not to read my request for help carefully enough and the only response they seemed to have in their repertoire were "knee-jerks"; one size fits all, which may help the majority but but leaves the rarer specific probelm unsolved.
Good luck to the rest. RICHARD

Collapse -
Issue resolved by Divadrummer.
by 11Devesh_Singh11 / October 6, 2016 10:42 AM PDT

Thanks Diva drummer. The solution is the same but you explained it in a noob language understood by all.

Collapse -
Instant Fix with Microsoft UMDF File
by cnicole19 / January 20, 2009 2:19 PM PST

I just had this error and spent tons of time looking up how to fix it. Turns out I needed to install the UMDF file from Microsoft found here: That took about 10 seconds. Then, while the device is still plugged in, go to Device Manager and uninstall the device. Then unplug and replug, it installs correctly and you are good to go! Good luck!

Collapse -
usb and device manager ....
by Grandella / May 25, 2010 3:28 PM PDT

try to go to the same place and un-install the whole thing and restart . keep in mind after uninstalling you will probably have to re-install the software unless it is PnP (plug n play) for a usb device to operate it must first have a driver to start it...
Hope this works for you go back to device manager and also look in safely remove programs , by the way most thing in properties you can set for quick removal so if you forget to safely remove it won't crash your computer... GOOD LUCK!

Collapse -
service installation section in the INF is invalid...WORKS
by Elvistheblue / December 4, 2011 5:48 AM PST

This is quite an old thread, but i thought it deserved a bump to say that the resolutions found here really do work.

I had trouble getting my Samsung GS2 to connect to Kies, but following the instructions on this thread has resolved the issue. Thank you to all those that made a suggestion on this thread.

Collapse -
Tried everything in this thread, still won't work
by FrustratedWithMTP / August 26, 2012 12:17 AM PDT

I've been having this problem with my Samsung Galaxy S3 -- I simply cannot get it to connect properly to my PC laptop (running XP Professional SP3). Unfortunately, I've tried everything in this thread and still can't get it to work. I've installed the Samsung drivers and uninstalled them, installed Kies and uninstalled and reinstalled again, no luck. When I update the driver using the method in the original post and select wpdmtp.inf and click "Next" it just gives me another error message saying either "A service installation section in the INF is invalid" or it says "Cannot Start this Hardware
There was a problem installing this hardware: MTP Device
This device cannot start (Code 10)."

I downloaded and installed the Windows Framework that several users in this thread said would solve the problem, but that did nothing and I'm still unable to get it to connect. Occasionally I'll get it to almost work and after uninstalling/reinstalling the drivers it will say "Found New Hardware: SAMSUNG Mobile USB, SAMSUNG_Android etc etc, MTP" in the lower right hand corner of the screen and it will list a few different things it finds, meaning it's recognizing the phone, but then that's followed by "A problem occurred during hardware installation. Your new hardware might not work properly" and nothing works.

I can successfully connect it to a friend's Mac and a relative's desktop PC (also running XP Pro SP3) but not my laptop. I've spent hours trying to fix this to no avail and I'm about ready to throw both the laptop and the phone out the window. Can anyone help? Is there anything else I could do that I haven't already tried? If someone could help me find a solution it would be GREATLY appreciated!

Collapse -
Re: connect phone
by Kees_B Forum moderator / August 26, 2012 12:24 AM PDT

If it works with your relative's PC and not with yours, something is wrong with yours. The obvious candidates:
1. USB drivers
2. corrupted OS or malware
3. bad hardware

You didn't tell about #1, so I assume they are OK (meaning: your USB mouse, keyboard, printer, memory stick, scanner, external hard drive work).
That leaves #2 and #3. Now do a clean install of Windows XP (from the recovery media or partition), or from the XP and driver CD's and see if it works. If it still doesn't work, it's a hardware issue. If it works now, your problem is solved.


Collapse -
...problem installing this hardware: MTP Device - Resolved!
by phamdinhnguyen / November 29, 2012 8:35 AM PST

This thread may be old, but it absolutely solved my problem.
I got a brand new HTC Droid DNA yesterday. Love it!
I was trying to migrate stuff from my Windows XP hard drive into this HTC Droid DNA, and always got this same error.

Correction steps:
1) Downloaded:
2) Installed, rebooted the XP.
3) Connected the phone to the XP.
4) Opened the device manager, saw under "Portable Devices" an yellow exclamation mark on my phone device, which is HTC6435LVW.
5) Right mouse clicked on HTC6435LVW, then selected "Update Driver..."

Worked like a charm!
My HTC Droid DNA now is recognized instantly every time connected to the XP.
Files transfer is as easy as it's supposed to.
The VZW rep who was supposedly helping me got the entire scoop, so he can help others with this issue.

Thank you, GatesDA!

Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!