Speakeasy forum

General discussion

A question for our SE Linux mavens:

by Paul C / November 16, 2004 10:22 AM PST

I posted a couple things over at the Linux forum; they're here and here.

I covet any suggestions you might have...

Thanks!

Discussion is locked
You are posting a reply to: A question for our SE Linux mavens:
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: A question for our SE Linux mavens:
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: A question for our SE Linux mavens:
by David Evans / November 16, 2004 10:34 AM PST

This is the next distribution that I'll be installing:

http://pclinuxonline.com/pclos/index.html

I have one of the live-cds and it's really good. The last cd I downloaded has flash and java and all the codecs for multimedia stuff. I think Tex had to stop putting Flash in due to a licensing issue, and I'm way behind on the developers email so don't know how that was resolved.

PCLinuxOS started off as a fork from Mandrake, then developed into its own thing. I was going to wait until it hit 1.0 before installing but I might go ahead and install at 0.8.

DE

Collapse -
Re: A question for our SE Linux mavens:
by null. / November 16, 2004 10:36 AM PST

Mandrake 10 (community) is good - It's what I currently use.
I have used Fedora, in all flavors, I do not like it - I found it geared to the noobie (the one who just heard of linux) and as such the GUI is cumbersome for me. Try http://www.linuxiso.org/ for most distros available. It don't hurt to DL and BURN the ISO'S. Next for me to try is Slackware 10.

Don Erickson
California Republican and very proud of it!

Collapse -
Last time I tried Linux
by Dragon / November 16, 2004 11:33 AM PST

I had it one one part of the drive, with Win on the other. Somehow WIN knew Linux was there. I could tell when I was firing up WIN. It didnt look right, and it was acting funny. That was not supposed to happen.

Collapse -
Re: A question for our SE Linux mavens:
by Edward ODaniel / November 16, 2004 12:33 PM PST

Hello Paul,

Never tried a USB mouse on Linux but you might give this a try:
http://www.mandrakelinux.com/en/hard-details.php3?F_TYPE=mouse&F_ID=199

I assume you already Edited /etc/modules.conf as root and added the following line:

alias mouse usbmouse

Also check for these lines in /etc/X11/XF86Config-4

Section "InputDevice"
Identifier "Intelli Mouse"
Driver "mouse"
Option "AlwaysCore"
Option "CorePointer"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
EndSection

If that doesn't help try:

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "CorePointer"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

Later Distros supposedly fixed this little problem with USB mice.


Regarding Redhat vs. Mandrake, that is just something you have to experience on your own because it sort of gets into the Ford vs. Chevy vs. Mopar.

Collapse -
(NT) (NT) Get it working?
by Edward ODaniel / November 17, 2004 10:57 AM PST
Collapse -
Re: (NT) Get it working?
by Paul C / November 17, 2004 6:13 PM PST
In reply to: (NT) Get it working?

Not yet, as I can't open the files to edit them as per your suggestion without mouse support (or do you know a way to do that, too?). I'm guessing that a more up to date distribution's in order here, and will take care of that issue tonight...

Collapse -
Re: (NT) Get it working?
by Edward ODaniel / November 18, 2004 4:41 AM PST

su to root then use vi or nano or whatever text editor to edit /etc/X11/XF86Config-4 (once in the terminal the command would be vi /etc/X11/XF86Config-4

(If you don't have or have never used nano look it over here http://www.nano-editor.org/ -- really a simple to use text editor)


Alternatively, X comes with a keyboard mouse which is activated by pressing CTRL-SHIFT-NUMLOCK (allows keypad to emulate mouse actions):
<8>: moves mouse pointer upward
<4>: moves pointer to the left
<6>: moves pointer to the right
<2>: moves pointer downward
<5>: emulates pressing mouse button 1
<->: changes the emulated mouse button
<0>: enters 'click and hold' mode (e.g. for drag and drop)
<+>: emulates a double-click

Do be aware that this emulated movement is pretty slow, but you can increase its speed considerably by pressing any other key while moving. This takes some exercise, though... Note that this times out after a while, so you might have to press CTRL-SHIFT-NUMLOCK again to reactivate it.

Hope it helps.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

We are giving away 'Black Panther' swag!

Four lucky readers will be taking home *Marvel*ous "Black Panther" prizes, including magazines autographed by the King of Wakanda himself! Giveaway ends Feb. 25, 2018.