Windows Legacy OS forum

General discussion

98 Will not recognize second hard drive

by Rockit / July 15, 2005 2:08 AM PDT

I have two HD's. My boot drive is a 30G Maxtor. My second is a 120G WesternDigital used for storage. I had to re-format my boot drive. I disconnected my second drive, formatted the boot drive and re-installed Windows 98SE on it. After the installation,(and reconnecting the second drive) Windows will not recognize the second drive. The bios recognizes it. It is also listed in device manager but has no letter assigned to it and will not allow me to assign a letter. It is NOT listed in "My Computer" or "Windows Explorer". The second drive was originally formatted using four partitions of 30G each. I tried using DataLifeguard software from Western Digital, it recognizes the drive as a primary slave (which is how I have the jumpers placed) when I highlight the drive, it shows only two partitions instead of four. One of 30G and one of 90G. I can click on the 30G partition and see its properties. When I try to click on the 90G partition, I get a software runtime error and it immediately shuts down. My jumpers are correct. Anyone help will be very appreciated. There is alot of data on this drive that I need to get off.

Discussion is locked
You are posting a reply to: 98 Will not recognize second hard drive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: 98 Will not recognize second hard drive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Chances are...
by FrankQTran / July 15, 2005 12:59 PM PDT

your master boot record didn't has information on the seceond drive correctly. Try boot into C:\ (Safe Mode or thru bootable floppy) and at the prompt, type in:

FDISK /MBR then press ''ENTER''

Reboot your PC to see if the problem is fixed.

Good luck!

Collapse -
RE:Chances are...
by Rockit / July 15, 2005 11:32 PM PDT
In reply to: Chances are...

When booting up in safe mode. I do not get a prompt to type anything. Windows starts up.

Collapse -
Same prob!
by ramusson / July 15, 2005 6:52 PM PDT

I had the same problem a couple of times. I got a couple of solutions (may not be the right way...) that worked.

1) Re install the OS WITH the second HDD not disconnected. This is simple if you notice the problem right at the begining. Its a pain to redo this if you notice the problem AFTER installing the Programs, Upgrading, ....

2) This step has worked, dont ask how! Get a spare Hard Disk, (size does'nt matter!). Put it as a Slave, use FDisk and create a partition in it. Even 1 partition will do; partition size does'nt matter. If you make a Primary Partition, its ONE step. If Extended Partition, Two steps - 1 for the Extended Partition, second for the logical drive.


Shut down the system, put your original 2nd HDD. It should work. It did for me quite a few times.

Feed back requested.

Collapse -
more ideers...
by reefurbb / July 15, 2005 11:16 PM PDT

1. your original W98 install may have had all the chipset drivers and now you don't., get and use the chipid.exe small utility to determine the Intel chipset, then hunt same for chipset drivers, maybe video drivers in chipset, maybe USB drivers in chipset. I have seen a few W98 PC's that had part of the chipset drivers but not all, FX and HX for example.
2. For VIA chipset, go to their website, one general download for all VIA chipsets.
3. Search for SiS chipset drivers, after looking at chipset for numbers.
Caution!, some main chips may be under a pasted-on heatsink. You may have to determine motherboard, web site, and go there for drivers.
4. another clue is to look at Device Manager-Performance, to see if something is running with DOS drivers.
5. disconnect CDrom drive, make 120gb hdd a master and connect. If it works, use CD drive as a slave on primary IDE ribbon.

Collapse -
You expect Windows 98 to read Drive that large?
by Earth9111 / July 16, 2005 12:35 AM PDT

If you get it too work,lets us know how.W98 is not set up to read large drives as that.

Collapse -
Re: You expect Windows 98 to read Drive that large?
by Rockit / July 16, 2005 1:44 AM PDT

This 120G drive was already on this pc and worked well for a couple of years. Remember, I had it partitioned into four 30G drives.

Collapse -
Re: You expect Windows 98 to read Drive that large?
by Rockit / July 16, 2005 1:56 AM PDT

Of course, I should have realized. I have used Western Digitals data recovery software Data Lifeguard and it shows the drive now partitioned into only two drives. One at 30G and one at 90G. Obviously Windows 98 will not read the 90G drive. It should recognoze the 30G partition though.

Collapse -
Windows 98se limits are out at 127GB.
by R. Proffitt Forum moderator / July 16, 2005 2:11 AM PDT
Collapse -
What documentation tells you the jumpers are correct.
by R. Proffitt Forum moderator / July 16, 2005 12:42 AM PDT

For example, for years I've seen incorrect jumpers on the 80 conductor IDE cables. Too many times I'm moving the jumper from master/slave back to the proper CS or cable select. I can only guess this is a legacy issue from the bad old 40 conductor IDE cable days.


Another joy is the use of non-Microsoft partition tools. Such will result in your scenario and rarely can be recovered from since most owners forgot how they prepared the drives. My lesson here is to use FDISK only. FDISK is not hard to use and has the virtue of being compatible with the noted OS.


Collapse -
Re: What documentation tells you the jumpers are correct
by Rockit / July 16, 2005 1:52 AM PDT

I used these drives for years with its current jumper setting. The bios recognizes the two drives and with their correct disignation (master and slave). I have gone back and verified that the jumpers were set correct. I have switched to cable select and tried a variation of both. I got the jumper selection from and I verified the settings with my original documentation that was with the drive when I purchased it. I am familiar with jumper settings and have eliminated that as a possible problem. You are correct on the fdisk application and I do not remember if I used it or not. I think so, but can not be sure.

Collapse -
Don't let "it worked before" tank you.
by R. Proffitt Forum moderator / July 16, 2005 1:56 AM PDT

It's a common trap. Go with the right jumper settings for the cable type you use. Many fall for the trap "it worked this way for years." It's a lesson we all have to relearn.

-> My bet is on initial disk prep. An end run around the issue is to get a KNOPPIX boot CD and use that to scrape (copy) off the files you need to save.


Collapse -
by Rockit / July 16, 2005 7:17 AM PDT

I am going to try Linux.

Collapse -
Proffitt may be right...original install...
by reefurbb / July 17, 2005 1:10 AM PDT
In reply to: Re:

was from mfg floppy as few older PC mobo's could handle high GB hdd's. Mfg floppy puts an Ontrack or EZbios master boot record translator to make the hdd appear with different Cylinders-Sectors-Heads.
BUT those should have stayed on Hdd and it must be allowed to boot before using some other boot floppy.
If you used Fdisk/MBR, you may have wiped out the Translator.
A message appears for C: drive, only "press space bar to boot from floppy or other", and quickly disappears for automatic boot to C:

Collapse -
by stormfords / July 18, 2005 9:36 AM PDT

mate listen to this u can get a way better computer with ten time more hard drive space for like $1300 dont even bother with windows 98 go windows xp way faster trust me

Collapse -
re: reply
by Rockit / July 19, 2005 11:57 PM PDT
In reply to: reply

It's not the PC or the drive I want. It's the data on the drive I am trying to recover.

Collapse -
Tell how KNOPPIX sees the drive.
by R. Proffitt Forum moderator / July 20, 2005 12:56 AM PDT
In reply to: re: reply
Collapse -
Re: Tell how KNOPPIX sees the drive.
by Rockit / July 22, 2005 10:10 AM PDT

If it aint one thing, its another. Remember, I formatted my boot drive. Well,afterward, I did not have any CD burning software so I installed adaptec. WRONG, I forgot, adaptec will not recognize my burner. Ok, So I install Nero, (my old burner software) and download the KNOPPIX software and actually get it burned onto a CD. Now, when I try to boot from the CD rom it bypasses it and boots up windows from the IDE. I have changed my bios to boot up from the CD rom. That did not work, still boots up windoes from the C drive. Ok, so I disabled the number two and number three boot sources in the boot sequence. Now all I have is for it to boot from CD rom. It trys to, it says ''Loading boot sequence from cd rom''. but immediatley loads windows from the hard drive. Anyone. I'll get there, its just a matter of time.

Collapse -
Re: Tell how KNOPPIX sees the drive
by Rockit / July 22, 2005 1:12 PM PDT

Ok, I got knoppix to load up linux. It recognizes one of the partitions of my lost drive and allows me to access it, but not the second part. It only shows two partitions. Naturally, thats where most of the data is. When I try to access it, it gives me an error code.

Collapse -
1. Recover what you can from there.
by R. Proffitt Forum moderator / July 22, 2005 10:28 PM PDT
Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?