I am running Leopard 10.5.8 on a MBP