Laptops forum

General discussion

800mhz SODIMM DDR2 in Fujitsu Amilio Li 1718

by darrenforster99 / December 3, 2009 3:30 PM PST

I've got a little problem that I wonder if anyone can advise me on.

One of my friends has got a Fujitsu Amilio Li 1718 laptop, recently he noticed that the computer started to go really slow and his memory has gone down from 1Gb to 897Mb (???). At first I thought it was possibly the 128mb shared graphics, but in the BIOS you can increase the shared memory to 256mb and that doesn't make any difference in the amount of memory, so I presume some part of the memory has blown.

I have tried with CPU-Z by CPUID and that identifies that the memory is 1Gb but both BIOS and Windows Vista only show 897Mb.

Anyway we decided best solution is to upgrade the memory to 2Gb, he's running Vista Home Premium and 897Mb is barely enough to keep this system running.

I advised him to get two Corsair 800mhz 1Gb SODIMM DDR2 sticks. The current memory is one 1Gb 666Mhz stick.

After putting the two memory sticks into the computer and turning it on we got nothing but a blank screen. Put the old memory back in and it's fine, it still reports only 897Mb not 1Gb.

At first I thought it was possibly a BIOS issue so found an update, he was on Phoenix v1.7 and it's now updated to v1.9 but still nothing, the only thing this BIOS update claims to fix is the 897mb problem as apparently the computer reporting 897mb instead of 1Gb is known bug, however that didn't even fix that.

I notice on a few websites they mention all memory speeds up to 666mhz for this laptop but not 800mhz, but surely if the computer doesn't support 800mhz memory the memory will still run at 666mhz instead, on desktop computers this is normally the case, is this different in laptops?

I've also tried inserting the memory in one at a time and putting it in the different slots in case it's a defective slot or one of the memory modules is defective, but nothing, the memory does state on the back "Guaranteed compatibility"

Any help or advice to get this memory working would be greatly appreciated.

Discussion is locked
You are posting a reply to: 800mhz SODIMM DDR2 in Fujitsu Amilio Li 1718
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: 800mhz SODIMM DDR2 in Fujitsu Amilio Li 1718
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I'm going with no.
by R. Proffitt Forum moderator / December 3, 2009 9:40 PM PST

Don't over analyze this one.

Vista is already slow on 1GB so any small update to antivirus could cause it to go slower still. Think 3GB ram next time.

Walk away now while you can. This is one of those tar pit issues where you could lose far too much time over nothing but just too little RAM and "Vista".

Again, you can fret all you want over "where's the RAM" but Vista on this little ram will be a slug.
Bob

Collapse -
fixed...
by darrenforster99 / December 28, 2009 2:12 PM PST
In reply to: I'm going with no.

It's now fixed, turns out yes the laptop wouldn't take 800mhz memory, only 667mhz. Strange how it doesn't just slow the memory down to 667mhz though.

We took the 800mhz memory back to Scan computers in Bolton and they were really helpful about it, just changed it over straight away, and allowed us to use their testing area to install the new memory in and check it works, to save us another trip back out there.

The laptop is running super fast now.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?