Question

7-Zip Can not create temp folder archive

I bought a new Microsoft surface pro 3

It originally had windows 8 installed on it.

Whenever I tried to install certain plugins or programs from the internet, they did not work, and instead the errors always came with the message can not create temp folder archive etc. or something of the like.

I downloaded Window 10 because it looked comfortable. No change; none of the programs that I download from internet explorer, edge, or google chrome work. No plugins, and sometimes no important pop-ups either.

Another problem... which I have a feeling is related... I downloaded Microsoft office too. All of it worked except for Microsoft Word. Every time I try saving something, regardless of which button I press, there is absolutely no response and none of the files are saved... Horrible.

I looked into the internet for answers and there weren't that many. One video on youtube seemed to have a solution. However, I have no idea what the video means when it says to

User variables for {userName} and change the TEMP and TMP vars values to "c:/temp

or something like that...

I can't believe such fatal errors are happening even though my surface pro is brand new...

Please help me... these errors are seriously preventing me from doing my studies

Discussion is locked
Follow
Reply to: 7-Zip Can not create temp folder archive
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: 7-Zip Can not create temp folder archive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
This has been a problem for some since Windows 7

here is a forum where a fix was given:

http://www.sevenforums.com/general-discussion/161216-can-create-temp-folder-archive-any-exe-2.html

to solve this annoying problem, there are 2 ways

1. run it as administrator

if still not working, then try

1. right click on the file
2. properties
3. go on the compatibility header
4. click on run compatibility troubleshooter

when the troubleshooter opens

1. troubleshoot the program
2. only check the "i dont see my problem listed" box
3. click next
4. it will ask about the version of the windows, in which the particular program had worked before, AGAIN "i dont know"
5. click next
6. click on "test the program"
7. if it worked or not, click on next
if it had worked, click on "yes, save these settings for this program"
if it hadnt worked, click on "No, try using different settings" after that redo number 6 and 7 until it does!

- Collapse -
Does not help

Does not work at all.

Please help somebody ******* it ...

- Collapse -
Re: errors

Upgrading from a not fully functional Windows 8 system to Windows 10 can very well result in a not fully functioning Windows 10 system.

So I would either go back to factory conditions (the original Windows 8 it came with, using the recovery media) or try a fresh install of Windows 10 from the installation disk or stick you can make.

Kees

- Collapse -
Answer
OK, you wrote you changed temp to C:\temp

That may not be allowed today. But let's roll forward. Is there a C:\Temp?

As to your new PC. Back to Microsoft and ask them what's up. I've fixed this issue about a dozen times but there are 6 or more fixes. That could really upset folk that demand a fix. I can't know why it did it on your PC.

CNET Forums