General discussion

50+ Cookies?!

Is it really necessary to have over 50 cookies for cnet pages? In both firefox and chrome I signed out, erased all cookies, then signed in again and went to a single CNET page. Chrome ended up with 50 cookies and Firefox had 5 more. In addition, Firefox reports some cookies are requiring TLS handshake with encryption (which is probably what's slowing and messing up firefox connections to cnet up). The worst are the cookies starting with "fly_ " of which there's a number of them.

http://www.glenburniemd.net/CNET/CNET-cookies.png

http://www.glenburniemd.net/CNET/CNET_cookies_firefox.png

Discussion is locked
Follow
Reply to: 50+ Cookies?!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: 50+ Cookies?!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
(NT) Great question. Great research!
- Collapse -
I'd noticed something about cnet cookies

I'd seen a time when entering the forums was very slow and it was necessary to wait while other sites were accessed. I presume this was to load their cookies. I don't store but a few but I noticed that after accessing cnet the list grew very large. Now, I see only one cookie named cnet but it contains quite a few "sub-cookies. Perhaps the slowness of the site was resolved by delivering the cookies all at once in a package rather than one at a time.

- Collapse -
Odd things have been happening in CNET

I've tried a couple times to post a note about a former mod who died in June, and can't figure out WHAT won't allow it to post, instead get some notice about submitting later, and that happened in both Firefox and Chrome. I tried it in two forums also, the one he mod in and another. I've been able to make other posts though. Truly odd.

- Collapse -
I had a couple of "submit later" failures myself

but that's nothing new. I've often found that trying again results in duplicate posts so I give some time and post again if if I've not changed my mind. Another thing that's been happening is ads have been sneaking in even though I use adblock plus. I do have it set to allow non-intrusive ads such as animations and those that jump at you with loud and raucous music. The ads I've been seeing have been large banner types at the top that go fully across the screen and about 1/5th of the way down. If I reload the page, they might or might not go away. I do consider ads that take up that much real estate to be intrusive but it may be that they sneak in before adblock catches them. Of course the Amazon gift card survey hoax is back and I've noted it. It's appearances have been less frequent these last two days. Overall, I do think the forums have run OK for a long time. FF is also getting a lot of updates and that might be a factor. I've been trying Chrome in Linux and it does seem a lot faster with some web sites and it really helps with Google maps and Google Earth but Chrome isn't a browser I trust as much as I do FF. It's definitely tracking ones every move.

- Collapse -
Yup

Saw the same thing about 12 hrs ago.

Using FF 54

I could create a post and preview it but I would get a msg of a problem when I tried to submit the post.

Loaded FF with add-ons disabled, same thing.

Tried IE, same thing.

Waited 6-8 hrs, now all better.

Stuff happens.

- Collapse -
Came back

Sat 7-8-17 0830 edt.

Error trying to submit a post.

This time the fix was to delete the cnet cookies and sign in again.

Either that or it fixed itself at the same time I deleted the cookies.

With the iffy mail alerts and now this the forums are getting tough to use.

- Collapse -
Bob__B still happening for you?

Just wanted to check in to see if the Error message is still happening to you on FF as of today (7/10). Please let me know. Thank you!

- Collapse -
Just butting in before bed Lee.

I also cleared cache and local data in FF. Works fine now. That's FF with UO.
Dafydd.

- Collapse -
Thank you Dafydd for the update!

You can butt in anytime Happy

Have a good night and sleep tight! Thanks again Dafydd!

- Collapse -
Late to the party

With the wonky mail alert system I stumbled across your question by accident.

It now 7/23/17 and I have not seen the error submitting post in well over a week.

Whatever it was seems to be gone.

Is this mail alert system getting any closer to being looked at?

I'm lucky to get an alert for one out of five new post.

- Collapse -
Whaa? You don't like cookies?
Grin In all honesty James, I really have no idea why there are that many. Probably a lot are ad related and related to being logged in as a member. I'm curious if other sites have that many cookies too. When I have some spare time I'll check myself.

I'll mention this to our product managers about this.

Thank you!
-Lee
- Collapse -
I've just been trying to....

....troubleshoot why there's these odd interferences going on with CNET forums. I wanted to post about Steve Kayless passing, but got the "submit later" from both FF and Chrome, even after resetting the page in two different forums. That one happened also using Chrome.

- Collapse -
I'm looking into this as I had a few errors as well

I tried submitting a few test post and ran into this error. I finally had to clear my cache in Chrome to get it working again. Not sure what's going on. Hitting up some folks to see if there is a problem with logged in members.

- Collapse -
Getting this in Chrome.

Trying Edge out now. Worked but slow.
Dafydd.
Trying Firefox now.
OK. That worked.

Post was last edited on July 7, 2017 3:24 PM PDT

- Collapse -
Thanks for checking Dafydd...

Can you try clearing your cache in Chrome to see if that works? I had to do that for it to work. Not sure what it is.

Thanks!

- Collapse -
Did that Lee.

No change. Using FF to reply.
Dafydd.
Just tried Chrome again Lee. Same result.

Post was last edited on July 7, 2017 4:41 PM PDT

- Collapse -
Re: issues

Deleting a post failed to delete it (error while deleting, usually given if it was deleted already, but it wasn't) and editing a post gave a 404 not found error. I went on to do something else and half an hour later it worked . Clarly server issues, and I doubt they have nothing to do with the browser cache or cookies.
And now posting this post givers 'sorry, there was a problem, try again later" message. I'll repeat what worked a few hours ago. Copy/paste the text into Notepad, save it, then cancel this post, hibernate, go away and try again in hour after restarting Firefox. If that works, you can read this.

Let the techs have a look at various loggings to see if they can find a cause.

- Collapse -
Just replying using Chrome Kees.

And it works now it seems. Maybe it's intermittent though.
Dafydd.

- Collapse -
Is this still an intermittent issue, Kees or Dafydd?

The delete, posting a reply and getting that error message are most likely all related. Trying to reproduce it and it not reproducible for me.

Bob is having the problem as well and it is intermittent which makes this bug difficult to track down. Filed a ticket for it to have some investigate it. Thank you all.

- Collapse -
Seems like it Lee.

I just tried to reply using chrome and it failed. Using Edge now.
Dafydd.

- Collapse -
ughh. OK thanks Dafydd

Ticket has been filed already for our folks to look into it.

- Collapse -
I'm finding that I need 3 browsers to keep going.

1. Firefox with or without UO.
2. Chrome (no addons.)
3. Opera and it's Toronto VPN enabled. (had to use this to post this reply.)

- Collapse -
its been a couple of weeks

its been a couple of weeks since I received that submit error message. usually I just resubmit and the post goes through. just figured the forum was busy so really never gave it a second thought. I think I was using the firefox browser. I switch between it and chrome so am not 100 percent sure. both browsers are set to delete history and cookies at close.

- Collapse -
Also should mention this
- Collapse -
defined better
- Collapse -
While the generic 404 page displays the same...

there will be different errors on the backend. Anytime a page fails to load, it will use that generic CNET 404 page. Hope this makes sense.

- Collapse -
someone fixed it before you saw it

As late as yesterday, there was the same large black image superimposed over the generic 404 page when attempting to view a profile that was an error page. If you see my screen captures in other post, you can see what I was seeing till today. It's gone now.

- Collapse -
Is this it? (picture only.)
- Collapse -
That's It!

Where did you see it? From profile section, or a forum?

- Collapse -
Your link above

Firefox with Ublock Origin enabled.

CNET Forums