Samsung forum

General discussion

3D blu-ray startup problems after firmware upgrade

by calmbeach / February 15, 2011 4:18 PM PST

Hi! We have a Samsung 3D-television model LE46C755R2WXXE and a 3D blu-ray player, model BD-C5900. After upgrading both to the latest firmware versions, the 3D-functionality seems to be more or less broken.

New firmware versions:
BD-C5900: 1009.1
LE46C755: 3007.1

Most of the time, when inserting a 3D blu-ray disc into the player, the disc starts with what looks like very fine garbled noise (snowfall-type). The 3D-logo is displayed for a couple of seconds on top of this noise, in the lower left corner of the TV-screen. There is no picture and no sound after that. This leads me to think the problem might have something to do with HDCP(?)

Before the firmware "upgrade" the TV and player started 3D blu-ray discs without any problems at all.

We have tried to unplug everything, reset everything, but the problem remains. We have several 3D blu-ray discs. About 80 percent of the time the system fails to start any of them. This means that playing a 3D movie has become a struggle. You have to insert a disc, wait for the "noise", then eject the disc, restart the TV and player, and try everything over again until the movie finally displays correctly. There appears to be no such problem with ordinary "2D" blu-ray discs.

Is there any way of downgrading the firmwares to the previous versions? I still have the previous firmware files, but the TV and the player refuses to accept them, saying that I already have the latest firmwares.

Additionally to the above mentioned problem, the "Motion Plus"-feature of the TV now seems to result in noticeably more judder as compared with the previous firmware version, when viewing a PAL 576i-signal through HDMI from a digital cable settop box.

Discussion is locked
You are posting a reply to: 3D blu-ray startup problems after firmware upgrade
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: 3D blu-ray startup problems after firmware upgrade
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Update: New highspeed HDMI 1.4 cable solved the problem
by calmbeach / February 17, 2011 8:27 PM PST

I yesterday decided to exchange my HDMI-cable, which was supplied by the store I bought the TV and player from. The results were very good indeed, it seems.

I did not pay any attention to the HDMI-cable before, as I presumed the store had sold me an appropriate cable for the expensive 3D-equipment I had purchased. But it now seems that the old two meter long cable for 25 euros was neither "highspeed", nor HDMI 1.4-compatible.

Yesterday I bought a certified highspeed HDMI 1.4-compatible cable for 55 euros, one meter long. Since then we have experienced no problems at all. I have tried to reproduce the previous problems with this new cable, without any success - luckily.

So it seems the quality of the HDMI-cable does matter. The firmware upgrade in some way (coincidence or not?) brought this to our attention.

Collapse -
Update: New highspeed HDMI 1.4 cable solved the problem
by Samsung_HD_Tech Samsung staff / February 24, 2011 12:28 PM PST

calmbeach,

I'm sorry to hear that you're having these issues with the television. However I'm glad to hear that you're able to figure out the problem.

There seems to be a consensus on the Internet in several forums that I visit every now and then that suggest that either the cable will work, or won't work. There are not very many instances where people observe that it works poorly or sometimes with odd results. Nevertheless, I'm glad to hear that your system is working correctly now. Thanks for posting back with your results.

Best,

--HDTech

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?