Solution to Problem 1:
I reinstalled Windows XP using my Restore CD that came with the laptop. Then I updated all my antivirus and malware software. I am going to check out WinTasks 5 Pro, which I heard is very good at removing malware and is easy to use.

Solution to Problem 2:
The culprit was the keyboard setting, which had been set to "English(United States-International)". I went to Control Panel, clicked on Regional Options, checked the Input Locales tab, then set "English(United States)" as my default keyboard layout. No more problem with quotation marks and apostrophes.