General discussion

1990 Jeep Cherokee no running lights and no dash lights.

I have no power going to my rear running lights and no power to my dash lights. I believe there is no power to the radio either. But I've replaced the ignition switch and tried to follow the wires for the lights but it is a cluster. Please if anyone has any suggestions it would be great appreciated! Thanks

Discussion is locked
Follow
Reply to: 1990 Jeep Cherokee no running lights and no dash lights.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: 1990 Jeep Cherokee no running lights and no dash lights.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
1990 Jeep Cherokee no running lights and no dash lights.

wow where to star. i just went through the same problem when i bought my cherokee. easiest one to start of course is the fuses. if its not those check the (headlamp relay) dunno if thats what its actually called but stock it should be blue. just follow the wires from the headlamp switch and youll find it. if all else fails check for melted/grounding wires. hope it helps

- Collapse -
1990 Cherokee interior and dash lights not working

I had the exact same issue as well, I had to take out the whole dash and go threw the whole wire harness from the fuse box throughout the whole dash and also threw the fire wall. I checked the fuses first and of course they were blown, then they still didn't work, when I was in the wiring harness I found 7 wires melted together and had to replace them all. After I did that they seemed to work just fine. I do still have one issue and that's that when you turn on the headlights the interior lights shut off regardless of the door being open. I still have not figured this one out yet. All wires are fine and fuses, I don't know what else to check. Hope I helped a little.

- Collapse -
headlight switch

try the headlight switch i had the exact same problem and it solved most of mine

- Collapse -
Found a fix for similar problem

I had the same problem! Bought brand new fuses and replaced everything, still no lights. Replaced the light switch and still nothing! It turned out to be a bad connection between the fuse and fuse box. The two tabs that hold the fuse in place were too far appart, pushing them together with a flat head fixed the problem!

CNET Forums