It stumped me too. Turned out the router was out past channel 11 on WIFI. Setting the region in the router to USA helped it be in the channels the laptop could use.
Bob