CNET también está disponible en español.

Ir a español

Don't show this again

Christmas Gift Guide
Computers

Finder: Copying a folder not copying contents?

Some users are experiencing an issue with Finder where copying an existing folder to an external flash drive formatted for FAT does not copy the contents of the original folder.

Some users are experiencing an issue with Finder where copying an existing folder to an external flash drive formatted for FAT does not copy the contents of the original folder. When reformatting the flash drive for Mac OS, the files copy fine, but when reformatted back to FAT, it again fails.

Apple Support Discussions user "mwfanelli" reports:

When I copy a folder from one location to another, the folder is always empty! If I go into that folder on the main drive and copy each file manually, the files copy fine. The subfolders however are now empty.

The files are there on the main drive, I can see them and use them. The files I am copying to are on an external USB flash drive formatted to FAT for back and forth use on Macs and PCs.

Nope, it's not the drives as I've tried both of my SanDisks and the one PNY. All have the same result. I tried reformatting one of the drives, did a repair, verify, etc. No errors are shown. Oddly enough, all three copy fine on my Windows XP box. That's unusual as Windows tends to be much pickier with these flash drives than the Macs.

The issue seems to be related to folders that were originally on the FAT-formatted flash drive, copied to the Mac, and then moved back to the flash drive. When tested with folders that were originated on the Mac, the problem did not occur and the contents of the folder copied just fine.

Attempts to repair permissions on the Mac and the flash drive proved to be fruitless. ASD user "V.K." offers this suggestion:

there were a number of posts here by people having problems copying back and force to and from FAT drives. those problems seem to have been caused by split resource forks. but this folder [mwfanelli's folder] has no split resource forks at all. and neither does the subfolder.

the only other thing I would try is deleting .DS_store files. close all those folders and run:

find /Users/mwfanelli/Documents/Teaching/2009\ Cecil -name .DS_Store -exec rm '{}' \;
then try copying the folder again. see if it copies now.


Be sure to check us out on Twitter and the CNET Mac forums.
Do you have questions, issues, or stories you would like to see on MacFixIt? Email Us.