CNET también está disponible en español.

Ir a español

Don't show this again

Tech Industry

CA updates Y2K tool

Computer Associates' new CA-Impact/2000 version pinpoints mainframe software that is not Year 2000-compliant.

Computer Associates International (CA) has developed a new version of a tool for pinpointing mainframe software that is not Year 2000-compliant.

The tool, CA-Impact/2000, works with COBOL, assembly language, Fortran, PL/1, and popular fourth-generation (4GL) languages, CA said.

According to the company, the tool can scan single, multiple, and entire libraries of code in a single execution, and builds a database of code that contains date-sensitive fields. Programmers then can generate reports from the database to find out where their program needs to be changed.

The tool links to use other tools, such as code generators and analysis tools, for changing and generating new code.

The Year 2000 problem, also known as the "millennium bug," arises because many computer programs record dates using only the last two digits of the year. Such programs could treat the year 2000 as the year 1900, causing miscalculations, unexpected errors, or complete system crashes.

The consequences of the Year 2000 problem have been widely debated. Some experts believe the impact will be minimal, since most sensitive systems will be repaired long before the turn of the century. Others say the problem could spark severe economic disruption if institutions such as banks, utilities, and hospitals fail to convert computers in time.

Fear of widespread problems has led many companies to institute Year 2000 programs intended to weed out troublesome code. Those programs have led to a boom in both software such as CA's tool and consulting services that retool existing systems to be Year 2000-complaint.

CA-Impact/2000 runs on mainframe operating systems, including MVS and VSE. The tool is priced at $31,920.