CNET también está disponible en español.

Ir a español

Don't show this again

Security

AMD issues chip patches for Spectre flaw

The chipmaker releases microcode updates to contain a variant of Spectre. Also, Microsoft is releasing an update for Windows 10.

security-privacy-hackers-locks-key-6780

James Martin/CNET

Chipmaker AMD issued updates Tuesday to combat a variant of the Spectre flaw, which makes computer processors vulnerable to attacks that could reveal sensitive information like passwords.

For Microsoft Windows users, AMD said a combination of processor microcode updates and a fully up-to-date version of the operating system would mitigate Variant 2 of the Spectre flaw.

Microsoft is releasing an update Tuesday for AMD users running Windows 10. AMD has also released microcode updates for its chips "dating back to the first 'Bulldozer' core products introduced in 2011," the company said. Customers can install the microcode by downloading BIOS updates from PC and server makers.

In January, researchers revealed they'd found two variants of Spectre, along with another flaw called Meltdown, affecting hundreds of millions of chips powering computers and phones. Processors from Intel, Arm and AMD are susceptible to Spectre, but only Intel chips are affected by Meltdown.

"While we believe it is difficult to exploit Variant 2 on AMD processors, we actively worked with our customers and partners to deploy the above described combination of operating system patches and microcode updates for AMD processors to further mitigate the risk," Mark Papermaster, chief technology officer, said in a post.

As for the threat from Spectre Variant 1, AMD said in January that it could be contained with operating system patches, which were made available earlier. 

Intel and Microsoft had patches for Spectre out in January but put a halt to some of them because they were causing devices to malfunction. In March, Intel said it'd released microcode updates for "100 percent of Intel products launched in the past five years" that needed protection.