CNET también está disponible en español.

Ir a español

Don't show this again

Computers

AirPort 3.4.x: success with 3.4.1; problems; confirming update; more

AirPort 3.4.x: success with 3.4.1; problems; confirming update; more

Over the past week we've been covering issues with Apple's AirPort 3.4 software. We noted yesterday that many of these problems appear to have been resolved with the release of AirPort 3.4.1. For example, James Furlong writes:

"I...had troubles with my Airport Extreme. But the combination of the new 3.4.1 release yesterday and resetting the Base Station seems to have worked. Also found that when I opened the Airport Utility, that there was a Base Station update available that you apparently don't have access to unless you run this utility. I never saw it on Software Update or VersionTracker." [James is most likely referring to the Base Station Firmware Update 5.4. -Ed]

Similarly, J. Novack writes, "Airport 3.4.1 did it for me. The signal reception on my PBG4 17" is back at least to where it once was...maybe a tad better."

Problems not fixed Although it appears that AirPort 3.4.1 was a welcome "fix" for most users experiencing problems, as we noted yesterday not everyone has had the same luck. MacFixIt reader Rory Choudhuri writes:

"Just to confirm that I'm one of the unlucky ones. On my 15" 1.25GHz Aluminium PowerBook, applying the 3.4.1 update has caused the problems I was hearing other people complain about with the 3.4 update. With the 3.4 update, I had noticed that the number of bars in the Airport menu bar icon had reduced, but my area of coverage remained the same. However, with the 3.4.1 update, Airport is unable to maintain a connection for more than a few minutes and, most of the time, loses the connection within 10-30 seconds."

Confirming update was applied Yesterday we noted complaints from readers that after applying the 3.4.1 update, the AirPort Admin utility reports the software version as 3.4, making it difficult to determine if the update was successfully applied. Reader Barry Porter notes that System Profiler provides the correct version number:

    AirPort Card Information:
      Wireless Card Type: AirPort Extreme
      Wireless Card Locale: USA
      Wireless Card Firmware Version: 3.4.1 (3.50.37.p4)
      Current Wireless Network: ***(deleted)***
      Wireless Channel: 10

Wake from sleep issues Last we we covered reports on an issue where, after installing AirPort 3.4, PowerBooks would be unable to reconnect to an AirPort network after waking from sleep. It appears from some reader reports that the 3.4.1 update may not fix this problem. Reader Norm Cohen writes that his experiences with this issue are limited to WPA encryption and AirPort Extreme cards:

"[OS 10.3.3, Airport 3.4.1, Pismo with standard AirPort, PowerBook G4 800 with standard AirPort, iBook G4 with AirPort Extreme. Router: Negear 614v4 firmware v4.04]

"Using Shared Key WPA, the iBook would fail to reconnect to the router after waking from sleep. Manual reconnection would result in an error dialog. The only way to reconnect was to go to the Web-based router configuration page and reapply the wireless settings. This forces a router wireless initialization. The iBook would reconnect until the next sleep cycle. The other two computers reconnected after sleep/reboot without problems.

In looking at system.log in Console.app, the iBook would continuously report a Link Up message immediately followed by a Link Down message, demonstrating repeated attempts to reconnect to the router after a sleep state.

"I went back to WEP security on the Netgear router and now the iBook reconnects after sleep without any problems. Given that the issue is only with the AirPort Extreme-equipped computer, I would guess (but can't prove) that Apple still has a problem with the AirPort 3.4.1 software update."

5.4 Firmware problems We haven't received many reports of problems with Apple's recently released AirPort Firmware 5.4. However, reader Harald Striepe reports a problem traced to the update:

"AirPort Firmware 5.4 disabled network printing to Canon i9100 by throttling print speed to a stall. Printing from Windows via TCP Port/Jet Direct continued to work great. [Reverting to] Firmware 5.3 fixed the problem."

AirPort update feedback? Drop us an email at Late-breakers@macfixit.com.

Resources
  • Late-breakers@macfixit.com
  • More from Late-Breakers