Macs at times showing static after display sleep

After waking displays that have gone to sleep, some Mac systems are showing a static output to the display.

A small but ongoing issue that some Mac users have experienced (1,2) is a problem where upon waking displays from sleep, the system will display a fuzzy snow output to the monitor. This seems to happen predominantly on Mac Pro systems, but has also happened on others such as Mac Mini and iMac systems, though on the iMacs it only happens if a secondary monitor is being used. This problem appears to be an issue with the use of display adapters, and specifically those for converting DisplayPort to DVI connections.

The issue is not related to any particular hardware, since the problem happens on systems with Nvidia and ATI GPUs, as well as on those where people have upgraded their GPUs after purchase. It also has happened on multiple installations of OS X, and has persisted for people who have experienced the problem in OS X 10.5 and then upgraded to OS X 10.6.

This suggests the issue is not associated with any particular hardware component or system configuration, and is likely in either an unchanged implementation in how Apple's drivers handle video output, or in a fault with an adapter (though while Apple's mini-DisplayPort adaptor has been the most prominently used one, others have also shown this behavior).

The problem only seems to happens after waking the display from sleep, and as a result could be an issue with how monitor color calibrations are applied or reset when the display activates and is recognized by the system. As a result, if you are experiencing this problem, try calibrating your monitor or otherwise changing the monitor's colorsync profile. Another potential fix may be to change the adapter you are using. If your monitor supports a different input such as HDMI or VGA in addition to DVI, you might try an adapter that converts to those connections instead of a DVI connection, if that will not affect your computing requirements.

Ultimately this issue is not a severe problem, but it is annoying. If it happens you can try a couple of things to correct the problem and prevent it from happening. The first is to force the display to go to sleep again by pressing the control and shift keys on the keyboard following by pressing the eject key, and then wake it up and hope the snow output has disappeared. Alternatively you can try power-cycling the monitor by turning it off and optionally unplugging it, and then turning it back on.

A workaround that does seem to prevent this problem from occuring is to enable the system's screensaver so it activates a few minutes before the screen is set to go to sleep. Go to the Energy Saver system preferences and see when you have the display set to go to sleep (do this for all available power modes and choose the shortest time). Then go to the screensaver settings and ensure that the screensaver is set to start before the display is set to go to sleep.



Questions? Comments? Have a fix? Post them below or e-mail us!
Be sure to check us out on Twitter and the CNET Mac forums.

Featured Video
Close
Drag