Make old add-ons work in Firefox beta

There's a trick to make add-ons work in the beta version of Firefox, but be prepared for the consequences.

The cool thing about trying out a Firefox beta is you get all those neat new features before everyone else does. But the bad is that none of your add-ons work anymore.

Thanks to garysimmons on Twitter who pointed to a Lifehacker article from the awesome Gina Trapani on how to force your old add-ons to work in the beta version of Firefox.

Big warning! You're removing a safety net when you do this. Be prepared to deal with bugs, crashes, and security risks if you do this.

OK. Here's how to do it .

Go to the Firefox address bar and type about:config.

Click the button promising to be careful.

You're promising to be careful...RIGHT?

Right-click anywhere on the screen, choose new, then Boolean.

Name your new preference extensions.checkCompatibility. Press OK. Then set it to false and press OK again.

Now right-click again anywhere choose New and Boolean and make the name of this one extensions.checkUpdateSecurity and set the value of that one to false.

Great! You've just instructed Firefox not to check the validity of the extension and to tell update security to go take a flying leap.

If you're sure you want to do that, restart Firefox.

Now all your add-ons should load quite nicely. At least if they don't crash the whole browser. Don't forget you turned off the capability to ensure secure updates. So do be careful.

One last tip, several people wrote to me about the Add-on called Nightly Tester Tools. It allows you to use otherwise incompatible add-ons in beta versions, although it doesn't seem to get Firefox 2 add-ons to work in Firefox 3.

 

Join the discussion

Conversation powered by Livefyre

Don't Miss
Hot Products
Trending on CNET

HOT ON CNET

Find Your Tech Type

Take our tech personality quiz and enter for a chance to win* high-tech specs!