IPSEC being disabled seems "odd" to me, but SP2 isn't known for this.

Since you have been altering the default services you need to move back to stock. I don't want to list what you need. Use Black Viper's web site to go back.

Doug Knox has written about this issue in 2003, but the article is being elusive. For now, move back to stock settings.

Bob