Samsung forum

General discussion

wis09abgn not working with WPA2

by miguellspinheiro / April 21, 2010 9:29 AM PDT

Hi all,

I have an LED TV UN40B7000 with an WIS09ABGN wireless adapter.
I have an DLINK DI-524 wireless router configured in G Mode and working now at 54 Mbps.
Both are configured with the last firmware (from Brazil support sites).

The problem is:
if I put both TV and router to use WEP, everything is OK and my TV works fine on @internet.
if I put both the router to use WPA2 (using WPA2 pre shared key and AES), the TV cannot connect.
The log on router shows the same error during one or two minutes. The log entries look like this:
Sunday April 18, 2010 12:43:31 Associated: 00-12-FB-2E-6F-44 st=0
Sunday April 18, 2010 12:43:35 Disassociated: 00-12-FB-2E-6F-44 because WPA retry failed 4

My notebook works fine using WPA2 with that wireless router.
yet, Here is some information about the router:
Beacon Interval 100 (msec, range: 1~65535, default: 100)
RTS Threshold 2432 (range: 256~2432, default: 2432)
Fragmentation 2346 (range: 256~2346, default: 2346, even number only)
DTIM Interval 3 (range: 1~255, default: 3)
Wireless Mode G (11 b/g Mixed G mode 11n mode 11 b/g/n Mixed)
TX Rates Auto (Mbps)
SSID broadcast Enable

Anyway, Is it possible to use WPA2? where I am wrong?

Post a reply
Discussion is locked
You are posting a reply to: wis09abgn not working with WPA2
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: wis09abgn not working with WPA2
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
wis09abgn not working with WPA2
by Samsung_HD_Tech Samsung staff / April 21, 2010 11:51 AM PDT

miguellspinheiro,

Under the "Network Connection - Wireless", it should list out which options are available. The U.S. model has this listed on P. 32, and depending on the mode of your router, may accept certain versions of WPA2.

For the U.S. model, it says that WPA2+PSK is an accepted authentication mode, but then requires an encryption type of WEP, TKIP, or AES.

--HDTech

Collapse -
wis09abgn not working with WPA2
by miguellspinheiro / April 22, 2010 3:37 AM PDT

Hi HDTech,

I am using WPA2PSK in the router.
*** The TV manual says "Authentication Mode : OPEN, SHARED, WPAPSK, WPA2PSK".
I am using AES in the router
*** The manual says "Encryption Type : WEP, TKIP, AES".

I can choose these options on router, but the LED TV only asks for the security key when I select the network name (SSID) on menu.

Is there a way to do some troubleshooting the wireless TV?
Is there a way to get the log on TV?

I don?t have another TV, but I have a notebook. Should I try the WIS09ABGN with my notebook?

-miguellspinheiro

Collapse -
wis09abgn not working with WPA2
by Samsung_HD_Tech Samsung staff / April 22, 2010 1:47 PM PDT

miguellspinheiro,

Are you able to input the security code? The code would be set on the router.

--HDTech

Collapse -
wis09abgn not working with WPA2
by miguellspinheiro / April 23, 2010 2:48 AM PDT

HDtech,

I am an IT guy like you.

I can input on TV the same the security code I have put on router.

In the router side, everything is ok: my notebook works fine with that router and the configuration I made.

This is why I am asking you about trobleshoting the TV (how to see logs and so on,..) Or how to try the WIS09ABGN in my notebook.

If I choose WEP, in both router and TV, the wireless network works. But I want to use WPA2 (for security reasons, of course).

What is the next step?

Collapse -
wis09abgn not working with WPA2
by Samsung_HD_Tech Samsung staff / April 23, 2010 2:16 PM PDT

miguellspinheiro,

I don't know of any way to test this. The issue could be anywhere - the router, LinkStick or television. I'd have to work with all three to be able to even diagnose it. Least likely would be the TV, as I'd be more likely to lean towards a network issue between the LinkStick not working, or being compatible with the router.

I have seen that some people who have Apple Airport Routers also initially have trouble connecting with WPA2, but a call to the router company can often resolve this through settings.

--HDTech

Collapse -
Same problem
by icpcruz / January 3, 2011 7:07 AM PST

Hi Miguel

I have exactly the same problem (55" instead only) but I am more unfortunate, 1st for not being an IT guru..., but even more because not even WEP or "unsecured" setups work for me: the same associated-disassociated "WPA retry failed 4" message keeps popping up at the log register of the router.

Have you suceeded on finding your way around it, please?

Thanks in advance, Ivan

Collapse -
(NT) Not yet, but I am trying a
by miguellspinheiro / January 8, 2011 11:42 PM PST
In reply to: Same problem
Collapse -
Not yet, but I am trying again
by miguellspinheiro / January 8, 2011 11:57 PM PST
In reply to: Same problem

I am sure now that the driver with comes with Samsung tv is outdated or was not prepared to work with WPA2.

I used the last firmware released by Samsung (Brazilian firmware, UN40B7000, October-2010) with no success.

I was able to use the same wis09abgn adapter with my Windows XP computer. With the windows driver, I can access my wireless router without modifications, I mean, WPA2 security!

Now, I am going to search to a replacement for the driver released by Samsumg.

Collapse -
Some news that may lighten a solution
by icpcruz / January 11, 2011 6:03 AM PST

An interesting finding: the TV is able to locate and see my PC connected (by cable) to the router as an DLNA client / network and I can see photos, videos or listen music that are in my PC (even without "SAMSUNG PC Share Manager" software)! This means the TV finds its way around the router and get included in the local net. Only when I ask for internet connection things go badly...

Collapse -
A possible solution
by al_mon / March 2, 2011 6:08 PM PST
In reply to: Same problem

Here is how it worked for me. Same LinkStick adaptor, UA37C5000 TV. ADSL router Dynalink
Firmware: 3.64y
ADSL2+ : A2pB025c.d20h
Wireless : 3.131.35.6

On your TV go to Settings -> Network -> Network Setup
Scan for networks, down below in the list of found networks you can add a network manually.
Type in your SSID and pick your security setings combination, mine was WPA2PSK/AES.
Type in your key.
Click on Done.
Check if TV is happy by going to Network -> Network Test

Aparently TV driver cannot autoselec the right security method.
HTH

Collapse -
Same problem
by fdg71 / November 29, 2011 9:22 AM PST
In reply to: A possible solution

I have the exact same problem, my tv is a ue40d6000 i think, it works fine if i am on wep encryption, but i bought a linksys n router to allow higher streams, and draft n speed will only work on wpa encryption not wep, i tried manual config using network setup, add manually and selecting wpa2psk/aes + correct key but no can do. Same setup works fine on the laptop and phone, just not on the samsung tv...a nightmare. Anyone found a way around this yet?

Collapse -
And in the past few days, folk reveal
by R. Proffitt Forum moderator / November 29, 2011 9:28 AM PST
In reply to: Same problem

They put an equal sign in the WPA2 password. Something I never thought to put in there. I'm a little old fashioned and stick with a to z and 0 to 9.
Bob

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech Tip

Stuck without Internet and want to watch movies?

CNET shows you how to download movies and TV shows onto your device using Amazon Prime so you'll always be entertained.