Networking & Wireless forum


Wireless Repeater Help

by CiviCity / August 10, 2012 1:30 AM PDT

Hey guys,

I have bought a Winstar WN518N2 Wireless N Wi-Fi Repeater a few days ago and its giving me a major headache trying to set it up.

In the installation guide (which is very poorly explained), its telling me to setup a manual TCP/IPv4 connection on my computer.
This is exactly what it is being said:

Plug your computer with the Wifi Repeater with RJ45 cable. Type Ip address is 192.168.10.x (x is from 2 to 254). Subnet mask is Type routers LAN IP address (the default IP is into the default gateway field.
Open web browser and type and the login screen will appear.

I have tried that and when I go in my browser and type, i get an endless loop turning and at one point it tells me that the webpage cannot be displayed.
This is the configuration I tried:
Ip Address:
Subnet Mask:
Default Gateway:

On the backside of the repeater, there is also another ip address mentioned,
So I have tried setting up my IPv4 with something like:
Ip Address:
Subnet Mask:
Default Gateway:

That also did not work.

My main router is a Dlink and has DHCP setup as to

Im completely out of ideas and in need of help...

Thank you

Discussion is locked
You are posting a reply to: Wireless Repeater Help
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Wireless Repeater Help
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
This does not match what the documentation asked for.
by R. Proffitt Forum moderator / August 10, 2012 8:26 AM PDT
In reply to: Wireless Repeater Help

Manual (slim as it is) wrote:

You wrote " I go in my browser and type"

In some computers such small things means it won't work. Try again and be sure the NETMASK is set and you are doing every step. Wish I could watch it for you.

All Answers

Collapse -
How are you connecting to the repeater? Wired or wireless?
by Steven Haninger / August 10, 2012 4:37 AM PDT
In reply to: Wireless Repeater Help

Here's a hint from something I saw. Your router uses 192.168.0.XXX. If your router acts as your PC's DHCP server, it's address will be within that range. To get your PC to connect to the repeater, it must also be within that range. If you're wanting the router to do the addressing, your repeater must have it's configuration changed to DHCP so your router can provide the address. Here's what you may need to do now if your repeater is using that address you mentioned as a default. You'd change your PC from DHCP to static. You'd give it an address using 192.168.10.X (something other than 1) This will put you within the network range. Make sure you use a wired connection to the repeater and use a browser to input it's address. You should be able to reach it's web interface and make whatever changes are needed. Good luck.

Collapse -
Wired connection.
by CiviCity / August 10, 2012 5:16 AM PDT

Hey Steven.
Thanks for your answer.

I'm connecting to it with a wire because it is not showing up in my available wireless networks list.
I did give my computer a static address of and I also tried

When I attempt to connect to the admin page via my browser, it won't connect. It tells me that the server is taking too long to answer or something in those lines..

I have tried doing so on my Apple and on my Windows machines, if this helps.
*I'm disconnected from my regular network when I try to set up the repeater to not cause any interference.*

Collapse -
By any chance did the repeater come with
by Steven Haninger / August 10, 2012 7:33 AM PDT
In reply to: Wired connection.

some kind of "discovery" utility or can you find it on the manufacturer's web site. This is a workaround to old default IP address issue I'd see long ago. My guess has to be that the address you've found is incorrect. Bob mentions the reset idea. If the address you gave is properly the default address, what I suggested should work. I've done this many dozens of times. Barring that, you could have a defective device that needs to be returned.

Collapse -
by VinceSGH / November 21, 2012 7:19 AM PST

Just wanted to chime in and let you know that a bunch of people with Winstar's are having a similar problem. Like Steven said, you have to be within range, but at the same time make sure that you change from DHCP to static simply because if you don't want to keep filling in numerical values every time that you want it to work. I was reading over at that sometimes the best thing to do is just get a router and repeater made from the same company. Seems to solve a lot of issues. If not, you can always use and put in some new firmware and hope it works.

Collapse -
My quick idea.
by R. Proffitt Forum moderator / August 10, 2012 6:30 AM PDT
In reply to: Wireless Repeater Help

Look for a RESET on that repeater then power it up and press the reset for a full minute. Most are much shorter but I'm working without a manual. Release the reset and then try what you did again.

Collapse -
by CiviCity / August 10, 2012 8:02 AM PDT
In reply to: My quick idea.

I have tried resetting the device.
It says in the manual to hold it for 10 seconds, but when I do, nothing seems to happen..?

I will retry to hold the reset for a full minute.

Also, Steven,
What do you mean by a discovery utility? Could u suggest me one please.

Collapse -
by CiviCity / August 10, 2012 8:16 AM PDT
In reply to: Wireless Repeater Help
Collapse -
Two thoughts after seeing the instructions
by Steven Haninger / August 10, 2012 9:50 AM PDT
In reply to: Manual

First off, a "discovery" utility is a piece of software that sometimes comes with network attached devices to aid in getting them on your network. Apparently you have none so the point is moot. It appears that what your setup instructions are doing is having you set the gateway address of your wired network interface to the repeater's default IP address. That gateway address is usually your own router's address. You're going to want to plug the cable directly from your PC into the repeater making sure your router is in no way connected. I am also wondering about the cable type. Generally a PC to PC connection requires a crossover cable. Devices on a network that attach via a switch use standard Ethernet cabling or 586b configured on both ends. I am wondering if your device doesn't want a crossover cable when being connected directly. Your instructions mention using the "enclosed" cable. You're not using a different one by any chance are you? My guess is that you need a crossover type.

Collapse -
Cable type
by CiviCity / August 10, 2012 11:22 AM PDT

I have tried the supplied cable and a regular RJ45 cable

The one that came with it was a 8 pin black Ethernet cable.
Mine was a regular blue RJ45 cable.

Also a question for you Steven, In the manual, it says that the repeaters address is but on the back of the repeater itself, it says that the IP is . In your opinion, which one should I rely on??
I have provided a picture:

Collapse -
I'd try either LAN
by R. Proffitt Forum moderator / August 10, 2012 11:29 AM PDT
In reply to: Cable type

There is a cheat if I wasn't sure. I'd set the NETMASK to instead that way I can try either from my assigned IP.

Collapse -
by CiviCity / August 10, 2012 11:38 AM PDT
In reply to: I'd try either LAN

I would set up that as the netmask but do I put the IP Address as 192.168.10.X or 192.168.0.X ??

Collapse -
by CiviCity / August 10, 2012 11:55 AM PDT
In reply to: I'd try either LAN

I just have tried putting the subnet mask as and tried both Ip addresses (192.168.10.X and None worked.

I have decided to try something else, I tried to ping
I used to get host is un reachable with Now I got host is down.
I don't know if this helps or not.

Collapse -
This looks like a router and not just a repeater
by Steven Haninger / August 10, 2012 8:09 PM PDT
In reply to: Tried

That changes things a bit. Most routers I've seen default to being DHCP servers. Thus, connecting them to a PC using DHCP settings for the NIC should work. Did you try that? Attempting to ping the device is a good idea. It can be possible that the connection is good but the web interface firmware is bad. Another thought is that perhaps your PCs firewall isn't set to exempt LAN connections. I doubt that's the reason but you could check it. It's beginning to sound like your device may be defective...maybe even just the cable...and an exchange might be a good idea.

Collapse -
Never mind. Now I'm not sure what you have
by Steven Haninger / August 11, 2012 12:02 AM PDT
In reply to: Tried

This, from the website, doesn't look to be labeled like the image you provided. Yours specifically states that it's a router but AP/repeater is what the web site calls that model #. A router would have a WAN port. I'd wonder where this came from. I'd see if it was returnable.
Collapse -
by CiviCity / August 11, 2012 12:17 AM PDT

Yeah your remark does seem to make sense.
The item was bought on eBay and I have contacted the seller and agreed to resend me a new one.

I have tried using the DHCP in the NIC and still nothing.
For the cable, I have tried 3 cables and nothing lol.

Question for you, if the device has a bad web interface firmware, does that mean that there is no way to use it?

Collapse -
If no way to configure it through the web interface
by Steven Haninger / August 11, 2012 1:49 AM PDT
In reply to: Ebay...

it would be as good as useless but I doubt that's your only problem with it. I have to wonder about some of that ebay stuff as to whether it might be grey market. Basically, this would mean it slips by normal distribution channels and may or may not be the same product sold by recognized US retailers. Thus, instruction manuals gotten from web sites for the US designated products might not be accurate for what you receive from those grey markets.

Collapse -
by CiviCity / August 11, 2012 2:42 AM PDT

I understand but my manual is the same thing.
It tells me to do the same thing as the one I gave you with the same addresses.

That's why I'm asking what should I do with the address indicated on the back side of the repeater..?

Collapse -
That's why you'd try both
by Steven Haninger / August 11, 2012 3:39 AM PDT
In reply to: Manual

or use ping. Ping return messages can sometimes be helpful but aren't all that conclusive. If you can ping the device but not enter the web interface, something is broken between the network component and the firmware component. If you can't ping the device, you could have faulty hardware or just an invalid address. You'd have hundreds or thousands of possible combinations of numbers to try depending on which number set was incorrect. If you remain persistent, you can look up a free utility called "nmap" or other network scanning tool. These might discover a valid address for you. I'll admit to having never used any but know they are available.

Collapse -
Network scanning tool
by CiviCity / August 11, 2012 5:16 AM PDT


Yea I am able to ping the device without any problems but I can't access the admin web page.
So I'm going to give nmap a shot.

I will reply back.

Thanks Happy

Collapse -
If you can ping, nmap is no longer useful.
by Steven Haninger / August 11, 2012 5:55 AM PDT
In reply to: Network scanning tool

You just need to enter that address properly into your browser...http://xxx. etc. If no login screen appears, there's some detachment from the web interface component or it's corrupt. I've not tried this but I noticed the manufacturer's site showed a firmware upgrade available. How that gets installed, I don't know, as often you need to do so from within a web interface. Well, progress but not success...or so it appears.

Collapse -
If you can ping it... more
by R. Proffitt Forum moderator / August 11, 2012 5:58 AM PDT
In reply to: Wireless Repeater Help

Then my only added thought is that you didn't type in the http: part or you have a PROXY enabled.

One person had some PPPoE software installed and what a mess to clean up. In other words, try another PC.

Collapse -
by CiviCity / August 11, 2012 7:18 AM PDT

I have tried it on both my macs, my dads pc and my desktop. Still no success.

How do I disable a proxy? Or how I even know if I have a proxy or not?
Mac or pc instructions are fine with me.

For the http part,
I have been putting http:// , is that the correct way to do it?

Collapse -
by R. Proffitt Forum moderator / August 11, 2012 7:24 AM PDT
In reply to: Mac

But try that on google about the proxy. It's rare to use one today and it's just an item to be sure about. It varies with the browser so I can't answer you directly unless I give instructions for all 20 browsers out there (there may be more than that!)

As to the http part, I only have what you post to work with. At times it's been very important to type EXACTLY what's in the manual and to use IE for this setup. I've run into a few routers that only worked with IE.

Collapse -
The end
by CiviCity / August 12, 2012 4:33 AM PDT
In reply to: Sorry

I think I can come to the conclusion that the repeater is probably faulty.
I'm guessing that the web interface has some connectivity issues..?

I will still be trying any ideas or suggestions, so u can keep posting.

I will keep u informed when I get the other one to see if it works and how.

Collapse -
There is hope, it isn't the end!
by MarcusVRS / September 10, 2012 10:06 AM PDT
In reply to: The end

Hi, friend! I have an identic repeater. See carefully the instructions in the manual, specially the configuration of the adapter of your computer. Without this step you won't be able to access the repeater interface!

I used the following settings in my computer's adapter:

IP Adress:
Subnet mask:
Default gateway:

I hope this be useful, and please excuse some English error, it isn't my native language!

Collapse -
How I made my Winstar WN518N2 Wireless N Wi-Fi Repeater work
by copyl3ft / May 25, 2013 2:36 AM PDT
In reply to: Wireless Repeater Help

I know this thread is kind of old but it seems nobody yet was able to figure out how to make it work. Here what I did to make mine work:

Reminder: If you already tried configuring your repeater, please press and hold the "Reset" button for 5-10sec so it will go back to factory default. If not, go directly to step 1

1. Connect to repeater wirelessly thru the default wifi name: Wifi-Repeater
2. Access repeater by typing in the address bar of your browser: 192..168.10.1
3. Click on "Setup..."
4. Choose Repeater Mode
5. Let it scan for your wifi router's wifi connection. Once you found it, click the "Select" button next to the chosen connection
6. It will now ask for your router's wifi connection Passphrase/Pin (depending on what you use). Its important that your Passphrase/PIN is correct or this will never work.
7. Click "Save and Reboot"

You waited for it to Reboot. You'll notice that the wifi connection name is no longer "Wifi-Repeater" but its now: "Wifi-Repeater1". This is a good sign because that means your Repeater is now on Repeater Mode. However, you obviously dont want that "Wifi-Repeater1" name so you try to connect to again but you'll realize that you cant.

8. Its now time to use the RJ45/Lan Cable which came with the package. Plug one end to your laptop/PC then the order end to the RJ45 slot on the repeater.
9. Go to: Control Panel >> Network and Sharing >> Click on "Change adapter settings" >> then double click on: "Local Area Connection" >> then double click on: "Internet Protocol Ver. 4 TCP/IPv4"
10. Choose "Use the following IP address
11. Type in: (or anything from .2 to .254 but NEVER .1) then press Tab twice. You'll see the "Subnet Mask" field will be filled.
12. Click "OK" and another "OK" on the other dialog box.
13. Now try to access: and 99.9% you'll be able to access your repeater again.
14. Click Wireless >> Click "Basic" and you'll find your repeater's connection name (Wifi-Repeater1). Change that to whatever it is that you want. On top of that field, you'll see your router's connection name (SSID) with the word: "Connected" beside it to the right.
15.Enable System Logs. This will help you know whats happening in your reapter.

In my case, Im using a TP-Link MR3420 v1.2 router and at first, connection was erratic. My repeater either its connected to the router but no internet or my router keeps on dropping the connections from my repeater. Then I found out that my Repeater was having an issue with my router's IP Binding setup for my home network. So I totally disabled IP Binding and just used on DHCP feature of my router. Ever since, my repeat has been running at full capacity. I hope you'll find this helpful. Cheers!

Collapse -
by Aspifirik / July 10, 2013 2:25 PM PDT


I have the same repeater. It works great with WPA or WPA2 encryption however it does not repeat WEP. I can choose from the list and when it reboots itself I can not see Wifi-Repeater1 signal on wifi network list. Any ideas ?

Collapse -
Cant do
by Myasincp / July 16, 2013 9:06 AM PDT

Hi there! As u said i tried to do it, but when i search for the wifi repeater i cant find it. I connected to one network but i changed my wifi connection and trying to Connect to a new one, but reset doesnt seem to work!!! I want to reset it and connect it to my new wifi. Please help if u can

Collapse -
Welcome back CiviCity
by R. Proffitt Forum moderator / July 16, 2013 9:09 AM PDT
In reply to: Cant do

Given it's been nearly a year I thought you had solved this one. Let's start fresh with a new post?

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.