Windows Legacy OS forum

General discussion

Windows XP PRO- only registers 3GB of 4GB RAM

by chocl203 / August 25, 2006 2:48 AM PDT

I have had 4GB of RAM in my Athlon CPU board;

2.20 gigahertz AMD Athlon 64
128 kilobyte primary memory cache
512 kilobyte secondary memory cache

3072 Megabytes Installed Memory

Slot 'A0' has 1024 MB
Slot 'A1' has 1024 MB
Slot 'A2' has 1024 MB
Slot 'A3' has 1024 MB

Notice that Belarc info shows 3072 MB installed but 4 1024 MB chips.

When booting the Bios also shows 4GB of RAM

Is there anyway to have XP Pro utilize all 4GB of RAM?

Post a reply
Discussion is locked
You are posting a reply to: Windows XP PRO- only registers 3GB of 4GB RAM
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows XP PRO- only registers 3GB of 4GB RAM
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Be sure to google that.
by R. Proffitt Forum moderator / August 25, 2006 2:51 AM PDT

Yes, in a 32 bit VM OS like Windows, this is an issue. Feel free to try the various boot.ini switches.

No cure is planned from what I gleaned from a recent seminar.

However you will find it all works in XP-64.

Bob

Collapse -
Windows XP PRO- only registers 3GB of 4GB RAM
by chocl203 / August 25, 2006 6:58 AM PDT

Thanks, found some new information

I have an Athlon CPU

2.20 gigahertz AMD Athlon 64
128 kilobyte primary memory cache
512 kilobyte secondary memory cache

I thought I had tried the "/PAE" switch. Perhaps I did not place it correctly.

Do you know where it should be placed to be effective?

Collapse -
Just google BOOT.INI
by R. Proffitt Forum moderator / August 25, 2006 7:23 AM PDT

It's documented. PAE may or may not work. XP 64 does however address this issue.

Bob

Collapse -
boot.ini
by chocl203 / August 25, 2006 10:38 PM PDT

This is what I see in my current boot.ini

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn


How do I add the /PAE switch.

Thanks

Collapse -
Add it to the other / items with an editor.
by R. Proffitt Forum moderator / August 25, 2006 10:41 PM PDT
In reply to: boot.ini

A google of boot.ini does show how.

Bob

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.