Windows Legacy OS forum

General discussion

Windows media player will not play MIDI files

by vox / November 14, 2005 12:23 AM PST

Windows media player will not play any MIDI files. Other software has no problem; soundcard not an issue.

Post a reply
Discussion is locked
You are posting a reply to: Windows media player will not play MIDI files
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows media player will not play MIDI files
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Media Player File Types
by Rodax / November 14, 2005 2:55 AM PST

Open the media player, click tools, scroll down to plugins and choose options. On the options dialog box choose file types tab. See if there's a check beside MIDI, or choose select all from the bottom left of box.

Collapse -
option selection - no effect
by vox / November 14, 2005 3:32 AM PST

All types were already toggled on, does not solve problem. Any other suggestions? Thanks

Collapse -
From memory.
by R. Proffitt Forum moderator / November 14, 2005 3:37 AM PST

This issue is in the WMP MINI FAQ you read about on google.com

Collapse -
Google
by vox / November 14, 2005 3:59 AM PST
In reply to: From memory.

How do I access that of which you refer?

Collapse -
Try this one.
by R. Proffitt Forum moderator / November 14, 2005 4:00 AM PST
In reply to: Google
http://www.google.com

Type in WMP MINI FAQ and it's the first link. From memory you look for the word MIDI on that site.

If you have an issue with these steps, please tell which step you need help with.

Bob
Collapse -
thanks
by vox / November 14, 2005 4:05 AM PST
In reply to: Try this one.

i have found the webpage and am now perusing it for help.

Collapse -
Hmmm...
by Rodax / November 14, 2005 3:45 AM PST

On sounds and audio devices properties dialog box, click audio tab and see if there is a midi playback default device listed. Also wondering, are the midi files in your media library? And what message, if any, do you get when attempting to play?

Collapse -
baffling
by vox / November 14, 2005 3:57 AM PST
In reply to: Hmmm...

My sounds and audio devices MIDI default is my soundcard; the other choice I have is Wavetable Synth. I have tried that but no effect. There is no music in my media library, I have a lot of music on the hard drive but haven't used the media center. This is a new computer. Most importantly, and telling, I am unable to play MIDI files from websites. Error Message - Media Player cannot play this file.

So to sum up, MIDI files already on my computer load into Media Player, the title is there, I am able to run play, the cursor moves across the screen as if playing, but no sound. Other file types play fine.

Collapse -
In case you didn't find the content...
by R. Proffitt Forum moderator / November 14, 2005 4:04 AM PST

"Q: When I go to a MIDI site, I can bring up the page with no trouble but when I click on a midi or wav file the Media Player doesn't open and I get the message that this page cannot be displayed. If I right click on the MIDI link and "save target as" to my desktop I can play it from there.
A: Go to WMP's Tools:Formats:Options. Uncheck "MIDI File", click apply, then check "MIDI file" and click Apply.

Q: How do I trouble-shoot MIDI?
A: I don't know. WMP has nothing to do with MIDI, we just take advantage of the system's support for it. Wise Tess says:
* Make sure your volume slider for "Midi" (and/or SW Synth) is up and not muted.
* Make sure "Midi Sequencer Device" is loaded in Control Panel, Multimedia, Devices, Media Control Devices. You can add it from Add New Hardware, Next, Next, No, Sound/Video/Games, Microsoft MCI. If it is loaded, go ahead and remove it and reinstall it.
Also, this may help some XP users having troubles with MIDI."

from the WMP MINI FAQ

Collapse -
wrong OS
by vox / November 14, 2005 4:26 AM PST
In reply to: One More Link

article only applies to Win 3.1

Collapse -
Eureka!!!
by Hawkeye_616 / November 18, 2005 11:12 AM PST

Hi vox,
I had the same exact problem. WMP does not have visualizations while playing MIDI flies and I had the songs were playing without sound input as yours did. I tried all of the above help to no avail.
So I looked at the connection on the back of my computer for the output wire and found that the green wire was plugged into the wrong hole (yellow) Playing other files worked with it was plugged into yellow. I have 5 outputs: green, blue, pink, yellow, and black.
Well my green one was plugged into the yellow.
In other words check your speaker wires to your computer----could be a color matching mistake.
Good Luck

Collapse -
Windows Media Player 11 won't play miidi files.
by Necto / October 5, 2007 9:30 AM PDT
In reply to: Eureka!!!

I had a problem with Media Player 11 and Midi files. I couldn't play them from links on web pages. I could load midi files (from my hard drive) into the player (with no error message) and see that the midi was playing but couldn't hear a bloody thing. Yes, I checked all the "little" problems such as the VOLUME PLAY CONTROL, the midi volume level and whether or not it was MUTED. I went to the MEDIA PLAYER, clicked on the TOOLS option, clicked OPTIONS, then selected the FILE TYPE options tab. All the file types were checked. I tried the trick of clicking on the MIDI file to unselect it, clicked APPLY and then again went through the process of selecting and checking the MIDI FILE TYPE again. No joy. The Midi Player continued to play everything BUT midis. You can imagine my frustration level at this point. To say I was in a murderous rage would be an understatement. I "swear" I loved my husband... may he rest in peace. ::Joking!:: I then spent many forgettable hours searching help forums (and Microsoft :GAH!:) and after much hair pulling and teeth gnashing I just dove into my CONTROL PANEL with a vengence. I went to the CONTROL PANEL, then went to the SOUNDS AND AUDIO DEVICES. I then clicked on the AUDIO tab. I was given several selections to choose from on the MIDI MUSIC PLAYBACK OPTION. Having dealt with all kinds of Microsoft "glitches" over many years and knowing from experience that Microsoft has an ongoing, passionate (if somewhat volatile) love affair with itself I selected the MICROSOFT GS WAVETABLE SW SYNTH. Eureka! Problem solved. Remember... Microsoft "loves" other Microsoft components... it needs them, desires them, CRAVES them like an insatiable vampire seeking to suck the life out of your computer. When in doubt... always select any option that says MICROSOFT! ::Ahem.:: I hope this helps out... better late than never?

Blind Ambitions

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech Tip

Stuck without Internet and want to watch movies?

CNET shows you how to download movies and TV shows onto your device using Amazon Prime so you'll always be entertained.