Windows 7 forum

General discussion

Windows 7 Create network bridge

by animator816 / January 24, 2009 9:25 AM PST

hey cnet members i normal run windows xp on my machine but currently trying out windows 7 but i have a small problem i hope you can help me with. ok so in xp i create a network bridge with my wireless card and ethernet so that i can connect my xbox 360 to the internet without buying the wireless adapter. now when i try to do this in windows 7 i get an error that says. To create a Network Bridge, you must select atleat two LAN or High-Speed Internet connections that are not being used by Internet Connection Sharing. im useing a lan connection and a high speed wireless connection isnt that all i need....and if it's because of intnert connection sharing how do i turn that off in windows
7

Discussion is locked
You are posting a reply to: Windows 7 Create network bridge
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Windows 7 Create network bridge
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
NAT
by FrankQC / January 25, 2009 3:59 AM PST

If you plug your XBOX to your computer to access the internet you'll be using NAT and not Bridged.

My friend had a similar problem. the only way (to my knowledge) that you can make it bridged is if you directly plug in your xbox to the router.

p.s. are you running this via VMware? (running Windows 7 at the same as as Windows XP?)

Collapse -
not vm
by animator816 / January 26, 2009 9:54 PM PST
In reply to: NAT

i am not running as a vm im doing duel boot so ill try and set up a nat and see how it works out. thanks for the tip frank

Collapse -
Well...
by FrankQC / January 26, 2009 10:11 PM PST
In reply to: not vm

Well if you want to keep playing the game I suggest sticking to XP since it worked. Win7 is still in testing.

I still have 1 question though. Are you connecting your 360 to your computer, then your computer wired to the internet? If you do that you can't get Bridged. It'll be NAT.

Collapse -
How to Bridge Network Connections in Windows 7
by cyotee / September 5, 2009 7:18 AM PDT

1. Plug in your console (WII, Xbox 360, PS3) and allow it to acquiring ip address.
2. click on the Windows button and type "network and sharing center" and enter
3. on the left right under manage wireless networks, should say change adapter settings click that
4. right click local area connection and disable it.
5. right click local area connection and click properties.
6. there should be a tab that says sharing go to that tab.
7. there is a box that says allow other network users to connect through this computers internet connection. uncheck it if it is checked.
8.hit ok then right click local area connection and enable it.
9 now select both your wireless network connection and the local area connection and right click and it should have the option to bridge connections. when you click bridge it will do its thing and should work when its done.

A network bridge is just letting one device pass through another's network connection. No routing or NAT is needed.

Collapse -
Re: How to Bridge Connections in Windows 7
by wagner138 / October 30, 2009 9:02 PM PDT

I just had to create an account to thank you for this! I found it most helpful

Collapse -
windows 7 starter
by lee.p / November 25, 2009 11:12 PM PST

I have the same situation.. I bridged LAN and wireless on my previous laptop running XP, this enabled me to connect to xbox live via an ethernet cable.
with windows 7,( as i found out to my despair) if you have windows 7 starter edition, it wont let you bridge connections or hardly even manage them. what a con! my laptop was costly and now i have to fork out

Collapse -
help plz???
by goldie326 / December 7, 2009 10:19 PM PST
In reply to: windows 7 starter

i have EXACTLY same problem!!! wot did u have to spend

Collapse -
How to Bride Network Connections in Windows 7
by mrswimmer12 / December 29, 2009 7:00 AM PST

how come under the local area connection i have no share tab. I am using my windows 7 starter copy. please get back to me thank you
-Kevin

Collapse -
HOW TO CONNECT TO YOUR XBOX VIA LAPTOP WINDOWS 7
by mrswimmer12 / December 29, 2009 7:03 AM PST

I have no share tab under the local area connecton properties im using the windows 7 starter version please get back to me use this one to reply cause i didnt click track when there are updates. THANK YOU SO MUCH FOR YOUR TIME. IM TRYING TO CONNECT TO MY XBOX VIA LAPTOP

Collapse -
How to Bridge Network Connections in Windows 7
by oadbymirage / February 15, 2010 1:31 AM PST

"1. Plug in your console (WII, Xbox 360, PS3) and allow it to acquiring ip address.
2. click on the Windows button and type "network and sharing center" and enter
3. on the left right under manage wireless networks, should say change adapter settings click that
4. right click local area connection and disable it.
5. right click local area connection and click properties.
6. there should be a tab that says sharing go to that tab.
7. there is a box that says allow other network users to connect through this computers internet connection. uncheck it if it is checked.
8.hit ok then right click local area connection and enable it.
9 now select both your wireless network connection and the local area connection and right click and it should have the option to bridge connections. when you click bridge it will do its thing and should work when its done."
Thanks for this guide it works great for me and was what i have been looking for
Now here we go!!!!Except...I need to connect a Dreambox to the net through my PC... problem is when flashing an image on the box it is given an IP ...now your above fix does not allow me to enter this ip and therefore the box cannot get to be recognised and cannot get on the net...any work round out there ???

Collapse -
hi i have a problem
by Dasher1026 / November 13, 2010 12:55 PM PST

when u go to properties on your local connection i don't have that tab to sharing im trying to connect my xbox360 to my laptop for wireless internet i have connected my Ethernet cable. also my computer is a aspire one d260 it has windows 7.

Collapse -
NO SHARING TAB
by RickHeather / December 28, 2010 12:52 PM PST

I have Windows 7 / netbook and everyone gives the same instructions...to go to the shared tab. I don't have a shared tab....I can't seem to get pat this problem. Can anyone help!?

Collapse -
It's Usually Not There If You're On A Domain
by Grif Thomas Forum moderator / December 29, 2010 12:07 AM PST
In reply to: NO SHARING TAB

..and your computer must have at least two network adapters, such as wireless and ethernet, for the "Sharing" tab to show up.

Hope this helps.

Grif

Collapse -
Thanks
by LittleLeo27 / June 6, 2011 8:04 PM PDT

Thanks a heap it definitely worked and I have been wondering how to do it for awhile now and now I do, thanks.

Collapse -
help
by youngwhyte7414 / July 20, 2011 4:49 AM PDT

i tried this an it didnt work i dnt have a shar tab just the square boxes an i unchecked the square box that said all this pc to be dicovered an located on the other network was that the right box?

Collapse -
Why this is just a bad idea.
by R. Proffitt Forum moderator / July 20, 2011 6:06 AM PDT
In reply to: help

It doesn't work for everyone in spite of hundreds of web pages on how to do this.

I see routers for 15 bucks that usually cure what folk are trying to do with these bridges.
Bob

Collapse -
Can't disable connection
by LandlordTo / August 19, 2011 3:58 AM PDT

I was able to get the bridge to work with the following changes.

Was not able to disable network connection.

Must uncheck *allow other network users to connect through this computers internet connection" on both connections you want to bridge.

also must uncheck "allow other network users to control or disable the shared internet connection"

Thanks for the help

Collapse -
How to
by TaraS_WinTeam / December 5, 2009 1:35 PM PST
Collapse -
The Easiest way to bridge Xbox 360 and Windows 7
by timmyb1216 / May 13, 2010 9:16 AM PDT

Ok everyone...I just figured out how to get your xbox online WITHOUT bridging your connection! So delete that worthless network bridge and listen up. Ok...follow the steps below:
1) Right click on the network icon by the clock and click on "Open Network and Sharing Center."
2) From this window that opens up, on the left hand side of the window, click on Change Adapter Settings.
3) If you've still got the bridge...delete it...you don't need it.
4) Right click on the "Wireless Network Connection" icon and click "properties"
5) Click on the tab named "Sharing"
6) Check the box that reads "Allow other network users to connect through this computer's internet connection"

And that's all you need to get your Xbox 360 online using a Windows 7 laptop (or desktop).

Collapse -
xbox live
by oldestbro1004 / June 27, 2010 6:07 PM PDT

i tried the right click on wireless network connection and clicked on properties but it does not show a "share" tab for me? am i doing something wrong? please help if you can.

Collapse -
TimmyB1216
by The True Computer Genius / November 28, 2010 8:09 AM PST

It can work BOTH ways. However, The Genius TimmyB1216 gave you all the EASIEST way.

If you do not get a SHARING tab on Windows 7, it is because you didn't DISABLE the device before going into it's properties. Cancel properties, right click on the device, disable it. Then right click on it again and go back to it's properties and the 'sharing' tab should be there....

Collapse -
sharing tab
by crpierce / April 2, 2011 8:16 AM PDT
In reply to: TimmyB1216

So my sharing tab didn't show up in the wireless properties. It showed up in the LAN properties. Now what????

Collapse -
much simpler
by dmobbjr / May 14, 2010 7:09 AM PDT

Okay everything that everyone else was saying was useless. The reason you got that original error message was because of one of two reasons. The first is you have ICS on. simply right click each connection go to properties and turn off sharing. The other reason is that you may have had only one connection selected. Highlight both connections then right click and choose "bridge networks".

Collapse -
windows 7 bridge
by keepstill / September 18, 2010 11:53 AM PDT
In reply to: much simpler

i can't highlight both wireless and land area connection.when i highlight the second one the first one won't stay highlighted.

Collapse -
network bridge
by oldestbro1004 / June 27, 2010 6:01 PM PDT

sorry to interupt you but did you ever found a solution to your problem for network bridging? if so i wonder if you can help cuz im trying to network bridge but there is no icon "local area connection" which allows me to bridge so i can get on xbox live. thank you i'll appreciated if you replay back.

Collapse -
PROBLEM SOLVED!!!
by jeffmk3 / July 10, 2010 11:34 AM PDT
In reply to: network bridge

dude delete that bridge conneection **** its just going to make things more complicated.
Step 1. make sure your wireless is sharing with other networks.
Step 2. right click on the local area connection. click on properties. go to internet protocol versoin 4 DONT CLICK ON VER. 6!!!
Step 3. go to the start menu and type CMD on the search programs and files press enter on the CMD type ipconfig/all.
Step 4. on the protocol version 4 click on (use the following ip adress) the ip address should be the default gateway address thats on the cmd. VERRY IMPORTANT U DONT MIX THE ADDRESSES
Step 5. subnet mask is the same on both IPv4 and the cmd.
Step 6. default gateway on the IPv4 should be the same as the ip address you assigned on the xbox. for example the ip for the wireless adapter is 192.168.0.121 then the ip for the xbox has to be diff. 192,168.0.131 only the last three digits.
Step 6. on the bottom the dns server address should be the same for both the wireless and the IPv4.
Step 7. click ok. close the properties view. right click on the internet bars at the bottom of the screen next to the volume control.
Step 8. what does the local are connection network say public, work, or home? on mine it was public i changed it to home n it worked im connected to xbox live i guess the computer doesnt trust the network when its on public so i think theres no file sharing. this worked for me. no joke i was trying to figure this out for about three ******* hours. and all i needed to do was change the network to home WTF!! wow thanks window 7 for making this a living hell.

Collapse -
Sharing Tab
by crpierce / April 3, 2011 11:02 AM PDT
In reply to: PROBLEM SOLVED!!!

Yea as I stated above in a reply, my wireless doesn't have a sharing tab for me to enable all networks to share. The LAN properties do, but the wireless doesn't....so now what do I do?

Collapse -
Restart In Safe Mode With Networking
by Grif Thomas Forum moderator / April 4, 2011 4:23 AM PDT
In reply to: Sharing Tab

...See if the "Sharing" tab shows up.

Hope this helps.

Grif

Collapse -
help
by jtrautner / May 27, 2011 5:15 AM PDT
In reply to: PROBLEM SOLVED!!!

how did u change your lan from public to home??

Collapse -
Windows 7 Create network bridge
by Feraya510 / June 7, 2011 4:58 PM PDT

If you plug your XBOX to your computer to access the internet you'll be using NAT and not Bridged.My
friend had a similar problem. the only way (to my knowledge) that you
can make it bridged is if you directly plug in your xbox to the router.

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.