Networking & Wireless forum

General discussion

WiFi: "Limited or No Connectivity" Problem

by fliggil / March 23, 2008 5:15 AM PDT

Hey all, so here's what I've been through. I have built-in wireless on my VAIO VGN-C140G laptop. I am in the same room as my Linksys WRT54G v.2 Wireless-G router. I am able to connect to my router, it says signal strength is Excellent, and speed at 48.0mbps. My problem is, I always get a message that says "Limited or no connectivity", and basically I cannot get any sort of connection to the internet, whether it be a webpage, AIM, etc.

I'm able to connect via rj-45 cable (which is what I'm on now) and it works fine. Both of my roomates connect to our router without any problem. I've upgraded my wireless adapters drivers, I tried the WinSockXP fix, and I'm still unable to connect wirelessly.

Does anyone have any suggestions? Thank you all so much!

Discussion is locked
You are posting a reply to: WiFi: "Limited or No Connectivity" Problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: WiFi: "Limited or No Connectivity" Problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Did you try it setup per the forum sticky?
by R. Proffitt Forum moderator / March 23, 2008 5:17 AM PDT
Collapse -
A common reason:
by Kees Bakker / March 23, 2008 5:20 AM PDT

incorrect security settings, for example WEP in stead of WPA, or the wrong kind of WPA or simply an incorrect password.


Collapse -
by fliggil / March 23, 2008 5:32 AM PDT
In reply to: A common reason:

My setup is wall to Westell Model 1600 DSL modem -> Linksys WRT54G wireless router. As I stated earlier, both of my roomates can access the WiFi connection, so the setup obviously is not a problem.

How would I know if I'm set to WEP as opposed to WPA?

Collapse -
The WRT54G manual tells how to
by R. Proffitt Forum moderator / March 23, 2008 5:34 AM PDT
In reply to: ...

Set it to the forum's preferred settings.

Collapse -
BTW, With WEP you can experience...
by R. Proffitt Forum moderator / March 23, 2008 5:35 AM PDT
In reply to: ...

Issues where everyone can connect but you. This issue is something I must decline writing the full reason everytime it comes up. Feel free to read former replies about it.

Collapse -
Re: setup
by Kees Bakker / March 23, 2008 6:02 AM PDT
In reply to: ...

The setup of the wireless connection in your PC should match the setup in the router. That's encryption type and password. Did you check the properties of the connection in your PC? They should be equal to those in your roommates. Are they?


Collapse -
I read somewhere that
by PudgyOne / March 23, 2008 11:41 AM PDT
In reply to: ...

the Westell 1600 uses an ip address of

The Linksys router also uses an ip address of

So you'll have to change the ip address in the Linksys router. (Hint: Forum Sticky mentioned this about a Westell 6100.)

They're conflicting with each other.

Remember to update the firmware in the Linksys WRT54g

Broadcast SSID

Use WPA Security

Change the LAN ip address in the Linksys

mixed b and g mode(N if available)

Use channels 1, 6 or 11. Most devices work better on these channels.

Good Luck,


Collapse -
try this....
by Mr. Daniel / March 26, 2008 9:25 AM PDT

log into the router by entering it's ip address into your web browser. if you don't know the ip address of the router, double-click on the "wireless network connection" icon in your network connections. click the support tab. your router's ip address is the default gateway. once inside your router you can get the password for whatever type of encryption is enabled.

next, clear your wireless adapter's profiles. right click on your "wireless network connection" icon and select properties. wireless networks tab. in the box below "preferred networks" highlight and remove the networks that you don't use and the router in your room. click ok.

reset your wireless adapter. right click on wireless network connection, disable, wait 10 secs. right click, enable. view available wireless networks. select the router from the list, click connect. enter the router's password.

if that don't do it, i would suggest resetting the router to factory defaults and set it up again.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Smart Home Help

Light bulbs you shouldn't buy

There are plenty of dimmable LED light bulbs, but make sure you don't buy the ones that flicker when you dial them down.