Phones forum

General discussion

Wi-fi Connection

by hauser.josh12 / June 21, 2010 2:07 PM PDT

I have a BlackBerry Curve 8520 WITHOUT a data plan.

I am trying to connect to my private protected wireless network to access the internet.

The white wi-fi logo turns white and it says "T-Mobile: Hauser Home Network" and everything acts like it's working.

The web browser is set to Internet Browser not web2go.

However, whenever I try to access any website, direct link or google search, I get the error message:

"Unable to connect to the Internet, please try again later.

If the problem persists please contact your service provider."

Post a reply
Discussion is locked
You are posting a reply to: Wi-fi Connection
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Wi-fi Connection
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
This error is easy to reproduce.
by R. Proffitt Forum moderator / June 22, 2010 5:52 AM PDT
In reply to: Wi-fi Connection

Set up a wifi point with WEP. Mistype one character (or even get it right) and you see this. Test this with WPA or no security.
Bob

Collapse -
I've tried
by hauser.josh12 / June 22, 2010 6:25 AM PDT

I have tried setting my wi-fi network up with every security option possible. It still does not work.

Like I said, it acts like it is connected, but it can't connect to the internet still.

Collapse -
I can't duplicate this.
by R. Proffitt Forum moderator / June 22, 2010 6:31 AM PDT
In reply to: I've tried

I only have a BB World Edition.

But last week I had this failure on some Augen 7 inch Windows CE netbook. Cheap thing but it blew (has a bug) the WIFI implementation. This thing can't get the IP addresses but did "connect." So I had to manually enter in an IP, netmask, DNS and gateway.

Sorry but all that appears to be Greek to some but now it works.
Bob

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.