Windows Legacy OS forum

Question

Why can i only access the internet in safe mode?

by blondeme / July 1, 2011 4:33 PM PDT

I have only been able to do this the last 4 days or so....and i honestly cannot recall anything happening to see how any changes occurred.

When i click on Firefox in normal mode i can wait around 15 minutes before the firefox browser (and IE browser also) slowly comes up and then it just says connecting for several more minutes until the message says server cannot be found.( i think that was the correct words onscreen).Yet going into safe mode with networking it works fine.I have done a chkdsk and also scanned with spybot s&d and avast free and also malwarebytes anti- malware.All come up clean including housecall online.I clicked repair on the lan connection in control panel>network connections>Lan.It also says it is connected in both normal and safe mode.

My winxp Professional is version 2002 with service pack 3.
Registered to myself.

This is an older computer i have had for a few years now.

I connect with ADSL and my router is same as always.

I have Everest installed and also backed up all important personal documents onto an external hard drive.
I have not as yet backed up drivers - i am unclear how to do that as yet.
I also was not supplied with a windows disk originally - i bought this online and it is an OEM desktop system.

I used the Network Diagnostics to diagnose anything and I do not see fail in any of the results. But after googling i did find how to ping to test for any problems.

I did ping loopback....127.0.0.1 - passed 100%
ping ip address....192.168. * . *** - also passed 100%
ping Ip address of default gateway - failed (timed out)
ping dns servers - failed (both timed out)

ipconfig /all:
Windows IP Configuration:
host name is............. listed
primary dns suffix.......
node type...................unknown
ip routing enabled......no
wins proxy enabled.....no

Ethernet Adapter Local Area Connections:
Connection Specific DNS Suffix:
Description.........................Sis 900-based PCI Fast Ethernet Adapter
Physical address................00 - ** - ** - ** - ** -**
Dhop enabled.....................No
IP address..........................192.168. * . ***
subnet Mask.......................255. *** . *** . *
Default Gateway..................192 . *** . * . ***
DNS Servers.......................203 . ** . ** . **
203. ** . * . *

I also used msconfig and disabled everything in startup tab(in Normal mode on desktop) then restarted normally. Still same problem.

When i look at Everest in safe mode it says in network/internet current proxy and LAN proxy are both disabled.Pop3 is my email.


I am lost and do not know what else to try...
Any ideas?
Thank you

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Why can i only access the internet in safe mode?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Why can i only access the internet in safe mode?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
i forgot to add
by blondeme / July 1, 2011 4:35 PM PDT

ps. I only use this computer there is no other computers in the house connected to this one.

Collapse -
A quick test.
by MarkFlax Forum moderator / July 1, 2011 9:41 PM PDT
In reply to: i forgot to add

Try this quick test.

I guess you use Firefox mainly and rarely use IE, but we sometimes find that a setting in IE has changed, and this affects the way the computer's browsers attempt to connect to the internet. That settings seems to be a global setting, ie, for all browsers, and not just IE.

So, open IE and go to Tools > Internet Options. If you are using IE9 then Tools is the gear-wheel shaped icon on the right. With the Internet Options dialog open, go to the Connections tab, then find the "LAN Settings" button and click that. In the new window, make sure there are no settings selected other than "Automatically detect settings". If there are, remove them all and make sure the "Automatically detect settings" is selected. OK/Apply/OK out of that.

Sometimes malware will try and change the settings to a Proxy Server. Restart all your browsers and try again. If they still fail, reboot, (restart), the computer. That may not be the case in Safe Mode.

Does that help?

If so it is possible that this causes the delay in the browsers opening as they are searching for a proxy connection. If the browsers work but there is still this delay in them opening, then that shows some other problem.

I see you are using Spybot S&D. Sadly we find this utility often forms a toxic combination with other anti-malware scanners nowadays, especially if Spybot's TeaTimer component is turned on, and cause conflicts. We recommend uninstalling Spybot, (turn off TeaTimer first), to see if that helps performance. If not, Spybot can always be reinstalled.

If not that, then review all your IE and Firefox Add-ons, to see if there is anything that might be causing both browsers to be s,ow in opening.

Mark

Collapse -
Problem still remains unfortunately...
by blondeme / July 2, 2011 4:13 PM PDT
In reply to: A quick test.

Thanks for your reply MarkFlax.
I do use mainly Firefox.
I followed your directions and went into IE then tools>internet options>connections.I then went into Lan Settings. I found there is absolutely nothing at all in there as it was all blank.So i ticked "Automatically detect settings", clicked OK, then as apply was greyed out i ticked OK once again.
I did notice IE is fast to open but sits for a few minutes with it "connecting".Then diagnose network connections comes up on the screen.
I tried then to open Firefox and once again it took a quite a few minutes to open then i get the message the connection has timed out - the server is taking too long to respond.I then checked in Firefox the connection - tools>options>advanced>network.Once again this window is totally blank and the "use system proxy settings" is ticked.
I then went on to uninstall Spybot s&d using Revo uninstaller.I also never did have teatimer enabled just in case of any problems with other software.
I did all this while in normal mode.
Unfortunately the problem still remains.I then opened IE once again and tried to click "Diagnose problems" button that was onscreen.It did not work so i went to tools>diagnose connection problems which brings up network diagnostics for windows xp.
It tested for me then it says there is a winsock provider catalog problem.I then clicked to fix and reboot but the problem still remains.
Oh and i checked IE it seems i have version 8.0.6001.18702
Firefox is version 5.0
i dont have any addons in IE at all since i normally do not use it.
I do have only 4 in Firefox but i have disabled and rebooted but that did not help in any way.

Collapse -
Winsock Fix
by MarkFlax Forum moderator / July 2, 2011 10:48 PM PDT
Collapse -
once again no luck..
by blondeme / July 3, 2011 5:57 PM PDT
In reply to: Winsock Fix

Thank you once again - unfortunately my problem still remains after trying these options.

First link in above post i used the Winsock xp fix tool - no luck it did not work but i looked into the Internet Protocol Properties (my computer>my network connection>right click and click properties>lan connection and i needed to reenter the ip address etc. So the tool did what it should have done but my problem remains.
Tutorial 1 did not link but tutorial 2 did:I downloaded and used the snapfiles tool - i rebooted as i did for the previous tool and problem still remains.

I checked the ipconfig /renew command and i did not get any error as microsoft mentions may occur.Also
"In Device Manager, when you click Show Hidden Devices, the TCP/IP
Protocol Driver is listed as disabled under Non-Plug and Play drivers,
and you receive error code 24." there is no error there either.

I followed then with the microsoft link: I have not used "Netsh commands" option as it says xp with service pack 2 but i have service pack 3 so was being cautious as to whether it was safe or not.

I used the Microsoft fix it tool 50203 on that same page and i did not notice any change once again.

I also used the MSinfo32 method to check my protocols and if the winsock 2 is damaged or not.My files appear to be almost the exact same name microsoft state apart from i see 3 extras - MSAFD NetBIOS [\Device\NetBT_Tcpip.... names.

Seems everything i try just doesn't want to "fix" it for me.

And i still connect through the safe mode with networking..sigh!

If i had an installation disk - i think perhaps it would be an easier - and perhaps faster option!

Collapse -
The Netsh commands are the same for SP3
by MarkFlax Forum moderator / July 3, 2011 9:24 PM PDT
In reply to: once again no luck..

But this is getting confusing now. You have internet access in Safe Mode but not in Normal Mode.

Questions;

1] How do you connect to the internet, do you use a modem, or a modem&router? Whichever, as a last resort, try rebooting the modem and router, (if you have one). Turn them off, router first, then modem, wait two minutes, then turn them on, modem first, then router. I would shut down the computer first, and don't boot it up until both are fully connected again.

I don't believe that will work, because internet access in Safe Mode is still available, but it's worth a try.

2] What firewall do you use? Has it's settings changed recently? Is the firewall blocking all access in Normal Mode?

Next steps;

Consider that some malware is causing this, the malware has not been detected by your other scanners, and this malware doesn't get the chance to load whilst booted up into Safe Mode. Then...

a) Try the SmitFraudFix.exe option discussed here;
http://www.geekstogo.com/forum/topic/109268-how-to-use-smitfraudfix/

b) Have a look at Carol's post here and follow the link to the BleepingComputer guidance for using RKill and Malwarebytes' Anti-malware. That guidance is comprehensive, and if you decide to try it, you will need to follow the instructions carefully.

See how you get on.

Mark

Collapse -
ok lets see...confusing yes
by blondeme / July 4, 2011 2:46 PM PDT

I use iconnectAccess 611 router. And i did as you asked in turning it off - but i always have it all turned off completely every night anyway.
And nope no difference.

I still have access to the internet in safe mode.

As for firewall, i use Comodo free firewall and i only use the basic firewall. I also did uninstall it and tried access in normal mode a couple of times without the firewall at all and i also simply turned it off also to no avail.Right now i dont have it at all simply as i cannot access internet in normal mode.

I just followed instructions on your link to use SmitFraudFix.exe and followed correctly. I rebooted 3 times to double check the internet in normal mode.

Other than the desktop background turned to "none" and retyping the Internet Protocol Properties numbers nothing changed.My icon in the systray for the internet connection does say it is connected when in normal mode.

And right this moment i am typing this reply again in safe mode.

I shall try Carol's post that you link there later this afternoon/evening.(I am in Australia).

As yet i have not followed the Netsh commands so will look at that also.

thanks for your patience....this definitely has me stumped - i would have thought any of the previous methods in this thread would have worked by now.

Collapse -
ok
by blondeme / July 5, 2011 12:21 AM PDT

I have just followed your previous link http://support.microsoft.com/kb/811259 and followed it closely.

I manually used cmd prompt then typed netsh winsock reset and enter.I then rebooted. Everything still seemed the same.

No internet in normal mode still.I did this all in normal mode.

I then backed up the registry in case.

Used regedit then Followed the directions to delete the winsock keys.

After clicking yes rebooted.

I then installed tcp /ip as instructed clicked ok...then checked all was there.

Once again all configurations look fine - but still no internet in normal mode?

But still connecting in safe mode only?

I shall look at Carols post now but am thinking maybe there are not many options left now.

thanks again

Collapse -
Answer
Re: no conection
by Kees_B Forum moderator / July 5, 2011 4:10 AM PDT

So it can't reach (ping) the gateway. That's your router. No need, by the way, to star that out; it's strictly local, such a 192 address. Then you don't have an internet connection.

Did you try in safe mode and compare this output. My guess: ping works there.

So something is blocking that gateway. If I should want to reach something like that, I'd open my firewall (Zonealarm free) and press it's emergency button to "stop all Internet activity". So I suspect your firewall. I can't find any mention of that scanning your posts. What happens if you disable of even uninstall it?

Kees

Collapse -
On close reading ...
by Kees_B Forum moderator / July 5, 2011 5:12 AM PDT
In reply to: Re: no conection

I see you mentioned the firewall in one of the posts above (they don't have a number anymore). And turning it off didn't help.

Still my suspicion is that something is blocking access. So it's time to start the start up diagnostics. See, for example:
http://support.microsoft.com/kb/310353
http://support.microsoft.com/kb/310560
http://www.freebits.co.uk/cleanboot.html

Just in case you need it, make a careful note of all services started automatically and all programs checked in the startup tab of msconfig, so you can manually return to that exact same 'normal' state.

Best of luck finding it.

Kees

Collapse -
Answer
Occasionally, Antivirus Suites and Firewalls Cause Such
by Grif Thomas Forum moderator / July 5, 2011 5:03 AM PDT

Following Kees' lead here, we occasionally see such problems with programs such as Norton, or other antivirus/antispyware suites which conflict with the various firewalls on your computer. Sometimes, uninstalling Norton will fix the problem.. Sometimes, if you have two AV's or two firewalls enabled, one needs to be disabled.. It's only happening in "normal" Windows because the Antivirus and firewall programs frequently only run when all the normal Windows drivers are running..

So if you've got a third party firewall installed, try disabling the Windows Firewall first.. Or simply uninstall your third party firewall and antivirus to see if that takes care of the issue.

Hope this helps.

Grif

Collapse -
erm..
by blondeme / July 5, 2011 1:06 PM PDT

Mark thanks for your previous help - even if the computer was stubborn and refused to let any of your suggestions become a solution.

Grif i do not use Norton nor 'suites'....i have read of many problems over time from others using these.
I also do not use windows firewall i always make sure that is disabled.
I also got to the point a couple of days ago where i uninstalled both Comodo and Avast completely - i figured they did not start in safe mode anyway and since it was not connecting in normal mode i just uninstalled....but have them both installed again now!

Kees thank you very much it seems that this link...http://support.microsoft.com/kb/310353 is the one that worked since i now am in normal mode answering this online!

I downloaded guided help from microsoft. Clicked the self extracting cabinet -tries to connect on screen , but then error says ' a connection with the server could not be established'.This was done in normal mode.

I then updated my windows time in normal mode without a problem.I could do this all along for whatever reasons - but not in safe mode.

So i followed:Method 2: Manually starting XP with a clean boot (advanced user only) up to and not including the optional step since once rebooted i then checked IE once again and - no delay, my window loaded and i was finally connected to the internet once again!

Seems Clean Boot fixed whatever it was that was blocking the gateway.

I had then went back into start.. run ..msconfig.. startup and selected to hide Microsoft then i unticked any of the startups (a choice of Cool that was not microsoft.I rebooted then checked IE again and def still all fixed!Although i left comodo and avast to startup.

So problem is solved at last and a huge thank you for all your brain waves working overtime!

Collapse -
That's Good But Not Entirely Fixed..
by Grif Thomas Forum moderator / July 5, 2011 1:53 PM PDT
In reply to: erm..

If you've unchecked many items in "msconfig" and things run fine, then the next step is to identify which item, or items are the culprit.. Place check marks in each box, one at a time, and restart the computer afterwards.. Eventually, you will find which program "breaks" the system and you can then uninstall or fix the problem program.

Good job.

Grif

Collapse -
Yep, excellent job
by MarkFlax Forum moderator / July 5, 2011 8:18 PM PDT
In reply to: erm..

and I agree with Grif about the elimination test, to see what was blocking the internet at startup.

But glad you have got it sorted, and thanks to Kees and Grif.

Mark

Collapse -
I found the problem
by blondeme / July 6, 2011 12:30 AM PDT
In reply to: Yep, excellent job

it was Avast free antivirus...after reinstalling same thing happened then when i uninstalled with Revo again but the thorough uninstall this time the problem went away and i once again had normal access.

I have now begun to use Avira and there seems to be no problems now.

Once again thanks for all the help and have a great day.

Collapse -
Avast free antivirus doesn't block Internet with me.
by Kees_B Forum moderator / July 6, 2011 12:52 AM PDT
In reply to: I found the problem

Never did so. So it's still a little bit strange. But let's be glad you found it.

Kees

Collapse -
Answer
DNS Issue XP Internet Only In Safe Mode McAfee Issue
by stevewashere / August 28, 2012 3:58 PM PDT
Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Big stars on small screens

Smosh tells CNET what it took to make it big online

Internet sensations Ian Hecox and Anthony Padilla discuss how YouTube has changed and why among all their goals, "real TV" isn't an ambition.