Windows Vista forum

General discussion

Weird problem with fonts being italic or bold

by Bennythecop / September 20, 2008 12:16 PM PDT

Seems I have quite the odd problem with viewing text. All of a sudden, all the text on sites viewed in FireFox were bold. At first I thought this was an issue with FireFox, but this is apparently affecting Internet Explorer as well, and even more troubling, the time stamp in Windows Media Player is italic. The time-stamp on YouTube is also italic, while everything else on that site is bold.

This problem isn't that consistent neither. I logged onto Fronter, which my school uses as a way to notify their students about homework, etc, in FireFox and it was displayed in bold, while the exact same site was italic in Internet Explorer. Filenames, shortcuts and most other things related to the OS are also normal.

I really have no idea what the problem is, as it happened all of a sudden in the middle of browsing the Internet. Is it Java? If so, how do I fix it?

I have a Toshiba Equium A200 laptop with Vista Home Premium 32bit, Intel Pentium Dual-core and 2 GB RAM.

Any help would be appreciated!

Post a reply
Discussion is locked
You are posting a reply to: Weird problem with fonts being italic or bold
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Weird problem with fonts being italic or bold
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I have the same problem
by sheilahoff / September 29, 2008 1:27 AM PDT

I hope someone posts a solution. I just noticed the same exact issue. I'll keep looking and post here if I learn anything.

Collapse -
potential solution
by sheilahoff / September 29, 2008 1:33 AM PDT
Collapse -
by Bennythecop / September 29, 2008 8:16 AM PDT
In reply to: potential solution

Thanks a lot, that actually worked. I still haven't figured out how to return to the same font, but as long as the bold and italic is gone I am satisfied.

Collapse -
Trick Recovery
by vikram_gandhi / December 11, 2008 3:23 AM PST
In reply to: Thanks

The problem is due to the fact that the font registry entries have got corrupted. The fonts affected are Arial, Courier, Times New Roman, Marlett, Terminal etc.

The programs like IE, Outlook (in mails) and Firefox fail when they try to locate these fonts. The beauty is that these fonts still exist in the <OS drive>\windows\fonts folder.

To fix this issue follow these steps:
1. Click Start -> Run. If you cannot locate the 'Run' item, then click 'Window Key' + 'R'.
2. In the run box, type: c:\windows\fonts (Replace c: with the drive letter where the OS is installed)
3. The fonts window will open. Click 'Alt' + 'F' to activate the menu. Click 'Install New Font' in the menu.
4. In the folders dialog, browse to c:\windows\fonts where c: is the OS drive letter.
5. All fonts would now appear under 'List all fonts'.
6. Click 'Select All' and then click 'Install'.
7. Confirm the windows permission dialog.
8. A replace file dialog would appear. Click on 'Yes' to each and every dialog that appears. This will ensure that fresh entries for fonts are written in the registry. To avoid clicking, press and hold 'Alt' key - then press 'Y' key for every dialog that appears.

Please let me know if this solution doesn't work for you

Collapse -
It worked!
by Bennythecop / December 11, 2008 6:17 AM PST
In reply to: Trick Recovery

I followed your instructions and it all worked well. I've noticed that Times New Roman and other fonts that wouldn't appear when changing fonts under the Advanced settings for Appearance now do. The thing is that I have gotten so used to the Segoe UI font that it doesn't really matter... but out of curiosity - which font is the default font?

Anyway, thanks a lot!

Collapse -
The default font
by vikram_gandhi / December 14, 2008 7:10 PM PST
In reply to: It worked!

The default font is Times New Roman, 16 pts

Collapse -
by Amorphous_Snake / March 14, 2009 5:35 AM PDT
In reply to: Trick Recovery

Thanks a lot. You saved me from a reinstall! I was that desperate!!!

Collapse -
One after another....
by chromejael / May 23, 2009 10:58 PM PDT
In reply to: Trick Recovery

Yes, this fix worked for many of my applications, including yahoo messenger, which used to be bolded all the time and youtube.

However, the wikipedia page has been drastically changed. The font is almost unreadable, and close together. I repeated your fix several times, but still no change. My yahoo mail font has changed, but i can bear with it, as the font is readable.

Please help me with my problem, I practically worship wikipedia, on a daily basis Grin

Collapse -
Font Problem
by vikram_gandhi / May 24, 2009 4:02 PM PDT
In reply to: One after another....

Have you tried resetting the default font settings for the browser. For IE, go to 'Tools->Options'. In the 'General' tab, locate the 'Appearance' box. Click the 'Fonts' button.

In the window that appears, select 'Language Script' to 'Latin based', 'Webpage font' to 'Times New Roman'. Plain Text font to 'Courier New'.

Please let me know if this solves the issue.

Collapse -
no change.....
by chromejael / May 24, 2009 7:36 PM PDT
In reply to: Font Problem

No, it didn't work. The font settings were already like you said. There was nothing to be changed.

I tried selecting it again anyways, but there was still no change in the wikipedia font

Collapse -
Try this
by vikram_gandhi / May 26, 2009 7:21 PM PDT
In reply to: no change.....

It seems that some of the core fonts like Arial may be missing on your system. To make sure that you all the default fonts installed on your system, do the following step:

Click 'Start'->'Run' and type 'c:\windows\fonts' and press 'OK'. I am assuming that the drive where Windows is installed is 'c:'.

Now you need a fresh copy of a couple of fonts. Use this link to get all the Microsoft Core Fonts:

Download the arial32.exe and times32.exe and follow the exe instructions.

Check the problematic web sites after this.

If this too doesn't work then we need to arrange for the Arial Unicode MS font which is used by Wikipedia's website.

Let me know if this worked or we will then look for an alternate solution

Collapse -
Still faulty
by chromejael / May 26, 2009 8:50 PM PDT
In reply to: Try this

No, it didnt work. I restarted my computer, checked Wikipedia, and its still faulty. I installed the fonts a second time, and it was still faulty.

Collapse -
by chromejael / May 31, 2009 2:39 AM PDT
In reply to: Try this

where can i find the Arial Unicode MS font?

Collapse -
another solution?
by chromejael / June 2, 2009 1:38 AM PDT
In reply to: Try this

I already tried installing the new font , weirdly enough, your post is gone. Anyway, installing the new arial unicode MS font still doesnt work. Is there another solution?

Collapse -
Please help
by chromejael / June 9, 2009 2:38 AM PDT
In reply to: Try this

I'm not fooling with you, I really can't fix this font. Please help me.

Collapse -
Weird fonts in Wikipedia
by danorse / July 14, 2009 8:47 AM PDT
In reply to: Please help

I have the exact same problem -- the only solution I have found appart from using another browser than IE is:
1. Open the "Tools" menu in IE then select the "General" tab.
2. Select "Fonts.." then change font from "Times New Roman" to "Arial".
3 Select "Accessability".
4. Mark "Ignore fonts..."
This will set all the fonts in the browser to "Arial" -- but when in Wikipedia it will at least look quite decent. When you have finished reading Wikipedia you may undo the changes above.
This solution is in the catagory of "Desperate problems need desperate solutions". Happy

Collapse -
by chromejael / July 17, 2009 2:43 PM PDT

Yes, thank you, it works, I am satisified with the solution because only some fonts are changed , not all, thanks for your help Danorse Happy

Collapse -
by HomerSp / September 25, 2009 6:51 PM PDT
In reply to: It WORKED!!!

I had this exact problem, and was able to resolve it by using my original Windows install CD (Windows 7 in my case) and 7-Zip.

Here's how:
Put your CD in the CD-Drive, open it in Explorer and go to sources. Right-click on install.wim and select 7-Zip -> Open Archive (or just drag-and drop the file onto the 7-Zip file manager).
Now in the 7-Zip file manager find your way to the Windows\Fonts folder and extract it to a directory (or your desktop, it doesn't matter). Go to the extracted directory and select all files. Right-click and click Install, be sure to replace all fonts.
Another window should appear saying that the selected font is not valid, just click Close.

Restart your computer and all fonts should be restored.

Collapse -
Bold and Italics appearing in Chrome while using WinXP
by peregrine0ne / August 14, 2013 6:32 AM PDT

What fixed it for me was that there are two different versions of Arial. Use the one that is 290 kb.

I also wrote this code in the "Custom.css" file for chrome:

@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial');

Open it with notepad and save it.

When I did this the problem was solved. You need the correct Arial font from 2007. Bold and Italics weirdness no more.

Collapse -
Weired issue in IE
by nishad_brijesh / July 1, 2010 5:03 PM PDT
In reply to: Trick Recovery

Thanx for sharing your great idea....
Keep it up...It's working....


Collapse -
Hi HomerSp
by kaushikbhargav / August 22, 2011 6:04 PM PDT
In reply to: Weired issue in IE
Happy Thanks a ton for sharing your idea. It really did ya lots Happy

Collapse -
whee it worked
by imaflyingjellybear / August 9, 2010 2:38 AM PDT
In reply to: Trick Recovery

thanks! it worked! love ya! only problem now is... my old bold and italics looked nicer . O:

Collapse -
by beezzzzzzzzzzzzz / May 23, 2011 11:40 AM PDT
In reply to: Trick Recovery

It happened to me in IE9 and it works there too.

Thanks Vikram.

Collapse -
Windows 7?
by MrModenait / November 12, 2011 4:05 AM PST
In reply to: Trick Recovery

Will this solution also work with Windows 7 Hone Premium? Am I in Risk of damaging any files permanently?

Collapse -
Windows 7
by Monster_Mash79 / December 13, 2012 2:12 AM PST
In reply to: Trick Recovery

I couldn't get the options you listed on my windows 7. Can you do an update post to help me with this issue? I get all bold font for the internet. Well, it's either bold or italicized. I have an HP slimline PC running windows 7

Collapse -
Great Solution
by scent_of_aspen / July 20, 2013 4:58 PM PDT
In reply to: Trick Recovery

this (your) guide solved my problems too! thanks so much for this very helpful solution. Happy

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Coming soon

Get behind the wheel with Roadshow

Love cars? Climb into the driver's seat for the latest videos, reviews, shopping advice and picks by our editors delivered to your inbox every week.