Windows Vista forum

General discussion

"Warning: Unresponsive Script" - What Does This Mean?

by beachangel1 / February 14, 2010 7:31 PM PST

I decided to download Mozilla Firefox and stop using IE. I still have IE on my computer as a backup but ever since I downloaded Firefox I get the message above: Warning-Unresponsive Sript, A script maybe running on this page maybe busy or it may have stopped responding and then says I bunch of other stuff. It happens every time I put something in a search field and when I open a webpage, try to close a webpage, etc.
How can I stop this? I know there has to be a way to stop it. I feel like once this problem is resolved I will like Firefox better than IE.

Thanks for any assistance you can give me.

Renee

Post a reply
Discussion is locked
You are posting a reply to: "Warning: Unresponsive Script" - What Does This Mean?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: "Warning: Unresponsive Script" - What Does This Mean?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Possible workaround.
by MarkFlax Forum moderator / February 14, 2010 8:06 PM PST

That message appears when 'script' included in a web page fails for some reason. Script refers to Javascript, and is often used by web site developers to enhance how a web page displays or interacts with the users, ie, you and me.

There is little you can do about faults in web page design as it is not under your control, but you may be able to prevent such scripts from loading using a known and often recommended Firefox add-on called NoScript. You can install this from;
https://addons.mozilla.org/en-US/firefox/addon/722

NoScript helps to control bad and unwanted scripts in web sites, and is a good security measure against scripts that may be harmful.

There's more about this error message here;
http://forums.mozillazine.org/viewtopic.php?f=38&t=473945

I hope that helps.

Mark

Collapse -
Question RE: Stopscript
by manilow1 / February 24, 2011 12:01 AM PST
In reply to: Possible workaround.

I use Facebook every day. You said to try NoScript. The problem is, one of the apps I use on Facebook, does cause that message to come through, but the app eventually does work, however, I don't want to install something that's not going to let the app work either. So is there ANY other alternative?

Collapse -
NoScript
by MarkFlax Forum moderator / February 24, 2011 5:03 AM PST

You can "Allow all scripts on this page" with NoScript, and you can change your permissions on the fly, so NoScript should be a problem.

I often wonder about apps in Facebook. There seems to be no control over them, unlike apple apps or Mozilla apps. That would concern me, and that's why I don't use FB.

Mark

Collapse -
A tip from Julia
by Kees_B Forum moderator / October 6, 2014 5:21 PM PDT

To make the Firefox run the script longer for this you need to:

1. Firstly in the location bar type: about: config and press Enter. This will make the about:config "This might void your warranty!" warning page to appear. Where you need to click on I'll be careful, I promise! For continuing the about:config page.
2. In the about:config page search for the preference dom.max_script_run_time, and double-click on it.
3. Then in the Enter integer value prompt, type 20.
4. At last Press Ok.

This will alllow the sites to continue run the script.

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the school year

Smart tech for smart students

Forget the pencils and notebooks. Gear up your students with these portable and powerful note-taking machines.