You must have a Mac Intel Core 2 Duo, Core i3, Core i5, Core i7 or Xeon processor to run Lion AND be currently running Snow Leopard version 10.6.8
You must have a login for the App Store NOT the iTunes Store and should have a fast internet connection. If you don't have a fast internet (broadband) connection then speak to your local Apple Store.