Windows Vista forum

General discussion

Vista won't sleep

by anunes / May 7, 2007 12:31 AM PDT

I have a new PC with Vista Home premium installed. The system uses cordless microsoft Keyboard and Mouse. With the blue tooth USB device for the keyboard and mouse connected the system does not sleep. If I disconnect the blue tooth USB device the system will sleep. Is there a work around for this. Tks

Post a reply
Discussion is locked
You are posting a reply to: Vista won't sleep
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Vista won't sleep
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Check Device Manager Properties
by tonyny77 / May 9, 2007 8:32 PM PDT
In reply to: Vista won't sleep

Anunes ... I don't have a wireless keyboard and mouse, so I'm not sure whether this will work.

Open Device Manager and check the entries for your keyboard and mouse. On my system, I right-clicked each of these entries to review the Properties. You'll see a Power Management tab for these types of devices. I'm not sure what options you'll see with your wireless devices, but I think the answer to your problem might be there.

I understand from reading another post to the forums that your Network Adapter can wake your system too. Right-click on your network adapter entry and select Properties. You might need to check under the Power Management tab AND the Advanced tab too. The other posted message I saw said to select the Wake Up Capabilities entry from the Properties list and select the Value "None." Although I've made this same change, I'm not certain this is my solution.

Good luck and let us know if you tried these things and whether they worked.

Collapse -
Mouse & multimedia
by Fungi008 / November 12, 2007 2:02 PM PST

I had the same problem: After choosing sleep, Vista would reanimate on its own 1 to 10 seconds later. Annoying!

For me the trick was to realize that perhaps something was waking the computer up ? and then to tell Vista to ignore it. It was both my (1) mouse and (2) Vista's dumb multimedia sharing option.

Mouse: Easy solution (often posted elsewhere). Shut it up. Do this:
Control Panel -> Device Manager -> Mice -> Right-click your specific mouse -> Properties -> Power Management tab -> uncheck "Allow this device to wake the computer"

Vista's dumb multimedia sharing option: More complex (and I don't think anyone else has posted it). Do this:
Control Panel -> Power Options -> If "High Performance" is selected, choose something else, like "Balanced" (I don't know why this works) -> Change plan settings (for the chosen power plan) -> Change advanced power settings -> Scroll down to Multimedia settings -> Choose "Allow the computer to sleep"

My, won't your computer feel much more rested, and your power bill will go down to boot.

Collapse -
by PookiePrancer / March 24, 2008 12:17 PM PDT
In reply to: Mouse & multimedia

My notebook refused to sleep if I used the "high performance" power option (Worked fine with the other power options). The display would go dark, but that was it; everything else was still on. Changing the multimedia setting as you described did the trick!

Collapse -
Thinkpad running Windows Vista Ultimate won't sleep
by vulfie / March 2, 2009 5:40 AM PST
In reply to: Mouse & multimedia

Hey, your tip worked for me too! Thanks much!

Collapse -
by dentness / March 29, 2009 11:19 AM PDT
In reply to: Mouse & multimedia

There is so much babble out there... No one mentions the MM settings. My machine, and I, can sleep now.

Much appreciated!

Collapse -
by matt5912 / June 10, 2009 11:43 AM PDT
In reply to: Mouse & multimedia

This worked perfect for me, changing the MM sharing setting. I knew it'd be something lame like that! Cheers mate

Collapse -
It worked, thanks
by charlybetito / September 14, 2009 12:07 PM PDT
In reply to: Mouse & multimedia

I did the multimedia thing and it worked great thanks

Collapse -
by juhak90 / April 17, 2014 6:52 AM PDT
In reply to: Mouse & multimedia

Multimedia sharing did the job!

Collapse -
by Dafydd Forum moderator / April 17, 2014 6:58 AM PDT
In reply to: Thanks

But thread is 2537 days old.


Collapse -
Thank you Fungi008: it was the mouse
by gigiprozzi / August 24, 2014 9:32 PM PDT
In reply to: Mouse & multimedia

I had the same problem. Disabling mouse from waking up the computer fixed it

Collapse -
by rdev6868 / September 23, 2015 2:34 AM PDT
In reply to: Mouse & multimedia

Hey, thanks for this. I was wondering for ages why my laptop wouldn't go tot sleep..

Collapse -
Would not go into sleep mode( vista)
by laroathwc / November 29, 2015 3:16 PM PST
In reply to: Mouse & multimedia

After hours of things to fix this sleep mode nothing worked. Just as I was going to give up I read your Mouse and multimedia and changed my power plan to balance and wow it worked. Thanks a lot for a simple fix.

Collapse -
Try this
by Phenomx4 / December 8, 2008 10:51 AM PST
In reply to: Vista won't sleep

It's most likely caused by Windows Media Player.

Open WMP and find the settings that allows WMP to search for shared files. Turn off File Sharing and that should let Vista sleep in High Performance Mode.

It worked for I'm sharing my success.


Collapse -
Thank you Phenomx4
by Reply4comments / January 4, 2009 8:49 PM PST
In reply to: Try this

Thanks Phenomx4, disabled media sharing and now my laptop can go into sleep mode while the AC adapter is plugged in + High performance power option.

Collapse -
Windows Media is the problem
by quadraticdude / January 24, 2009 1:37 PM PST
In reply to: Try this

Hey thanks ... so I had the same problem - my laptop won't go into sleep mode completely, only the screen would turn off and moving the mouse would bring it back to the welcome screen.

So I recall setting up network sharing for my xbox through Windows Media Player. Went into settings, turned sharing off ... and it sleeps properly!

Collapse -
Possible fix
by karthakon / February 17, 2009 11:03 PM PST
In reply to: Vista won't sleep

I'm not sure if any of the other solutions here worked for you but they didn't work for me. I thought I'd post my fix in case anyone else is having the same problem.

My mother board has a USB Jumper setting. One position for S1 Sleep the other for S3. Vista enables S3 sleep by default and the the default jumper position on my mother board was S1. I moved the Jumper over and and every thing works as it should. Vista power options and motherboard BIOS options are set to default.

Collapse -
For those that want to try. MCE STANDBY TOOL (MST)
by R. Proffitt Forum moderator / February 17, 2009 11:21 PM PST
In reply to: Vista won't sleep
Collapse -
Clear "Enable write caching on the disk" check box
by KauaiBilly / June 28, 2009 1:02 AM PDT
In reply to: Vista won't sleep

I also tried all these other suggestions, but none worked. Here's what (finally) worked for me:
Open Device Manager (Control Panel > System and Maintenance > Device Manager).
Expand the "Disk Drives" list.
Right-click each hard drive, and then choose Properties.
Choose the Policies tab.
Clear the "Enable write caching on the disk" check box.

Hope this helps someone.

Collapse -
That's the ultimate in voodoo.
by Larry_Brown / August 3, 2009 9:54 PM PDT

Wow! That's the ultimate in voodoo. Kudos!

Collapse -
An excellent, detailed discussion of Visata Sleep problems
by loriwaukee / July 19, 2009 10:21 PM PDT
In reply to: Vista won't sleep

I tried a number of the fixes on this page and they did not work for me. More are listed at this forum:

I was able to find the solution to my probem (my Network adaptor). Best of luck to all the other insomniac computers out there.

Collapse -
one of the suggestions worked for me
by BCY123 / January 31, 2011 8:53 PM PST

after many discussions with Dell...and no luck, i had a machine that would not go into sleep when plugged i used the suggestion by fungi008 (see above)...and it totally worked

here it is:

Vista's dumb multimedia sharing option is the issue: Do this:
Control Panel -> Power Options -> Change plan settings (for the chosen power plan) -> Change advanced power settings -> Scroll down to Multimedia settings -> Choose "Allow the computer to sleep

That's it..hope it helps someone


Collapse -
This solution works
by kjennett / June 19, 2012 4:13 PM PDT

Working through this thread this was the first solution that worked for me. Thanks BCY123.

Collapse -
Vista won't sleep because of Browsers!
by jskfjow / January 6, 2010 9:16 PM PST
In reply to: Vista won't sleep

My Vista wouldn't sleep, so I closed all programs, restarted the computer, did not open any programs, tried the sleep mode, and it worked. When I opened up my Firefox browser, it worked. When I opened up a couple of websites, is DID NOT SLEEP.

In my situation, it seems that websites would wake up my Vista.

Try it!


Collapse -
For me it was the power jack.....
by scifi1972 / November 27, 2012 5:18 PM PST
In reply to: Vista won't sleep

For the last week I've been scouring the net trying to find a solution. My laptop would enter sleep mode via closing the lid or manually choosing "sleep". It would keep running with the lid closed & immediately come out of sleep mode when I chose it manually. I tried every suggestion, power settings etc. After everything else didn't work, I disconnected the power cord & voila, it went to sleep. Turns out the issue was the computer's power jack & the power cord not connecting properly. I'm posting for others who might see this thread & try this option.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.