Windows Vista forum

General discussion

Vista's explorer.exe uses 100% CPU

by dragoncheval23 / January 29, 2008 7:52 AM PST

I have Windows Vista Home Premium that came pre-installed with a HP Pavilion dv2600 with AMD Turion64 TL-50, 1GB Ram, and a Nvidia graphic card. It functioned perfectly well until yesterday, when explorer.exe started using 100% of my CPU. This only happens when I open a folder, but after I close it, this continues even if I am doing nothing. I can only stop this when I finish explorer.exe and start it again. Is it a virus? what can I do to stop this?

Post a reply
Discussion is locked
You are posting a reply to: Vista's explorer.exe uses 100% CPU
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Vista's explorer.exe uses 100% CPU
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
few things
by rhino_31 / January 29, 2008 9:10 AM PST

well what antivirus software are you running, and what spyware are you running as well? I see a problem right off the bat, and it's 1gb of ram with Vista.... go there, and upgrade your ram to 2gb's. it's easy to upgrade. just find out what ram is compatible with your unit, buy it, and throw it in. it's easy enough to do. I just added another gig to my wife's HP, and it's working wonderfully now.

Collapse -
by dragoncheval23 / January 29, 2008 9:22 AM PST
In reply to: few things

I am currently running Norton Internet Security 2008. And 1GB of Ram had worked perfectly fine, I don't need more except when I try to run 10 apps at a time (never). I am currently working on the HP and the CPU usage by explorer.exe is none but I think I still have the problem, so please help!

Collapse -
Windows Vista constant high CPU due to explorer.exe
by ladhani / June 15, 2008 10:45 AM PDT

I am afraid this does happen in Windows Vista!

Suddenly my Vista computer had a very bad performance and everything started to work
very slowly, especially windows mail.

The Task manager showed that CPU was constantly at 50% - 80% even if I was
not doing anything and let the computer untouched for a few hours.

Most of the CPU time was taken by explorer.exe.

After trying many things and struggeling with this issue for many many hours,
I slowly got some idea.

Appearently something under water goes wrong with your user profile and the search
index settings of the files in your USER folder. Vista tries to index stuff in this folder
and gets completely crazy. It keeps on trying and trying and eating up most of
your CPU time (explorer.exe).

The only lasting working solution, I found was to make a completely new User Account.
After making the new User Account, you can only copy a limited number of stuff
from your original User Account. Some stuff when copied to your new User Account
will again make your new User Account go crazy.

Also, I turned off the search indexing for the new User Account, including all subfolders.

Here is what I did:


* Backup your original User Account, Mails and any other critical files.

* Make a new user and make an extra help account (for example called: admin with Administrator rights).

* Make sure that the search indexing for the new User folder is TURNED OFF
(via properties of the folder -> Advanced)

* Manually and carefully only copy back stuff you really need.

* Use Command line with Administrator rights to copy User stuff step by step.
The moment you see the CPU getting crazy again, delete the last User stuffs you just copied.

To restore your e-mails:

1 - copy the e-mail folder to another partition in folder mail2 (for example: f:/mail2).
2 - in the new user login, set the archive folder of Windows mail to f:/mail.
3 - delete f:/mail and rename f:/mail2 to f:/mail (BE CAREFULL! make sure you have a backup).

It's quite a headacke, but it will bring down your CPU to 2% - 10% when you are idle.

Collapse -
by quindrax / June 16, 2008 1:12 AM PDT

Thank you! I have been struggling with this problem for weeks, and so far this solution works perfectly!

Collapse -
Explorer.exe high CPU when browsing folders
by ebecks / October 16, 2009 1:18 AM PDT

Migrating to a different user account seems drastic unless this problem occurs regularly.
From what I've seen, the problem with explorer.exe high cpu usage occurs when browsing to a folder that contains video files with unusual or corrupt codecs, or corrupt video files. It seems explorer is trying to index and also generate thumbnails for these files (even if the folder option of using only icons is selected).
I recommend using a different file browser (freecommander dot com has a good freeware browser), moving the offending files to a separate folder and not accessing or browsing them from explorer.
You can also set the folder option "Launch folder windows in a separate process" which will allow the killing of the offending explorer.exe process without the bad side effects of losing the taskbar and desktop icons.

Collapse -
I fixed it easily - switch off drive indexing
by felix_s / September 1, 2010 10:41 PM PDT

Christ it was horrible.. 97% plus of the CPU being used. Problem only started last night and I had created some new large mp3 files last night. Other users wrote that when it "indexes" these it can get overwhelmed especially if they are corrupt.

So the following EASY advice fixed it:
My Computer > C drive
right click > properties
The UNSELECT "Index this drive for faster searching"

faster my ***... faster searching but if there is a corrupt file perhaps everything else like a snail or a tortoise.

It gave the option of just "c:\" or "all subfolders" The subfolders option was taking too long so i just did "c:\" and that has fixed it totally!!!!!!!!!

Even revisited the possibly corrupt .mp3 and that doesn't seem to cause any disasters. Oh well, took about 120 min to fix the pc...

Collapse -
You can try...
by wertysdf / September 25, 2010 12:31 AM PDT

Go to start menu properties, click on the start menu tab, click customize, then under search files, check don't search for files. worked for me.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.