My guess is that it's the comments section. One of those features in Word not everyone knows or uses. At work, we use it when reviewing a colleagues draft document. But you can use it yourself also to make notes for later use when composing a document.

http://blogmines.com/blog/2010/02/17/how-to-insert-a-comment-in-word-2010-document/ shows how to add them. As soon as you add on, the gray bar appears.

The uppermost picture in http://www.officetooltips.com/word/tips/customizing_revision_marks.html shows where to change from seeing that gray bar to not seeing it. In the top right field of the Tracking box on the Review tab, change "Final: show markup" to "Final". And it's gone.

So it's just a setting.

Kees