The uverse tech couldn't get a Windows 7 machine to connect with uverse's stock wifi settings. There is a page on the uverse router Settings, Lan, Wireless called "Wi-Fi Protected Setup" that the ATT tech disabled and bam, the windows 7 machine was then able to connect.

I also use WPA/WPA2 PSK and a simple SSID for security.

Works now.
Bob