Mac OS forum

Resolved Question

Using a I Mac OS X 10.6 DVD to upgrade a G4

by ed Koepsell / January 28, 2013 4:49 AM PST

I have a G4 Tower, PN 614-0157 running on OS X 10.4
I Would like to install OS X 10.6
I Have a I Mac Model MC508LL/A which has a Mac OS X 10.6.4 Install DVD

Can I use that DVD to Up Grade the G4 to OS X 10.6?
Also can the Applications Install DVD be used?


ed Koepsell has chosen the best answer to their question. View answer
Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Using a I Mac OS X 10.6 DVD to upgrade a G4
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Using a I Mac OS X 10.6 DVD to upgrade a G4
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by ed Koepsell

Collapse -
You could always try but I would not hold my breath.
by mrmacfixit Forum moderator / January 28, 2013 7:17 AM PST

Restore discs, which are usually grey, are generally machine specific and will not install on machines other than the one it was designed for.

You have at least two things going against you here:

1. G4 has a PPC processor
2. The iMac has an Intel processor.

Given that, I would not be surprised if the Restore disc took one look at the G4 and tell you it cannot install on this machine.


Collapse -
Will not work.
by ziptie / February 1, 2013 9:54 AM PST

10.5 is the last version of OSX that will install on any G4 or G5. I wouldn't do that unless you have at least a 1 GHz processor, and a GB of ram. Your probably better off just sticking to Tiger.

Collapse -
You are correct.
by mrmacfixit Forum moderator / February 1, 2013 9:16 PM PST
In reply to: Will not work.

I forgot to post para 3.


Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


Having Wi-Fi troubles?

From the garage to the basement, we blanketed every square inch of the CNET Smart Home with fast, reliable Wi-Fi.