PC Hardware forum

General discussion

USB Flash Drives Not Showing in "My Computer"

by library_tech / September 22, 2009 11:32 PM PDT

System: Dell Pentium 4 - Windows XP Pro SP3 - on a domain

Problem: I work for a public library. We have several (not all of them) of our Public Access Computers (PAC) that when a patron plugs their flash drive into the USB ports, the computer recognizes it, assigns it a drive letter that does not conflict with any other drive letters and still does not show the drive in "My Computer".

Solutions I have tried that did not work:

1. Drive letter conflict due to network drive mappings.
Result: I have eliminated all partitions and network drives. The computers simply have a C: drive and the dvd/cd drive in D:. PROBLEM PERSISTS.

2. Removing Daemon Tools, including SPTD.
Result: The drivers and program were not found on the computers. I installed them simply to be able to uninstall them. After uninstall, PROBLEM PERSISTS!


Any help on this would be much appreciated.
Library_Tech

Post a reply
Discussion is locked
You are posting a reply to: USB Flash Drives Not Showing in "My Computer"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: USB Flash Drives Not Showing in "My Computer"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
You claim a drive letter is assigned but
by R. Proffitt Forum moderator / September 22, 2009 11:47 PM PDT

Does not show in Explorer (which is "My Computer". That's proper and supported. Research TWEAKUI HIDE DRIVE LETTERS and you'll see where Explorer does not have to show the drive.
Bob

Collapse -
Tried it...
by library_tech / September 23, 2009 3:12 AM PDT

I checked the registry and modified the entry to have explorer show all drives. Still unable to see the flash drives in "My Computer" or Explorer.

Thanks though.

Collapse -
This is more than one entry.
by R. Proffitt Forum moderator / September 23, 2009 3:30 AM PDT
In reply to: Tried it...

Remember you told me that the drive letter is assigned. But not showing in My Computer. There are POLICY settings at play too but a clean install of XP does not do that.

Be sure to enable AIN too. (google XP AIN if you forget it.)
Bob

Collapse -
...
by library_tech / September 23, 2009 3:38 AM PDT
Collapse -
That's no bug.
by R. Proffitt Forum moderator / September 23, 2009 5:31 AM PDT
In reply to: ...

Hiding drives from My Computer is a well known area. I haven't read a reply or screen shot that shows TWEAKUI with the drives all good.

Nothing really busted here. Just keep asking why they locked out the drive letters from Explorer.
Bob

Collapse -
Checkout
by Willy / September 23, 2009 12:25 AM PDT

Since you're in a setup that may have various sorts of flash drives of all types and sizes, thus flash drives themselves can be a PITA, because they're junk. I exclude any OS acknowledgments, etc. to proceed. If used, is there a USB type firewall, check that? Our local library doesn't even provide USB access as the possibility of malware attacks. Then, there is the issue of rear and frt. panel USB ports, over time the frt. port(s) get hosed or lack the "umphf" to power USB devices. Next, there is the MAC and PC side effects, they may work or may not after use from either system to the other. Last, did you manually assign a drive letter to the flash drive within HD/computer(i forget) management? As you can see many things may effect the USB port, check these out.

tada -----Willy Happy

Collapse -
Thanks
by library_tech / September 23, 2009 3:13 AM PDT
In reply to: Checkout

I did try manually assigning a drive letter, and that didn't change anything.

Thanks for the advice though.

Collapse -
An update
by library_tech / September 23, 2009 3:22 AM PDT

So, I have continued to try different things from reg edits to services to mapping, still no success.

However, I am able to open from and save to flash drives. When I open a program like "Paint" or "Word", I can open the flash drive and open a file off of the flash drive, I also can save to the flash drive. However, it still does not show in "My Computer". I have uploaded a screen shot that shows disk managment, my computer, paint, and the save as window from paint if you would care to see it. here is the url.

http://skyways.lib.ks.us/library/emporia/problempic.JPG

Collapse -
I hope this helps
by Ross Quinnell / September 23, 2009 4:40 AM PDT
In reply to: An update

Go into your bios sand find where usb settings are and make sure that you set them usb 2.0 and check if everything ells in the usb settings are OK .Also try to enable P&P in the bios.

Collapse -
Checked.
by library_tech / September 23, 2009 10:34 PM PDT
In reply to: I hope this helps
Collapse -
I've Herd
by Ross Quinnell / September 24, 2009 12:47 AM PDT
In reply to: Checked.

that if the machine uses usb 1.0 and the usb device is 2.0 it may do that and even the other way round.

I think the only way your going to solve this is get a new one

Collapse -
Just so you know.
by R. Proffitt Forum moderator / September 24, 2009 12:57 AM PDT
In reply to: Checked.

This is not a BIOS, USB version or hardware issue. It's just a policy setting that you haven't found yet. The issue is well known so all that you need to do is find the setting.

Collapse -
find the setting...
by library_tech / September 24, 2009 1:17 AM PDT
In reply to: Just so you know.

Any idea what setting?

Collapse -
Just the usuals.
by R. Proffitt Forum moderator / September 24, 2009 1:37 AM PDT
In reply to: find the setting...

We've covered using TWEAKUI so what's next is to ask the person who installed the OS what policy they used on Explorer.

Some get confused over My Computer and Explorer. Explorer is what's running that show.

Collapse -
The guy who installed the OS....
by library_tech / September 24, 2009 2:26 AM PDT
In reply to: Just the usuals.

He was fired. I am his replacement.

Collapse -
Cool.
by R. Proffitt Forum moderator / September 24, 2009 2:49 AM PDT

Always fun to re-discover or ask "now what did they do?"

There are many ways to lock down Explorer. Look at all of them.
Bob

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.