Windows Legacy OS forum

General discussion

Unknown Publisher Warning

by Rowelax / June 2, 2005 9:06 AM PDT

OK I have a Windows XP Pro machine with SP2 installed on it for a company. I am running a program that requires me to go on the network and run a program from a server (an .exe file to be exact). It runs and everything but everytime I run the program I comes up with a Security warning. IN the box it says: "This publisher could not be verified. Are you sure you want to run this program?" Then it tells me the name of the file and Unknown Publisher. Then it gives me the option to Run or Cancel. I know you get this warning if you run stuff over the internet (I know from my home computers. Especially Applications which this is.

My question is this, How can you shut off that warning? I have tried everything in the Internet settings Including turning off the check for Publisher certificate in the Advanced tab in the internet options. I have turned everything in the Local Network Security tab to Enable and both still give that warning. I know if i click run i can run the program but I don't want that warning to come up for users. So if anyone can tell me how to turn off that warning in XP that would be awsome. Thanks.

Discussion is locked
You are posting a reply to: Unknown Publisher Warning
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Unknown Publisher Warning
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
A little registry editing should help...
by uksamo / June 3, 2005 3:14 AM PDT

Unfortunately you can't disable this message for just one program but you can remove it completely. You'll need to edit the windows registry (if you've no idea what the registry is then I'd get someone who knows to help).

Navigate to the following keys, and change their data to that listed below, restart and those annoying messages should cease:

Key "HKCU\Software\Microsoft\Internet Explorer\Download\CheckExeSignatures"
data: "no"

Key "HKCU\Software\Microsoft\Internet Explorer\Download\RunInvalidSignatures"
data: 1

Key: "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Associations\LowRiskFileTypes"
data: .zip;.rar;.cab;.txt;.exe;.reg;.msi;.htm;.html;.gif;.bmp;.jpg;.avi;.mov;.mp3;.wav

Collapse -
Tried that
by Rowelax / June 3, 2005 8:26 AM PDT

Ok went to the registry went to those keys and they were already set to the values that you marked. And the last key isn't in windows XP I don't think. There is no Associations in HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies

Is there another key that it might be under. I am going to keep looking myself and post if I find something.

Collapse -
"I SPY a Microsoft BUG"
by nworley / June 4, 2005 7:54 AM PDT

If there is a chance you happen to be running Microsoft's MicrosoftAntiSpywareInstall.exe found at:http://www.microsoft.com/downloads/details.aspx?FamilyID=321cd7a2-6a57-4c57-a8bd-dbf62eda9671&displaylang=en&Hash=84H3RVB

It could be the culprit as evidenced by a posting on http://netrn.net/spywareblog/archives/2005/01/07/adware-vs-microsoft/

"It?s started folks. WeatherBug Miffed at Microsoft?s Spyware Classification .


Microsoft Corp.?s newly released anti-spyware is flagging a component of AWS Convergence Technologies? WeatherBug application as a threat to Windows users, prompting an immediate complaint from the Gaithersburg, Md.-based company."

Collapse -
Maybe not
by Rowelax / June 4, 2005 9:36 AM PDT

I don't thing that it is a bug because I have seen this message with every windows XP system. I happens with me when I try and run a install over the internet.

Collapse -
Anyone Else have an idea about this one
by Rowelax / June 7, 2005 8:17 AM PDT

I have tried everything. Did microsoft make it so you can't turn that off?

Collapse -
Unknown Publisher Warning
by billzhills / June 7, 2005 10:18 PM PDT

If I am reading this post correctly you are attempting to run an application from a remote desktop. If so Import the programs publisher in Certificates under Internet Properties - Content.

I don't know the proceedure on how to accomplish this task or if I am on the correct path. (I'm not networked trained)

You may also want to name the application you are attempting to run. As the application itself is the issue.

Bill

Collapse -
The publisher needs a certificate
by Rowelax / June 8, 2005 1:44 AM PDT

Yea I have tried to import that program awhile ago but you need a actual certificate or that is what the import program is telling me. I have talked to the actual company and they can't figure it out either. The only way I can see to turn it off is for the company where the software came from issues a publishers certificate with the software. Or to find a way to turn off that warning (I am not seeing a way to find that one).

I know it has something to do with service pack 2. After I install actually anything in service pack 2 with an unknown certificate (includes network or local)it always gives me that security warning. I am starting to think that it is so inagraded with window that you can't shut it off.

Collapse -
What is the fix action to "unknown publisher" ?
by RooHann / January 5, 2006 1:46 PM PST

I've spent the last three days surfing, questioning, etc etc etc to total 18+hrs and still I'm no closer to a resolve as when I started. The only consistant finding is that I'm not the only one having this problem; it's effecting the network and local system(s); and appears to be linked to windows XP Home & Pro, SP2.
Did you receive/find a resolution to "unknown publisher" ?

Collapse -
Try De-Installing and Re-Installing Microsoft Net Framework
by SoCalTech62 / June 3, 2009 11:50 AM PDT

I know that this is a very tardy response but we just ran into the same problem. We followed all the steps above but that did not help. One quirk in the process is that the PC was running IE V6. We thought that maybe upgrading IE to V7 would take care of the problem since we had already followed the steps but that did not help at all. What finally solved the issue was de-installing Microsoft Net Framework V2, restarting the PC, and re-installing Microsoft Net Framework V2. The application triggering the "unknown publisher" message happened to be a web-based product. Microsoft Net Framework had become corrupted I was told and had to be de-installed and re-installed.

Collapse -
How to fix the problem for once and for all!
by Megleris / June 17, 2009 3:45 AM PDT

In order to stop getting the error, it's a fairly simple process. Open up Internet Explorer, Tools, Internet Options, click the Security tab. Once there, click on "Local intranet". The Sites button should be clickable. Click on it, and uncheck the "Automatically detect Intranet network". Leave "Include all local sites not listed in other zones", "all sites that bypass the proxy server", and "all network paths(UNCs)" checked. This should remove the "Unknown publisher" warning.

Collapse -
Windows XP Unknown Publisher problem
by margal168 / June 8, 2010 2:28 AM PDT

I fixed my problem and although I don't know if it will work for everyone here it its:

1. Internet Options/Security tab/Trusted Sites/Sites: added my web site.
2. Enabled Run ActiveX controls and plug-ins. It was set to Prompt before.
3. Restarted IE.

Good luck.

Collapse -
Here's how you fix this... really
by elnator / March 28, 2011 11:20 PM PDT

You are getting this message because IE's security zones don't accurately detect local area networks. It happens on a very regular basis. To fix the issue some folks here have given partially correct answers but here's the full way to do this (Without hacking your registry, which you should never do except as a last resort).

1) Open Internet Explorer
2) Go to Tools - Internet Options
3) Go to Security
4) Click on "Local Intranet" in the zone window.
5) Click on the "Sites" button below the zone window.
6) Uncheck the Automatically detect option. Make sure the 3 options below it remain checked. If they aren't, check them.
7) Click the "Advanced" button
Cool Add the server name you are going to. ie:
file://myserver
or, if you are reaching to the server by IP instead of server name:
file://ip.ip.ip.ip (where the ip's are the ip address of the server if that is how you are getting to it)
Un-check 'require server verification (https:) for all sites in this zone.

Close all the windows, restart IE and ensure the changes took.

Now you should be able to run any files from your server without getting nagged by the security check window.

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech explained

Do you know what an OLED TV is?

CNET explains how OLED technology differs from regular TVs, and what you need to know to make the right shopping decision.