What won't open? Safari or the Update?

If the update requires 10.8 then it would not have installed anything.

P