Mac OS forum

General discussion

Trouble using WD External HD on iMAC G4 OS 10.4.11

by Nickowner / August 14, 2009 7:27 AM PDT

When I try to format the Western Digital Hard Drive My Book, I get an "imput/output error." I started with a My Passport for MAC, which gave me the same message. WD tech support thought it might be that I needed an extrenal power source, so I got the My Book...but I get the same error message. This is after following all the steps in Disk Utility, trying to partition...
I have a Power PC iMAC G4 and am running 10.4.11
Any advice?

Post a reply
Discussion is locked
You are posting a reply to: Trouble using WD External HD on iMAC G4 OS 10.4.11
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Trouble using WD External HD on iMAC G4 OS 10.4.11
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Wonder if it has anything to do with
by mrmacfixit Forum moderator / August 14, 2009 9:26 AM PDT

the USB 1.0 ports on the computer but USB 2.0 ports on the external drive.

Any chance you can exchange that drive for a Firewire drive?


Collapse -
WD External HD on iMac G4
by geldstro / August 14, 2009 11:59 AM PDT

I believe you can possibly purchase a USB 2.0 network card which is easily installed and might possibly solve your problem. I also have a WD My Book (Home edition) which comes with 2 firewire 400 ports as well as one USB 2.0. The firewire is your better option assuming you can exchange the drive. According to the specs from your machine only has USB 1.1.

Collapse -
Thanks for these replies
by Nickowner / August 14, 2009 12:06 PM PDT

The WD My Book with the Firewire requires system 10.4.8 or higher...I'm running 10.4.11

Collapse -
That's good
by mrmacfixit Forum moderator / August 14, 2009 11:38 PM PDT

Technically, the firewire WD will work with any computer that has a firewire port.

The requirement for 10.4.11 may be because it has software on it that requires that version of the OS.
Firewire has been around, on the Mac, since the first iMac was released with System 9

If you have the version of the My Book that already has the firewire ports, all you need is a firewire cable and you are in business.

Let us know how you get on


Collapse -
You cannot install a USB 2.0 card
by mrmacfixit Forum moderator / August 14, 2009 11:35 PM PDT

in this iMac.


Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions


CNET bought a house!

Take a look inside the house where we will be testing connected locks, thermostats and other smart home products so we can tell a complete story.