Make sure there is a default printer selected in your Start, Settings, Printers. Good luck on the other items.