Computer Help forum

General discussion

System clock loses time - have tried everything

by karelaorange / February 10, 2011 2:01 AM PST

I accidentally posted this in the wrong forum, so I'll try it again here.

I have tried all the normal suggestions, please read carefully:

I have a Dell XPS M1330 laptop running Vista. About a year ago, my system clock started to lose time. I scoured forums and tried everything. I replaced the Bios battery. I finally found something that seemed to work- I powered down my laptop, unplugged it and removed the battery. I then disconnected the BIOS battery and pressed the power button to make sure there was no excess charge. I then put everything back together and started it up. I had to reset the time, but it would keep the time accurately AS LONG AS I DIDN'T POWER IT DOWN. If it somehow powered down, I would have to redo the whole thing.

This process no longer does the trick. My laptop doesn't lose minutes here and there, it loses about an hour all at once. This is so frustrustrating for many reasons, mostly because our work wireless network will knock me off (I suspect because it thinks I've been idle). If I put the laptop to sleep, it will wake up reading the same time as when I put it to sleep.

Please help me... I've tried all the usual, normal things, but none of them seem to work..

Post a reply
Discussion is locked
You are posting a reply to: System clock loses time - have tried everything
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: System clock loses time - have tried everything
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
The news is good.
by R. Proffitt Forum moderator / February 10, 2011 2:06 AM PST

Now there is that issue about time zones but most will write it's off by 30, or by hours but you didn't reveal if you checked that.

Let's hope it's the usual.
Bob

Collapse -
Time zones....
by karelaorange / February 10, 2011 4:50 AM PST
In reply to: The news is good.

By "that issue about time zones" I assume you are asking if I've confirmed that I'm in the correct time zone, which I have. Supposing the only place you do that is in the Date & Time Settings. And it continuously lags, slower and slower, it doesn't just stay one consistent time. I've had it tell me it was the year 1600, which obviously messes with my programs.

Collapse -
NTP
by squidie / February 10, 2011 5:51 AM PST
In reply to: Time zones....

Have you checked that the NTP service is running on your O/S?

Collapse -
Tried This?
by Grif Thomas Forum moderator / February 10, 2011 5:57 AM PST
In reply to: Time zones....

Because it appears like you have a system clock issue, have you tried setting up the clock to repeatedly sync with one of the internet time clocks? If not, here's how:

http://www.howtogeek.com/howto/windows-vista/dealing-with-windows-vista-time-sync-problems/

And just a thought... A number of Vista users were able to fix the problem by disabling/uninstalling their antivirus program.. Many using Norton were having such issues. If disabling it fixes the problem, then you might want to try a different program.

Hope this helps.

Grif

Collapse -
If enabling NTP and letting it set the time does not fix it.
by R. Proffitt Forum moderator / February 10, 2011 6:07 AM PST
In reply to: Time zones....

Then the news is grim. To fix it we have to replace the motherboard.

Collapse -
You said the year was 1600??
by Steven Haninger / February 11, 2011 2:28 AM PST
In reply to: Time zones....

See if you can enter the BIOS and set your clock to that year. My guess is that you cannot and I've not seen a board that would set back or forward more than a very few decades and certainly not 400+ years. If you can't set it to a date you've seen, you most likely have an OS or software issue. Many years ago, I remember a few shareware programs that would monkey with the clock and usually would just stop it. If this issue is easy to repeat, you might try just booting to the BIOS screen and letting it sit there over night this way to see if the clock keeps good time. If it works ok this way but not when running your OS, you've got another reason than hardware for this.

Collapse -
I have the same problem...
by Az_90 / March 26, 2011 7:19 PM PDT

...and only replaced the CMOS battery a few months ago (December).

If I boot to BIOS and go to the date/time settings, the clock does not tick at all. It just sits on whatever time it was when the PC was shut down / restarted (assuming it can remember that).

If I run the Dell Diagnostics, it suspiciously hangs at 20%, being 'IRQ 8 realtime clock interrupt'

I've had Windows tell me it was the year 9999 earlier this week.

I suspect it's a case of 'time for a new motherboard', though I'm hoping someone out there might have some clever idea (given the age of the laptop, replacing a mobo isn't really a worthwhile option).

Curiously, a Google search for this returned a number of reports of the same problem, all in the early months of 2011.

Collapse -
This usually means the motherboard failed.
by R. Proffitt Forum moderator / March 27, 2011 5:31 AM PDT

While it might be possible to fix a motherboard, today no one does that. Hope it's under warranty.
Bob

Collapse -
Another falling foul of a dodgy ticker!! XPS 1530 IRQ8 Clock
by Vanquish6 / May 16, 2011 9:32 PM PDT

Hi all, searching for help with a similar issue. My 2.5 yr old XPS1530 started losing time about 2 weeks ago. Again when the power shuts down the time freezes. Initially it was giving me an error message when I tried to update via the Internet Clocks ntp. etc.
I've now re-installed windows,drivers, updates etc and the time is still freezing when power is off or computer is shut down.
Cleared DSKCHK OK, then ran Dagnostics from F12 and it sticks on 20% with "IRQ8 Realtime Clock Interrupt".

If I can get this sorted I'll feel comfortable creating a Clean Back-up for future restores.. which I have no doubt are not far away ?!?

Any advice, guidance or assistance is much appreciated.

PS. First HDD was replaced after 5 months when it gave up, battery lasted all of 18 monthhs and the second one is now also starting to lose power and not charge fully. My 2nd and quite possibly last investment with this company.

Collapse -
I have the same problem
by oferyuval / November 5, 2012 2:26 AM PST

Did someone find a solution for it ? Confused

Collapse -
Why yes. Too many times.
by R. Proffitt Forum moderator / November 5, 2012 2:36 AM PST

From turning on NTP, replacing the battery on the motherboard, setting the clock to changing the motherboard, this has been fixed so many times I've lost count.
bob

Collapse -
cmos battery
by francisco85 / May 30, 2013 7:10 PM PDT

Hi keep in mind not all Dell CMOS batteries are the same. Had the same problem and replaced the battery from a different model Dell (with blue sheath) and the problem persisted. Fixed with problem with another battery (black sheath 3 wires with same colours)

hope this helps anyone else with the same problem

Collapse -
same problem
by jojo_webmail / September 8, 2013 6:12 PM PDT

i have exactly the same problem as u.. mine is also DELL XPS M1330, been dealing with the clock problem for more than a year. the CMOS battery is fine.
- the clock lags behind by about 7-9 minutes
- then oddly, after a while, it corrects itself, then lags again.

the problem was fixed in 2 ways:
- i changed my laptop's position : it stops lagging when i moved to a different floor in the building; then after a few days, when i came back to my old position, the clock lags again... it could be magnetic fields affecting the computer.

- i used AVIRA anti virus software before, then i changed to TREND MICRO. after that, my clock is running fine so far. even if i came back to my old position, the clock is working fine.

these XPS... strange, no?

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech Tip

Stuck without Internet and want to watch movies?

CNET shows you how to download movies and TV shows onto your device using Amazon Prime so you'll always be entertained.