AVG forum

General discussion

Something is blocking my internet connection to servers

by Tenex007 / December 26, 2009 9:33 AM PST

The reason why I am posting this on this board is I have recently removed an expired AVG firewall and the problem started since that day.

This is a very strange problem.

I use XP 32 bit home edition. I can browse the net just fine. Download things through web browsers etc.... fine. But the problem is every time I try to connect to a server or a p2p connection (ie: as a torrent client) through my internet connection it fails.

For instance I downloaded a download manager for an anti-virus and once I clicked on it, it failed to connect to the server.

I tried to update windows defender, it failed to update asking me to download updates manually.

I tried to connect to a game server that I could connect to just fine up until 3 days ago and it says failed connecting to the server. (reinstalled the game a few times and still the same results)

I don't understand what is causing the problem. I used to have a paid AVG firewall/antivuris (which I had downloaded last year and I believe it was V 8.5 or something) but the license expired two months ago and it seemed that it was not working anymore. Since I had caught a fake malware type virus I decided to pay and update my AVG firewall/anti virus license. Once I paid for it, the email generated license did not work and being through the Christmas and all I decided to remove the paid version of AVG and replace it with free AVG antivirus. Cut the long story short, Windows defender caught the malware/spyware and removed it but the connectivity problem I mentioned above still exists.

I have tried to even disable windows firewall to see if I can connect to the game server but it still fails and the game thinks I have no internet connection.

I have tried flushing the dns through command line, it did not help. I also used system restore to restore my computer to a week ago when everything was fine and when I did, I could not even access the internet with firefox. So I did a undo restore.

I think since I have removed the expired AVG firewall and windows firewall has kicked in, some messed up setting is blocking my access to some servers. (A residue of the paid version of AVG firewall or identity theft) or it may be a proxy problem.

Should I do a repair on XP?

What could be possibly blocking my connection to some of these servers? Is there a way to test and find out?

Thanks in advance

Post a reply
Discussion is locked
You are posting a reply to: Something is blocking my internet connection to servers
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Something is blocking my internet connection to servers
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
It may still be malware damage.
by MarkFlax Forum moderator / December 27, 2009 3:33 AM PST

You said that you caught a fake malware type virus, so it may be that there is still some infection there.

Follow Grif's advice in the link below, using another computer to download Malwarebytes' Anti-malware and it's definition files, and copy those across to your system to install and update;

http://forums.cnet.com/5208-6122_102-0.html?messageID=2969621#2969621

If you uninstalled the paid version of AVG with Firewall correctly, then I don't see this to be an AVG or firewall problem.

Just another note. You use P2P and torrents. That makes me wonder where the malware came from.

Mark

Collapse -
RE: Something is blocking my internet connection to servers
by Ondrej_AVG / December 27, 2009 3:37 PM PST

Hi,

if you have issues with AVG paid version, please contact our AVG technical support, which have enough tools to help you with this situation, on address:

http://www.avg.com/ww-en/customer-support

Thank you

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech for the school year

Smart tech for smart students

Forget the pencils and notebooks. Gear up your students with these portable and powerful note-taking machines.