Samsung

Question

smart tv will not connect to wireless router

by bobdep / February 27, 2013 12:42 AM PST

I have a samsung led un32eh5300 Tv and will not connect to the wireless router. The message is invalid gateway.
The router works with other devices.

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: smart tv will not connect to wireless router
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: smart tv will not connect to wireless router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Start with the basics.
by R. Proffitt Forum moderator / February 27, 2013 12:50 AM PST

Wireless router at about 20 feet, nothing fancy in the names and passwords, do not hide the SSID (outdated security advice).

Bob

Collapse -
smart tv will not connect to wireless router
by bobdep / February 27, 2013 1:43 AM PST
In reply to: Start with the basics.

Router is15 feet away and router was reset to default settings several times using original SSID and password.

TV still says invalid gateway.

Collapse -
At 15 feet try an Ethernet cable.
by R. Proffitt Forum moderator / February 27, 2013 2:02 AM PST
Collapse -
Answer
Latest firmware?
by sunwatcher / February 27, 2013 2:11 AM PST

Have you tried downloading the latest firmware on to a USB drive and updating your HDTV?

Collapse -
I like this idea.
by R. Proffitt Forum moderator / February 27, 2013 2:15 AM PST
In reply to: Latest firmware?

But out of the box I've never found that necessary. That is, the basics should be good to go.

You bring up a good point or question. Would you update your toaster's firmware after you pulled it out of the box?

Yes, this is not a toaster but it is a product that must arrive in basic working condition.
Bob

Collapse -
smart tv will not connect to wireless router
by bobdep / February 27, 2013 2:37 AM PST
In reply to: I like this idea.

I was told that my new TV did not have the newest firmware by a samsung tech so I received the latest and installed it and I still have the same problem

Collapse -
Without going over every WiFi parameter.
by R. Proffitt Forum moderator / February 27, 2013 2:43 AM PST

I think the Ethernet test is best until you can tell more about the router.
Bob

Collapse -
smart tv will not connect to wireless router
by bobdep / February 27, 2013 2:52 AM PST

I am sorry, but I don't understand your comment about Ethernet test

Collapse -
smart tv will not connect to wireless router
by bobdep / February 27, 2013 3:15 AM PST

So you are telling me to hard wire my TV to the router. Since the tv is in opposite corner of the room I need to buy about 30 of cable so I can hide the cable under my baseboard.

I need to $30 plus to fix a problem that Samsung cannot fix. This is my first Samsung product and will be my last since I am very disappointed in the service and quality.

Collapse -
Re: smart tv will not connect to wireless router
by Samsung_HD_Tech Samsung staff / February 27, 2013 5:06 AM PST

Hi bobdep,

He's not saying to try that completely in place of the wireless connection. He's saying to test it and see if it works. It's not supposed to be a permanent solution necessarily.

Let me ask this: when you see the invalid gateway message, do you see any other information, or is it just that message?

HD Tech

Collapse -
smart tv will not connect to wireless router
by bobdep / February 28, 2013 4:02 AM PST

The Tv finds the router but cannot connect.
The messages are "invalid gateway" and "set the correct gateway from network settings"

My son came to my house and immediately connected his I pad to my router without any problem so it seems to be all TV related.

Collapse -
smart tv will not connect to wireless router
by bobdep / February 28, 2013 4:59 AM PST

I fixed the problem. The IP settings was set to set up manually. I changed it to set up automaticaly and it set all the settings and worked.

I just wish the instructions said to try that in the first place.

Collapse -
AHH!
by R. Proffitt Forum moderator / February 28, 2013 9:36 AM PST

Out of the box it should have been automatic. Many folk can't/won't share the IP details and while I'm writing about this, it's not a security risk as it's only your LAN address that millions others use (192.168.0.10?)

If folk set it manually, well, that's deep.
Bob

Collapse -
Answer
Works!
by Samsung_Owner999 / March 7, 2013 9:14 AM PST

First, I could not connect to the internet from my smart 7100 Samsung Smart 55inch TV to save my life. BUT, Charter, my internet provider gave me a mediocre modem/wireless router which kept disconnecting anyway.... so I tried other techniques.

I tried to connect to my smart phone (TMobile) and used it as a WIFI hotspot which was connected to my modem and guess what...it worked.

So the issue must have been with the modem rather than the TV. So I tried a different approach.

I purchased a wireless router (NetGear) and bridged it with my Ubee Wireless modem. Tried to connect the TV and it worked - but the connection was slow.

Then I purchased a new modem from Best Buy (Zoom 3DOCSIS compatible due to 30mbps speed of my internet) and called Charter and registered the MAC with them.

Then I disconnected Ubee, connected Zoom Modem, connected the NetGear to Zoom and booted it up. Connected the TV to the wireless connection and VOILA! It works!

HERE COMES THE KICKER!

The TV immediately connected to the internet and began to update the HUB. After few minutes it re-installed the entire HUB channels! And guess what? They all work!

To all the unbelievers - stop hating on a quality product. Even the best have glitches. Have some faith in the company and wait until they can fix the issue before you start posting random messages of why you will never buy Samsung again.

In order to have this 2,000 dollars TV, you will need quality Internet Speed 20mbps or higher, and a quality gear. I spend 79 on the modem and 79 on the wireless router.

Everything works now.

Thanks Samsung.

Satisfied Customer!

Collapse -
Hate on this crappy product?
by HATEONWHAT / April 19, 2014 5:06 PM PDT
In reply to: Works!

I just bought this tv and have the same wifi problem. I'm using a 50 meg modem. This product is just straight defective. Most definitely the last samsung product ever. I was even thinking of getting the new phone. SMH. What to do with a 40 inch paper weight.

Collapse -
Re: Hate on this crappy product?
by Samsung_HD_Tech Samsung staff / April 20, 2014 11:50 PM PDT

Hi HATEONWHAT,

I'm very sorry to hear that has happened. In order for me to help you most accurately, please provide the complete model code for this device.

Regards,
HD Tech

Popular Forums
icon
Computer Help 47,885 discussions
icon
Computer Newbies 10,322 discussions
icon
iPhones, iPods, & iPads 3,188 discussions
icon
Security 30,333 discussions
icon
TVs & Home Theaters 20,177 discussions
icon
HDTV Picture Setting 1,932 discussions
icon
Phones 15,713 discussions
icon
Windows 7 6,210 discussions
icon
Networking & Wireless 14,510 discussions

Tech Tip

Know how to save a wet phone?

It's not with a dryer and it's not with rice. CNET shows you the secret to saving your phone.