Windows Legacy OS forum

General discussion

Slow Windows Shutdown

by wpbacon / May 3, 2006 9:03 AM PDT

I'm running windows xp pro and recently updated drivers for my sound and video cards. I started getting blue screens immediately afterwards. I have resolved the blue screens by uninstalling the drivers and reinstalling them. However now i when i try to turn off the computer, it takes an usually long time to shutdown. Even if i just started the computer it still takes a full minute or more before starting to shut down. Please help me!

Discussion is locked
You are posting a reply to: Slow Windows Shutdown
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Slow Windows Shutdown
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Hibernate for fast shutdown
by cmmer31 / May 3, 2006 12:09 PM PDT
In reply to: Slow Windows Shutdown

Hibernate for fast shutdown.
Start - Turn off Computer - Hold on Shift Key and
Stand By will change to Hibernate - Click it for fast turn off.

Collapse -
Shutdown issues
by tomron / May 3, 2006 12:15 PM PDT
In reply to: Slow Windows Shutdown

Don't forget to run your programs,such as,antivirus and antispyware.

Check this out LINK and LINK


Collapse -
Shutdown Issues:
by Bill Veik / May 11, 2006 9:30 PM PDT
In reply to: Slow Windows Shutdown

This problem can be caused by slow-running programs not shutting down in proper order. It can also be caused by background processes from spyware or keyloggers.

The first solution to try is to shut down using the Windows Task Manager (CTRL+ALT+DEL). Select the Shutdown Menu.

If you have no other computer issues, this may solve the problem. Use the Task Manager for a day or two to shut down your computer. It will "re-teach" your system the proper way and order in which to shut down its programs.

If not, update all of your cleaning and protection software, then run them all and restart your system. But if all else fails, you can always just keep using the Task Manager to shut down.


Collapse -
install your driver twice or upgrade your RAM
by rmarqu2 / May 12, 2006 12:12 PM PDT
In reply to: Slow Windows Shutdown

probably your driver vga card or soudcard crash and make your pc start slow to shutdown. try to uninstall and install driver vga card or soundcard twice. if your pc still slow try upgrade your RAM

Collapse -
Here is what you really need!!!
by dvesh / May 12, 2006 12:28 PM PDT
In reply to: Slow Windows Shutdown

Open REGEDIT. Click on Start/ Run and type ''regedit'' without quotes and click ''OK''... Navigate to 'HKEY_CURRENT_USER\Control Panel\Desktop\'
Highlight the 'WaitToKillAppTimeout' value.
Set it to '1000' (the default should be 20000).
Now highlight the 'HungAppTimeout' value
Set it to '1000' also.

The second part of this tip changes the same settings, this time for all users on the system.

Navigate to 'HKEY_USERS\.DEFAULT\Control Panel\Desktop'
Highlight the 'WaitToKillAppTimeout' value.
Set it to '1000' (the default should be 20000).
Now highlight the 'HungAppTimeout' value.
Set it to '1000' also.

In the third part of this tip, we will alter a second registry setting to decrease the amount of time Windows XP will wait before shutting down active services after receiving a shut down command.

Open REGEDIT and navigate to 'HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\'

Highlight the value 'WaitToKillServiceTimeout'

Change this value to '1000.'

This should help to considerably speed up the time windows XP takes to shut itself down

Auto kill tasks on shutdown

To allow Windows XP to close non-responsive applications automatically upon shutdown:

Open REGEDIT and navigate to 'HKEY_CURRENT_USER\Control Panel\Desktop'

Highlight the value 'AutoEndTasks.'
Change the value to '1'

Also 'HKEY_USERS\.DEFAULT\Control Panel\Desktop'

Highlight the value 'AutoEndTasks.'
Change the value to '1'

XP will now be able to close hung applications without user input during the shutdown process.

Now you should be able to shutdown Windows in less than 15 seconds... I hope this help Happy

Collapse -
Slow Shutdown
by R.Chandrasekhar / May 12, 2006 4:10 PM PDT

Hi,I could not find any of the keys in the regedit you mentioned.I am on winXP pro!

Collapse -
by dvesh / May 12, 2006 4:19 PM PDT
In reply to: Slow Shutdown

I'm on Windows Xp Professional too, all registry keys I have posted are there. Make sure to double check or use the search option in the registry to get to them... EVERY SINGLE ONE IS THERE. If you need future help we can chat with yahoo. I'm online right now and I can take you to the registry step by step
My nickname is IM there and I'll help you buddy

Hope this help

Collapse -
Reply to: LISTEN
by tomron / May 12, 2006 9:46 PM PDT
In reply to: LISTEN

Help is not recommended via e-mail.The other members neither get the opportunity to partake in the disscussion or benefit from it.

Point being,assistance via e-mail can not nor will not be acknowledged.

Big mistake to place your e-mail on a public forum.


Collapse -
by dvesh / May 12, 2006 10:17 PM PDT
In reply to: Reply to: LISTEN

I said CHAT not e-mail sir. Also What makes you think that the e-mail adress I have posted there could bother me at al, lol. NO SIR IS NOT A MISTAKE, IT IS AN E_MAIL ADRESS!! Thank you. Please read before posting

Thanks again

Collapse -
Calm down with the attitude
by tomron / May 12, 2006 11:15 PM PDT
In reply to: Thanks

RE:your e-mail,i was just trying to be helpful

RE:your statement

"If you need future help we can chat with yahoo. I'm online right now and I can take you to the registry step by step"

Irregardless of the method used it defeats the purpose of the forum,which is for all menbers to partake in the disscussions in which everyone can benefit.Why then have the forum,why not just have a list of e-mail address.


Your a new member or supposedly,and you come aboard with a bellicose attitude.Don't ever talk to me in that fashion again,i don't treat you that way.

Collapse -
Hey buddy
by dvesh / May 13, 2006 1:39 PM PDT

I don't know what made you think I was treating you with actitude. I think you just missunderstod what I wrote. i was trying to help you out by spending some time with you and taking you to the right place. I guess you didn't find any key and I thought I could be helpful. Anyways, I apologize if I made you feel uncomfortable with my post. I didn't mean to be rude...

I hope you understand me now. I mean well buddy...

Collapse -
Thanx for posting back
by tomron / May 13, 2006 1:58 PM PDT
In reply to: Hey buddy

Its just that sometimes someone every now and then does get an attitude and it does try my patience.

I,m trying to explain to someone in the V&S forum about the same thing you said about assistance by means other then the forum which i explained that would defeat the purpose of the forum and the members do not benefit.

He don't want to here anything,just wants to do it his don't work that way.

No problem,I appreciate you posting back,

Collapse -
Tried It - partially works
by =Assassin= / December 3, 2006 1:28 AM PST

I've been having a slow shutdown problem myself - it's a problem that's happened since I built the machine. Anyway, I tried the registry fix, and the first two shutdowns became fast - I was happy! Then virtually everyone after that has gone back to being slow, to the point I give up and restart. Always when nothing has been running, the shutdown is now fast (it was slow everywhere before), so somethings been fixed, but when I do any light gaming, or spend a few hours on the machine, it shutsdown slow again. I've tried all the standard fixes, and nothing really works. It's even odd how the hard disk activity just stops after "Windows is Shutting Down..." is reached, and then only activates again just before it finally powers off, some few minutes later.
It's really annoying me to have to restart all the time, so are the any further answers please?!! Happy

Collapse -
Forgot to post system specs
by =Assassin= / December 3, 2006 1:31 AM PST

AMD Athlon64 3800+ AM2
2GB DDR2 667 MHz RAM
160GB Maxtor IDE
Leadtek GeForce 7900GS 256mb
MSI K9N Neo-F 550 MCP
Onboard Realtek ALC883
XP Pro with SP1

Collapse -
Slow shutdown in windows XP
by D2D core / March 29, 2007 1:59 AM PDT

Thanks @ yoni5002. It gives me big help but what i had notice in the first time is it does not shutdown qucikly for less than 15sec. After I did what you mentioned, my laptop still slow in shutting down. I tried to plug my HP-ipaqhw6965 in the craddle and MS Activesync activates. When I shut it down it is very quick. And when i unplug my ipaq it goes back again to slow shutdown. So i noticed that the Activesync ver4.2 is the one who is holding up the shutdown process for a long time. I uninstalled it and installed the latest ver.4.5 beta version. After that even i didn't plug my Ipaq, the PC shuts down in less than 15secs.

However, I noticed that when I worked in one program say in Word or Excel and I did not save then I shutdown the PC, Windows XP does not prompt me to stop and save my work instead it goes directly to shutdown process. It shows a window "Do you want to save this file?" but it vanish quickly and shutdown the Windows.
Should I restore the setting in the registry on the 3rd Part you had mentioned? Pls. adivise on how to rectify. Thank you

Collapse -
XP Registry General
by monte_934 / November 11, 2008 2:40 PM PST

Excellent post.. Do you have any other mods or tweaks that the general public may not know about. Thanks.

Collapse -
I followed your instructions completely but
by hoseaj / April 23, 2012 4:39 PM PDT

After following all of your instructions my computer still takes about 75 seconds to shut down.
No other problems with this system.
Win XP

Collapse -
Slow shutdown, try Poweroff
by scoot / May 17, 2006 8:59 PM PDT
In reply to: Slow Windows Shutdown

While you are sorting outthe root cause of the problem you mighht likle to try 'Poweroff'

Its free and easy to use, just drag it on to the desktop or into the quick launch bar. You can select closure mode, force applications to close and you can also programme the shut down time - which is very useful if you need to leave the pc on an hour or two to complete a download

Collapse -
How to hold shutdown process when I still have file to save?
by D2D core / March 29, 2007 2:24 AM PDT

It's not the issue on slow shutdown now. It is onhow to hold the shutdown process when I worked a file or group of files that needs to be saved. It should prompt hold so that I can save it.

Collapse -
Slow windows xp logoff, rastart and shutdown
by mohalamer / June 1, 2007 6:02 AM PDT
In reply to: Slow Windows Shutdown

I Had the same problem . i had to wait for 2 minuts to start logging off . i started searching the internet for a seloution and i tried evreything that is mentiond and i tried some of my ways , and i downloaded more than 2 antispywares and antiviruses but no problmes were found . In the end i decided to make a new user and copy evrything to it , and now it's working great . and faster than anytime befor . but if you want my advice try evrey method in the internet and if nothing worked do what i did.

Collapse -
by Daviddude / June 1, 2007 12:28 PM PDT
In reply to: Slow Windows Shutdown
Collapse -
Windows Automatic Update Service glitch causes slow shutdown
by mrequenes / May 29, 2011 6:31 AM PDT
In reply to: Slow Windows Shutdown

The steps in this post fixed my slow shutdown problem.

It also fixes the following error seen in my Application events in the Event logger
Event ID: 454
Source: ESENT
wuauclt (2224) Database recovery/restore failed with unexpected error -1852.

In case the link goes stale, here are the steps:

To fix this error 0x80248011. Try the following in the command prompt.:
Click on Start - run - type command "cmd" (without the quotes) and
command prompt will appear.
After you are in command prompt type the following commands.

1) net stop wuauserv
2) cd /d %windir%\SoftwareDistribution
3) rd /s DataStore
4) net start wuauserv

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Coming soon

Get behind the wheel with Roadshow

Love cars? Climb into the driver's seat for the latest videos, reviews, shopping advice and picks by our editors delivered to your inbox every week.