Windows 7 forum

Question

Should I install Java add-ons?

by ClaireBH / October 18, 2013 8:27 PM PDT

I originally posted this on the 'Computer Help' forum but I don't think that was the right place to post it, so I hope this is OK! I am using Windows 7 and IE9.

One of the websites which I've used regularly for a few years has recently started denying me access, giving me the messages: "Sorry, the Java plug-in with your web browser is not enabled" and "This website wants to run the following add-ons: 'Java SE Runtime Environment 7 Update 45' from Oracle America Inc'". I have just downloaded the most recent Java update (version 7, update 45, as it says) and I have checked in 'Tools, Manage add-ons' and Oracle add-ons are definitely enabled. But are plug-ins the same as add-ons?? Please excuse my ignorance but I'm not sure!

I don't know whether or not to try to install these add-ons through the site that I've been using. I've read that it may be unsafe to install things through other sites, but I've looked on the Java website and I can't find any way of installing them through their site. Please help! Thanks. Happy

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Should I install Java add-ons?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Should I install Java add-ons?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Are you sure
by MarkFlax Forum moderator / October 18, 2013 8:40 PM PDT

that you are using IE9? If your Windows 7 OS is uptodate with all the Windows Updates then you are likely now using IE10.

If so then it is possible the web site you frequent hasn't yet allowed for any differences in IE9/IE 10.

What happens if you use another browser, eg Firefox or Google Chrome?

Mark

Collapse -
Java
by ClaireBH / October 19, 2013 9:18 AM PDT
In reply to: Are you sure

Hi Mark.

Thanks for your reply.

Yes, you're right - I've checked and I am using IE10. I've got automatic system updates so I didn't realise that it had updated it!

I haven't tried using a different browser. I know this sounds stupid but I'm a bit of a technophobe and I've never used any other browser but IE before. I was hoping that I could sort out this problem without having to use another one. Is there any way around this?

All Answers

Collapse -
Answer
Re: Java
by Kees_B Forum moderator / October 19, 2013 4:37 AM PDT

Also check Java settings in Control Panel. It has a setting to disallow running applets in a browser (for security reasons).

Kees

Collapse -
Java
by ClaireBH / October 19, 2013 9:22 AM PDT
In reply to: Re: Java

Hi Kees.

Thanks for your reply.

Whereabouts in Control Panel??

Collapse -
Re: Control Panel
by Kees_B Forum moderator / October 20, 2013 3:16 AM PDT
In reply to: Java

With me, it's Control Panel>Java. I thought that would be self-explanatory.

Kees

Collapse -
Java
by ClaireBH / October 20, 2013 9:59 AM PDT
In reply to: Re: Control Panel

Kees.

Thanks for that remark!

It may be self-explanatory to you but obviously it isn't to me, or I wouldn't be asking! It appears that I don't meet the required 'level of knowledge' which it is assumed that people have on here.

Claire

Collapse -
Java - New!
by maninlaspinas / October 20, 2013 6:11 PM PDT
In reply to: Java

Claire,

Click the window logo, (probably bottom left). In the list on the right, look for Control Panel. Click on Control Panel, look for java, and click on it.

Collapse -
Re: Control Panel
by Kees_B Forum moderator / October 20, 2013 6:19 PM PDT
In reply to: Java

That might depend on the view. In the upper corner you can choose between categories (that's the default, I think) or large icons or small icons. Mine is set to small icons, and then you'll see all Control Panel 'applets' alphabetically. With me Java is in the second row, but it may be different with you. Anyway, if you know the alphabet, you'll easily find it.

Kees

Collapse -
Java
by ClaireBH / October 21, 2013 8:29 AM PDT
In reply to: Re: Control Panel

Are you always this patronising??

I cam here for help but all you've done is made me feel stupid. I certainly won't be using these forums again!

Collapse -
I hear you.
by R. Proffitt Forum moderator / October 21, 2013 8:32 AM PDT
In reply to: Java

I see less and less makers willing to provide basic classes on computer use. The results are felt in the forums where folk don't have the basic skills to manage.

You bring up a good point. Is Windows going to pass as folk demand something easy such as a tablet?
Bob

Collapse -
I hear you
by ClaireBH / October 21, 2013 8:47 AM PDT
In reply to: I hear you.

Hi Bob.

Thanks for the support.

I'm glad I'm not the only one who feels like this.

I'm not a complete technophobe - and I'm sure you're not either - but some of the people on here make you feel completely stupid! It's not right when it's meant to be a forum to help people.

Claire Happy

Collapse -
And I hear that too.
by R. Proffitt Forum moderator / October 21, 2013 10:00 AM PDT
In reply to: I hear you

It's hard to hit the right tone as I've detailed everything and an advanced user will flame on about talking down to them. Move it up a few notches where you leave out the basics and you might offend others.

It's all free advice here so when you feel a detail was left out, try to focus on the missing details. Almost everyone in the CNET forums will keep trying as long as you do.
Bob

Collapse -
We're not hearing each other!
by ClaireBH / October 22, 2013 6:42 AM PDT
In reply to: And I hear that too.

Sorry Bob.....when I read your first post, I didn't realise you were a moderator - I thought you were someone like me who was looking for help on here! That's because I'm stupid, of course - because I didn't notice the red 'M' after your name, and even if I had, I wouldn't have known what it stood for!

What everyone seems to have forgotten here is that my question still hasn't been answered. But I'm past caring. I know I'm not going to get any answers here - none that make any sense to me anyway. I've tried to delete my profile but it appears that it won't let me do that myself, so I've had to send a request to have it deleted. I had to give reasons why I want to delete my profile, so I was honest about why I am not happy with this forum.

Collapse -
To do that, just click on the Yellow Triangle on this page
by R. Proffitt Forum moderator / October 22, 2013 7:04 AM PDT

And alert your post what you want done. Sorry that folk didn't get you a great answer or offer a tutorial on managing apps in Windows.
Bob

Collapse -
What??
by ClaireBH / October 22, 2013 7:33 AM PDT

I'm not trying to report anybody! The only thing I want "done" is my profile removed from this site.

Re your comment about Windows tutorial....serious apology or attempt at sarcasm??! I can't quite make up my mind! lol Happy

Claire

Collapse -
It was an apology.
by R. Proffitt Forum moderator / October 22, 2013 10:31 AM PDT

I alerted your post for you so it will get done.
Bob

Collapse -
Answer
The problem is it doesn't matter what version
by orlbuckeye / October 21, 2013 10:44 PM PDT

of java you install is the addon is disable in IE. You have to goto Tools\manage Add-ons and enable Java. I'm a software administrator and have to deal with Java issues alot. Chrome and Firefox have more problems then IE mainly because Chrome wants you to constantly update and FF disables Java by default. The app i manage needs particular version of Java and we have the users locked down so they can't download new versions. So what may be happening is when you install a new version IE is disabling it by default.

http://en.community.dell.com/support-forums/software-os/f/3524/t/19463279.aspx

Collapse -
Java
by ClaireBH / October 22, 2013 7:10 AM PDT

orlbuckeye,


From my original post:

"I have checked in 'Tools, Manage add-ons' and Oracle add-ons are definitely enabled"

Did you not read that?? All my Java stuff is definitely enabled! Contrary to popular opinion on here, I am not completely stupid!!


But don't worry - I have officially given up on this forum (see my previous post / reply to Bob the moderator).
I will find somewhere else to get advice from.

I thought I was asking a simple question. How wrong could I be?!

Collapse -
Yes! Thank you
by ClaireBH / October 22, 2013 4:08 PM PDT
In reply to: Does this...

It describes exactly what the problem is. Unfortunately the 'fix' didn't work on the website that I was having trouble with, but the scenario was the same.

You are the first person on here who has taken me seriously and given me a proper answer to my question! So thank you very much for that. x Happy

Collapse -
That's strange.
by Kees_B Forum moderator / October 22, 2013 5:03 PM PDT
In reply to: Yes! Thank you

Your whole thread is about Java, and now you say that a link about Javascript is describing your problems. Java and Javascript are very different things.

The messages you mention in your orginal post are "Sorry, the Java plug-in with your web browser is not enabled" and "This website wants to run the following add-ons: 'Java SE Runtime Environment 7 Update 45' from Oracle America Inc'" while this link is about the message ""This site requires a javascript enabled browser, please change your browswer and try again.".
This are very different messages also.

And let me ask again: did you already check the settings in the Java applet in Control Panel? That should definitely be there if Java 7.45 is installed. Note the checkbox in the first screen in http://www.java.com/en/download/help/jcp_security.xml
It's called "Enable Java content in browser". So if that security setting is not set, you get the message you describe. And it's a different setting than you see in Tools>Internet options in your browser.

Kees

Collapse -
That's strange
by ClaireBH / October 26, 2013 11:25 AM PDT
In reply to: That's strange.

Kees,

I didn't know that Java and JavaScript were completely different things. (Call me stupid). I have already checked the settings in the Java Control Panel, and Java is definitely enabled in the first (security) screen. However, if I need to go into the 'advanced' settings, unless someone is prepared to tell me exactly what to look for, i.e. which checkboxes should be ticked etc, then I'm not going to know what to do, am I?!

There's a guy who I know at work who's pretty good with computer stuff - he's been off work for a couple of weeks but he's back next week so I think I'll ask him for some advice about this.

Thanks for trying to help anyway.

Claire Happy

Collapse -
Clarie.. try ..
by Carol~ Forum moderator / October 27, 2013 8:06 AM PDT
In reply to: Yes! Thank you

Hi Claire..

I'm sorry to hear of all the problems you're experiencing. Sad

Taking into consideration Kees' last post, you might wish to check the below setting if you haven't already:

How do I enable Java in my web browser?

SYMPTOMS: Even after installing Java, Applets do not run.

CAUSE: Java is not enabled in the web browser. If Java is already installed but applets do not work, you may need to enable Java through your web browser.

SOLUTION: Please follow these instructions to enable Java though your Web browser.

Browsers for Windows

- Internet Explorer

1. Click Tools and then Internet Options
2. Select the Security tab, and select the Custom Level button
3. Scroll down to Scripting of Java applets
4. Make sure the Enable radio button is checked
5. Click OK to save your preference

http://java.com/en/download/help/enable_browser.xml The page also offers settings for different browsers

I don't know if the above is the cause of your problems, but it's worth checking.

The very best of luck..
Carol

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Smartphone tip

Hoarding photos on your phone?

Those picture are hogging memory and could be slowing down your phone.