iPhones, iPods, & iPads forum


Saving a pic generated by a graph calculation app

by evennewerbie / March 9, 2013 3:02 AM PST

I'm creating some diagrams, just simple math curves, on a app (called Quick Graph but this could probably be a question for many others) and I want to post it on a forum web site, or probably onto an album of my photobucket which I will then make a link to in the site.

There has to be a better way than the only the cumbersome one so far I've been able to manage, which was to e-mail it to myself, then save it .png in My Images and from there to a photobucket album I created. The result is just about acceptable but cumbersome and I haven't yet been able to handle the attached titles (which associate the colours of various curves in the graphs with a title - actually equations - stating what they are).

I have just installed the photobucket app on my i-pad but I am not familar with it yet, and in any case imagined it would be easier and more controllable to paste the pics from the calculation app onto my photo collection in the pad where I created an album to receive the pics.

When in the calc. app I click 'Share' I have besides e-mail the options Copy Image and Save to photo library.

So I copy, then go to the, at present empty, album. I expect, from what I do in other routines, to be able to press it and be given a Paste option. But nothing happens, so I don't know how to get my pic there or anywhere else.

With the Save to photo library option it tells me ERROR. Data unavailable... Launch the Photos Application.

What do they mean Launch?? It's there! It's never been beached! By the Photo application do they mean the one with the sunflower icon which the i-pad cons with already installed, where I have a score of images downloaded from the web (I have not used it for taking photos so far) plus some now there coming from my phtotbucket as I was playing around with this thing today, plus my empty album waiting for the graphs? Or something else?

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Saving a pic generated by a graph calculation app
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Saving a pic generated by a graph calculation app
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
You might want to use a spreadsheet
by wpgwpg / March 9, 2013 3:09 AM PST

Spreadsheets are good for making graphs and can be easily saved and used by others. The most common spreadsheet is Excel, but there're the free LibreOffice and OpenOffice too. If you have something that doesn't work with a spreadsheet, you can always use the PrintScreen button. That takes whatever is on your screen (or just application if you hold down the ALT key) and puts it into the clipboard. Then you can paste it into a word processor or Paint and save it in a format like JPG or DOCX that's easy to restore and view.

Good luck.

Collapse -
you do realize that the poster has an iPad,
by mrmacfixit Forum moderator / March 9, 2013 7:21 AM PST

so none of your suggestions will work for them.


Collapse -
I saw that
by wpgwpg / March 9, 2013 10:32 AM PST

I thought there were apps for everything on the iPad. You mean you can't get spreadsheet apps on an iPad? I'm really surprised because I can on my Kindle Fire. Did you notice he marked my response as "Answer"? He was looking for a way to send to other people.

Collapse -
Of course you can do spreadsheets on an iPad,
by mrmacfixit Forum moderator / March 9, 2013 11:11 PM PST
In reply to: I saw that

but you cannot install LibreOffice and OpenOffice.

You can do that on a Kindle?

The OP did not mark your response as "Answer". You did that when you clicked on the Answer button when you sent your reply.

Note that my earlier post was also marked as "Answer"


Collapse -
Always the troublemaker, try this link on the iPad.
by R. Proffitt Forum moderator / March 10, 2013 5:08 AM PDT
In reply to: I saw that
Collapse -
(NT) Taking it for a spin right now
by mrmacfixit Forum moderator / March 10, 2013 7:24 AM PDT
Collapse -
you are going to have to supply more
by mrmacfixit Forum moderator / March 9, 2013 7:26 AM PST

information than you have.

this Calc.app, is it one that came with the iPad or is it one that you purchased from the App Store?
If the latter, then contact the creator of this app and ask them the questions you want answers to.

Launch, in this case, means to start the program.

Let us know how you get on with the manufacturer


Collapse -
You said - start the program?
by evennewerbie / March 9, 2013 8:51 AM PST

It's the free version of which you can buy an enhanced version. But that costs £2.99 and times are hard.
Seriously you can spend a lot, well at least quite a lot of time trying the various apps for this purpose till you find the best one. Among the various free math apps I have seen a lot so limited I wouldn't think enough even for a starting secondary school student. This one was recommended by a teacher on Internet for being suitable for I-pad. Yes I guess I will ask the creator even if I haven't bought it yet. Tomorrow is Sunday and I hoped to conclude my calcs sooner.

I don't know what you mean by 'start the program'. If you mean click the sunflower and go there, that's what I have done and the things there mentioned in the first post.

Collapse -
I have an iPad2 and, apparently, nothing to do this morning
by mrmacfixit Forum moderator / March 9, 2013 11:49 PM PST

so I downloaded QuickGraph, the free version, from the App Store.

I have just created a graph of an equation, one of those in the library, and, using the Share button, emailed to myself. It arrived as an attachment (.png) and was easily saved to another location on my computer.

I also tested the "Save to Photo Library" function. After answering Yes to the question about wanting to access my library, the picture appeared in my photo library.
From there it is just a touch or two to get it into the Graphs Folder.
The Photo app is not built to take the "Paste" option, so while it seems to be a good idea, it will not work that way.

The Copy function also works as you describe BUT, you must have an app that is capable of having things added to it. Pages, Keynote and Numbers are all apps that will do that, unfortunately they do not come as standard on your iPad.

Even with a paid app, there are so many places to store pictures that an app developer could spend forever making all of them work in the "Share" menu. Even then there would be people whose choice of picture storage would not be there. Notice that Dropbox, arguably the most popular of the sharing sites, is not mentioned in that list!

You never mentioned you computer in all of this, but the best solution I can come up with is the one you are already using.
Email the graph to yourself, save it, convert it to JPG and add whatever titles and such with a Graphics tool and post it to Photobucket.

Let us kow if you come up with a better solution


Collapse -
Some progress, more confusion...
by evennewerbie / March 11, 2013 3:32 AM PDT

I sent message to the QuickGraph explaining and asking.

You have clarified one misconception of mine: that since copy-paste works for several things it is a universal function. (However the copy option was offered inside the QuickGraph app.)

You say <i>"I also tested the "Save to Photo Library" function. After answering Yes
to the question about wanting to access my library, the picture appeared
in my photo library." </i>
It didn't ask me any question, just said there was an error saving this image as explained in my first post

I am back with "Launch, in this case, means to start the program." to which my question was <i>"I don't know what you mean by 'start the program'. If you mean click the
sunflower and go there, that's what I have done" </i>and the things there
mentioned in the last para of first post. So maybe I still have some misconception here.

I am glad to know I at least hit on a reasonable, if cumbersome, solution using e-mail. And since then seemed to find some improvements but...

First I found I could download photobucket to my i-pad.
Second I found photobucket (I think this is fairly new) now gives you the possibility of uploading via e-mail, you have your own address.
Promising... Confused Promises to cut out some hassle.
I e-mailed from my own e-mail (to which I had sent the diagrams yesterday) and have the impression it may worked. But then as all the things I have done were all mixed up in a confusion, I deleted all connected stuff and sent it to myself again. This time it hasn't arrived.

And I should be able to shortcut that too as the QuickGraph app has the e-mail option.
But I have done that too, three times and nothing arrives.

And then I just now noticed that somehow at some time on my sunflower-iconed photos some of the graphs and other photobucket stuff have arrived from somewhere, and on the photobucket this corresponds to 'camera roll' (have deleted so I know when anything new happens). It looks like things could work but it is all very confusing. In the i-pad photobucket you have very few knobs and levers.

Collapse -
How about a simple screen grab?
by Pepe7 / March 10, 2013 8:00 AM PDT
Collapse -
Thanks - but didn't work.
by evennewerbie / March 11, 2013 4:17 AM PDT

Sounds useful, but didn't work for me. Except for the power off bit. It didn't even make the noise.

The link says "iOS version 2.0 or higher". Confused All I know is I have an i-pad 2.

Collapse -
(NT) You most certainly have an iOS version greater than 2.0
by mrmacfixit Forum moderator / March 11, 2013 8:15 AM PDT
Collapse -
I don't understand what went right
by evennewerbie / March 11, 2013 10:54 PM PDT

Thanks to everybody who helped and tried to.
I have made some progress.
After working at it all day into early morning I was able in the end to use e-mail and the (I think fairly new?) facility for uploading via e-mail sent directly to photobucket. In this way it is not necessary to go through the various cumbersome steps described in my first para.

One reason why I found such difficulty with this e-mail procedure before may have been that the mail can take several hours to get through. (This does not usually happen to me for anything else.). But what happens is that when it finally succeeds I get message on my ordinary e-mail: Congratulations! - you have suceeded.

After which I went to Photobucket and the pics were there. But I went there on my computer - however they were not there on my i-pad that I could find. So then I thought to hook up the i-pad to the computer via USB connection. This called up I-tunes and page of my music. And then the entire computer FROZE and the only way out was to unhook and unplug the computer. So I would not exactly say I am navigating systems with great ease and assurance! Not like someone who knows what he's doing. But at least the images were in my i-pad after that.

The images are nice enough but the fact that the titles/colour coding are unreadable still makes it scarcely useable for the educational site I intend to post them. But that is a problem of the Quick Graph app rather than one of general interest. I will say this when they ask feedback, and if they say anything of general interest will repost here.

A workaround that succeeded was the screenshot trick pointed out by Pepe7. Happy
It did not work right at first, but it is just a question of knack. After all you are pressing one button which normally takes you out of an app. and another which normally shuts down the device! This morning i e-mailed to photobucket a screenshot and it doesn't seem to have arrived. But I don't need it to because Blush the screenshot is in Camera Roll which appears in my Photobucket too. Not yet ready to post reslts on a site but this now looks good enough for my present purpose.

Without CNET helpers I would probably still be struggling or else have given up.

Collapse -
Glad to hear it worked like a charm ;) (n/t)
by Pepe7 / March 12, 2013 1:11 AM PDT


Collapse -
(NT) Yes, nice to see that your patience won through.
by mrmacfixit Forum moderator / March 12, 2013 8:47 AM PDT
Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

Smart Home Help

Light bulbs you shouldn't buy

There are plenty of dimmable LED light bulbs, but make sure you don't buy the ones that flicker when you dial them down.