Samsung forum


Samsung Wireless LAN Adapter stopped connecting to Internet

by egkenny / August 10, 2013 11:48 AM PDT

TV: Samsung UN55D6000S
Wireless LAN Adapter: Samsung WIS12ABGNX
Internet Provider: Comcast Blast 50mbs
Internet Modem: Comcast/Arris TG862G Gateway

The TV was working fine on the Internet. Now it will not connect. If I try to reconfigure the Samsung network settings the ending message says "network connection complete but unable to connect to the internet". The IP address, Subnet mask, gateway and DNS server in the Samsung network status look OK.

The gateway works fine with 2 wired desktop PCs, 1 wireless desktop PC, 3 wireless laptops, and 1 wireless printer.

I am at a loss to understand what the problem is. Comcast is no help with their free support. They want me to pay if I want additional help.

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Samsung Wireless LAN Adapter stopped connecting to Internet
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung Wireless LAN Adapter stopped connecting to Internet
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
by R. Proffitt Forum moderator / August 11, 2013 2:18 AM PDT

We can't check your work and some folk do not want to share the private IP address of 192.168.0.x or such. I can't duplicate in every reply that such information is not a security issue as it's a private address and what that means.

So try the usual DNS of and then hope that helps

Collapse -
Re: Samsung Wireless LAN Adapter stopped connecting to Inter
by egkenny / August 12, 2013 2:35 AM PDT
In reply to: Remember

A have no problem sharing private IP information. However I am hiding information that is not private.

The Network status for the Samsung TV displays:
MAC Address: C4.nn.nn.nn.nn.nn (real value not shown)
IP Address:
Subnet Mask:
DNS Server: 75.nn.nn.nn (real value not shown)

This information was received by the gateway DHCP server. All this information looks right.
The Comcast DNS server shown is one the values I get on my PC if I run IPconfig.

I first tried configuring the TV Network by manually selecting the SSID of the gateway. I entered the WPA security key when prompted.
The final configuration message says it connected successfully with the network but was unable to connect with the internet.

I even tried using push-button WPS. This worked but the final result was the same. Connection OK but no internet.

The gateway has something called "Auto-Learned Wireless Devices". It lists two devices and their MAC addresses.
The 1st device and it's "Device Name" and "MAC Address" look OK since this is my wireless HP printer.
The 2nd device has the same "Device Name" as the printer but it's "MAC Address" matches that shown in the TV's Network status above.

Possible problems:
* The TV's network adapter could be malfunctioning. I have no way to test this. It worked at one time but may have failed.
* When it was working with the internet I would see occassional Samsung updates. Is is possible that an update may be causing a problem?
* The gateway itself received a firmware update. This update may have added somthing that is causing a problem.
* The gateway's firewall could be blocking the TV for some reason. Even setting the firewall with minimal security has not helped.

Collapse -
Last checks.
by R. Proffitt Forum moderator / August 12, 2013 2:49 AM PDT

1. The info is fine. But still unsure why sharing the DNS entry would be any issue.

2. Did the and DNS change anything?

3. Is this all DHCP assigned? (except for the check in item 2?)

4. Final check. Is this your TV and is it at the firmware listed there?
-> I see the date of Mar 16, 2013, version isn't clear but try ver. 1031.0.
(what date and version is yours?)

If all these check out then it's time to call Samsung for service.

Collapse -
Tried again with your suggestions
by egkenny / August 12, 2013 3:43 PM PDT
In reply to: Last checks.

DHCP (auto settings) resulted in the following TV network settings:
MAC Address: C4.nn.nn.nn.nn.nn (real value not shown)
IP Address:
Subnet Mask:
DNS Server:

1) Tried manual setting of for TVs DNS Server:, & Each gave the same result.
2) Updated TVs firmware from 1028 to 1031. Tried again but still gave the same result.

I used push-button WPS to speed up the configuration process.
IPconfig/all on the PC showed the following DNS servers: &
ping on the PC gave a normal reply with no errors

Thanks for your suggestions so far. Its late. Maybe tomorrow will be better.

Collapse -
Here's why revealing details is needed.
by R. Proffitt Forum moderator / August 12, 2013 11:53 PM PDT
Collapse -
Re: Here's why revealing details is needed.
by egkenny / August 14, 2013 6:52 AM PDT

I do not understand how this site is of use to me. Can you clarify?
I contacted Samsung about the problem I was having.
After going through 2 levels of support I was told that since the TV was connecting successfully to my network there was nothing wrong with the TVs end. The problem had to be with my ISP Comcast.

Now I am back to square one. Unless I can come up with something else to try I guess I'll just have to give up.

Collapse -
Re: Here's why revealing details is needed.
by Samsung_HD_Tech Samsung staff / August 14, 2013 7:41 AM PDT

Hi egkenny,

In situation like this, it's best if we can ignore the wireless setup altogether in a few tests. So as a test, is there any chance of running a CAT cable to your router from your TV?

HD Tech

Collapse -
Tried a wired connection
by egkenny / August 14, 2013 5:32 PM PDT

I only had two short Cat5 cables so I used an old router/switch as a switch only so I could connect the two Cat5 cables together. The combined cable was long enough to reach the TV.

Using a wired connection the TV connected to the gateway and the Internet with no problem.

I then opened SmartHub. An automatic update of SmartHub was completed. I even watched a couple videos on YouTube.

Collapse -
by egkenny / August 14, 2013 7:39 PM PDT

Success!!! The Samsung TV is now connecting wirelessly to the Internet. What follows is a summary of what I did...

Even though the Samsung TV network status reported a successful connection to the network and a local IP address of it could not connect to the Internet. This made me believe the answer was in the gateway configuration.

I opened the gateway configuration menu. I opened the Connected Devices > Devices menu.For some reason the Samsung TV was not showing up in the list of online devices. The other desktop PC that I had previous started up was showing up as an online WiFi device.

I know I had not looked at the Parental Control menu before but then I remembered that I had done a firmware update for the gateway. I thought maybe the update had changed something there. I finally found a clue in the Parental Control > Reports. There were a bunch of entries like this: "UDP Packet - Source:,35664 Destination:,53, 02:46:15, 2013-08-15 [PRCTL_DEVICE_LOG] Blocked". Clearly packets from IP address were being blocked. I then selected Parental Control > Managed Devices. I found a lot of entries including the IP address Even though the entry said to always allow the device at IP I deleted that entry.

I again opened the Connected Devices > Devices menu. I now had a new Online WiFi device with an IP address of

I then went to the Samsung TV and checked the network status. It showed it was connecting to the Internet. I opened Samsung SmartHub and was able to go to YouTube.

Collapse -
Re: Success!!!
by Samsung_HD_Tech Samsung staff / August 15, 2013 12:58 AM PDT
In reply to: Success!!!

Hi egkenny,

Glad to hear it! So for those who follow behind this, the moral of the story is isolate out devices and test, test, test by changing one thing at a time.

HD Tech

Collapse -
See the last reply.
by R. Proffitt Forum moderator / August 14, 2013 9:05 AM PDT

The next test is wired. If that works, my bet is a service call is needed.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.