Hi. I tried for a long time to connect the Samsung Wave 8500 to the Kies software using windows xp. It appears that there is a problem with the power source on the USB 2 supply and when you try to connect the device you will probably be getting a code 10 notification.The best advice I found and one that worked for me was from the Sandisc support team (talking about a generic Sandisc device).
I include this below and hope it helps.

"MTP Device Cannot Start code 10" error message
I get an "MTP Device Cannot Start, error code 10" error message when I connect my Sansa player to a PC running Windows XP. What can I do?

1. Make sure you are logged in as an administrator
2. If connected, disconnect your player from the PC
3. Open your command prompt, click Start select Run
4. Type cmd then press Enter
5. Type the following after the prompt: Net localgroup Administrators local service /add then press Enter

NOTE: A "The command completed successfully" message should appear.

6. Close the command prompt and reconnect the Sansa player.

Best wishes