Samsung forum

Question

Samsung TV 5300 UN40EH5300F won't display wireless SSID list

by bachastain / September 7, 2013 11:07 PM PDT

I have a TV that I'm trying to connect to an ASUS RT-16N wireless router. If I configure the router to have NO security, then going to NETWORK -> NETWORK SETTINGS -> START works. Note that is does NOT show me a list of SSIDs. I saw it popup once but it was cleared from the screen faster than I could read it. Now I never see it. The problem is that I now need to have WPA2 security turned on and there is no way to select the SSID and enter the security key. Going to NETWORK -> NETWORK SETTINGS -> START just hangs for about 30 second and then returns to the same NETWORK SETTINGS page. There is no way to get to the SSID list (working just fine on other wireless devices).
I downloaded and upgraded the TV firmware this morning so I have the latest Firmware 1034.2.
The START button should take me to the SSID list but it doesn't. Just hangs and returns back to the START button 30 seconds later.
Note that I have never seen that SSID list, not even when the router is set for NO security.
Thanks!

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Samsung TV 5300 UN40EH5300F won't display wireless SSID list
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung TV 5300 UN40EH5300F won't display wireless SSID list
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Just a check.
by R. Proffitt Forum moderator / September 8, 2013 2:10 AM PDT

What channel is the router on? There is an issue if the WiFi is off on channel 14 and there can be a distance issue as these devices seem to have much shorter ranges. Try 20 feet or so.

I haven't heard this on the ASUS router so that's a good sign at least.

CLARIFICATION. You wrote does NOT show me a list of SSIDs then later about hanging so that hang is not a good sign. http://www.samsung.com/us/video/tvs/UN40EH5300FXZA tells it has built in WiFi so there should be no question about if it's there or not.

The more I think this over the more I think a service call will be made. Can you try any other hotspot source such as a phone? Does wired work?
Bob

Collapse -
Samsung TV 5300 UN40EH5300F won't display wireless SSID list
by bachastain / September 8, 2013 4:59 AM PDT
In reply to: Just a check.

Unfortunately I'm stuck with the distances. The TV is 8 feet high mounted to a wall near the ceiling in the basement. The router is almost directly overhead on the main floor, which is the only internet outlet in the whole house. Floors and ceilings are wood.

When you go to NETWORK->NETWORK SETTINGS. There is a START button. Pressing that button should take you to the next screen with a list of the SSIDs discovered. That change never happens. The START button grays and it sits unchanged for 30 seconds to a minute. No messages or errors of any kind are displayed. Then the highlighting returns to the START button. At that point you can press START again or exit. No matter how many times you press START, nothing happens.

I'm in a remote area surrounded by 20 miles of national forest. The chances of getting service call here are pretty slim.

I have numerous other WiFi devices in our home and all work just fine except for the WiFi sections of this TV.

Thanks.

Bruce.

Collapse -
Samsung TV 5300 UN40EH5300F won't display wireless SSID lis
by bachastain / September 8, 2013 5:15 AM PDT
In reply to: Just a check.

Oh, and the router channel is on auto at the moment but it is currently using channel 1. We're on 1.5 acre lots and there are no other wifi signals within range.

Collapse -
Then without the testing.
by R. Proffitt Forum moderator / September 8, 2013 5:59 AM PDT

I fear the best idea is to get it returned. I usually try it wired and with another hotspot but this can't be done so it's time to return it.
Bob

Collapse -
Samsung TV 5300 UN40EH5300F won't display wireless SSID list
by bachastain / September 8, 2013 6:08 AM PDT

It's about a year old. Never tried the WiFi until now.

Collapse -
In the USA do this.
by R. Proffitt Forum moderator / September 8, 2013 6:14 AM PDT

Be sure to register the tv at samsung.com and you may get 3 more months warranty but without the testing I can't guess further. There are routers I've seen samsung not list and the details are just not here for me to write about.

Over in the CNET Networking Forum I have a collection of ideas about this for Samsung owners but here we are and the tests can't be done so we have to move to something like a summary judgement.
Bob

Collapse -
Samsung TV 5300 UN40EH5300F won't display wireless SSID list
by bachastain / September 8, 2013 8:21 AM PDT
In reply to: In the USA do this.

Yeah, it's really weird. Doing some more playing, it turns out this started when I added a second SSID to the router, the purpose was to have a WPA2 secured private network and an open unsecured internet only account.

If I disable the secured network, the TV sees the open network and attaches to it without being told to or configured. It just does it every time the set is turned on. So the WiFi hardware is working because I can use it.

However, when I add a second secured SSID, the TV stops connecting automatically to either SSID, perhaps intentionally. Since the SSID list refuses to come up, it is no longer possible to tell it what SSID to use, and you can't get to the next screen where it asks for the password/key. As a result, the TV never connects at all.

Yeah, I bought the TV in the Chicago area before my move. Lots of service places there. I've since moved to the northern mountains of Georgia. I did go to the Samsung web site to see where the closest authorized service center is and it says Miami, FL. Not a practical alternative. And the shipping box got lost in the move so I have no way to ship it either. Just as well. It would probably cost more to ship it than replace it.

Thanks for your help.

Bruce.

Collapse -
That's good info.
by R. Proffitt Forum moderator / September 8, 2013 8:31 AM PDT

Now consider that Samsung does adher to WiFI specs pretty rigidly. TP-Link had to relax their router code to get it to work with Samsung so what you wrote makes me think about how rigid Samung can be.

-> In short, anything beyond a normal setup of the router seems to break. That is, router defaults and changing the security to WPA2 AES (personal) seems to work very well. Changing to a Google DNS seems to side step ISP issues.

But if you do the dual zone WiFi, I see troubles. As it's not a Samsung router you can take bets if you'll get support for that network.
Bob

Collapse -
Samsung TV 5300 UN40EH5300F won't display wireless SSID list
by bachastain / September 8, 2013 10:19 AM PDT
In reply to: That's good info.

Yep. And even if I could get it to a service center, the chances they could duplicate my setup seem slim to none.

And since I personally believe it to be a firmware bug (10 other WiFi devices in my house work just fine with my setup), the service department would be helpless to do anything about it even if they could replicate the problem.

Bruce.

Collapse -
Signal strength
by bachastain / September 8, 2013 11:15 AM PDT

BTW, I held my laptop up next to the TV and the laptop shows to be receiving an "excellent" signal strength. At least the laptop is very happy.

Bruce.

Collapse -
Laptops are usually 2 or times better than a TV.
by R. Proffitt Forum moderator / September 8, 2013 11:45 AM PDT
In reply to: Signal strength

It's not a very good test but nice idea. Is there any hope of getting any of the tests done?

If not we have to move to the end solution of return as defective.
Bob

Collapse -
Sorta working
by bachastain / September 8, 2013 11:01 PM PDT

The TV can't be returned or serviced.

I had another experiment that I thought might be interesting. Despite my laptop experiment that shows the area of the TV has an excellent signal strength, I thought it would be interesting if I could place a AP here in the basement, close to the TV, rather than through wood walls.

I found a freebee program called MyPublicWiFi. That runs on any device that has a WiFi adapter and it creates a new AP with a new SSID. Pretty cool for free. I was hoping the proximity of the new AP would help give the TV an even stronger signal.

It DID change the symptoms, but in an unexpected way. To review, I already had 2 SSIDs, one WPA2 secured and one open. The TV refused to attach or display a list of SSID.

With the addition of a 3rd SSID, another WPA2 secured one, the SSID list on the TV started coming up! The bad news is the list only stays on the screen for 100ms, just long enough to tell it is the SSID list. Rather than wait for my input, it sees the one open SSID and immediately attaches to to it, and then the list of SSIDs disappears. And it seems stable in this configuration, with good access to the internet. Even after turning the TV off/on it still connects to the only open SSID, even when I disable the just added 3rd SSID. Once the TV attaches to a network, it remembers that.

The problem is I want the TV to attach to the secured SSID that has intranet access so I can play videos from my PC on the TV screen. Until I can get it to attached to a secured network, I can't do that. Since the SSID list is only on the the screen just for a fraction of a second, it's impossible to select the correct SSID or enter the needed password/key.

Anyway, IMO that demonstrates there is nothing wrong with the TV's WiFi hardware. The problem is in the TV's firmware in how it handles the SSID list. Getting the TV serviced (even iif that was possible) would be a waste of time, effort, and money. What it needs is a firmware fix.

Bruce.

Collapse -
Back to the router settings.
by R. Proffitt Forum moderator / September 9, 2013 12:22 AM PDT
In reply to: Sorta working

You revealed that " it turns out this started when I added a second SSID to the router ".

As this is not a PC and the Samsung WiFi software "stack" adhers to the rules all I can write is you have choices to make.

As in, go with what works or find someone to fix it. I've encountered a few folk that yell and scream all the other PCs work and it won't change how Samsung's TVs work. Here's a note about that from TP-Link. They found the root cause and relaxed (some say broke) their code to accommodate the Samsung.

-> http://www.tp-link.es/article/?faqid=510

Bob

Collapse -
Continued
by bachastain / September 9, 2013 3:24 AM PDT
In reply to: Sorta working

This forum has cut off additional replies for some very rude reason, so I'll complete my last message here.

Thanks Bob. I learned a lot about arp understanding the TP-Link issue.

IMO, this is not a problem in the way the TV and router are communicating. This is not an Ethernet and/or stack problem.

It is simpler than that. The TV under most circumstances is refusing to either put the SSID list on the screen, or is refusing to leave it there. I have seen the list flash for a moment, just long enough to see the TV has the list and it's properly populated and accurate.

My guess is that the coders decided that if there is only 1 SSID and it is unsecured, there's no reason to ask the user about it. Just go ahead and attach to make configuration easier. And when the TV is powered on, if it has a previous SSID, go ahead and attach to that automatically. So the coders were trying to reduce the number of times the user has to be asked for the correct SSID, all in the interest of a more automatic WiFi configuration.

It is that code that I think is busted. When the START button is pressed, it is incorrectly suppressing the SSID list and blindly attaching to the old SSID it has. In some cases it actually puts the SSID list on the screen and then discovers it still has a valid SSID so it immediately clears the list from the screen. I think pressing the START button should force the list up, regardless of how many entries there and and regardless of whether they are WPA2 secured or not (requiring a password from the user).

Anyway, I think we've taken this about as far as we can. It's up to Samsung now to fix their busted firmware.

Thanks for your help!

Bruce.

Collapse -
Answer
When the forum bottoms out, reply up top.
by R. Proffitt Forum moderator / September 9, 2013 3:31 AM PDT

This forum software does that for everyone so it's not up and just like your router with multiple SSIDs you can go down many roads such as declaring Samsung's stack is busted or going with what works.

Here, if I want a second SSID I never use the router since I've found them to break when we do that. Instead I get a second router and set it up as a WAP. Google "How to use a router as a WAP?" if you want to know this.

I can't tell which road you're going to take here but it certainly looks like another strict adherence to the IP programming rules to me. I supplied the TP Link article to show where a router company "broke" their product to get along with the strict software in the Samsung.
Bob

Collapse -
WAP
by bachastain / September 9, 2013 8:05 AM PDT

Thanks for the idea about a WAP. I'll keep that in mind.

Bruce.

Collapse -
Yanking the cord
by bachastain / September 9, 2013 12:41 PM PDT
In reply to: WAP

I discovered that if I do the factory reset on the TV, the SSID menu does consistently appear after START is pressed, but only once. A nice menu of all available SSIDs does appear. If you select a WPA2 network then you get to the password screen. But it still won't connect.

After that you will likely never again see the SSID menu until another factory reset is done.

Of course factory reset resets all your TV customizations so it's a royal pain to use.

I've also observed that simply turning off/on the TV does nothing, but sometimes physically unplugging the AC will prompt the SSID menu to appear, also only once.

Bruce.

Collapse -
Very odd.
by R. Proffitt Forum moderator / September 9, 2013 1:48 PM PDT
In reply to: Yanking the cord

So this is with the single SSID on the router? If so, call it in and ask for a fix. My bet is dual SSIDs on routers is not supported as each would not have an unique MAC. If you've been absorbing all the above it would be odd to see two SSIDs with the same MAC.
Bob

Collapse -
SSID
by bachastain / September 10, 2013 12:15 AM PDT
In reply to: Very odd.

The number of SSIDs does seem to affect the symptom, so I disabled the guest SSID. All I have left is 1 WPA2 secured SSID.

As before, the START button brought up the SSID menu, but only for an instant. It was gone before I could read it or do anything with it, which meant there is no way to set the network key.

So I did a factory reset. As part of the reset, it asks a bunch of questions and also steps you through the network configuration. Using that, the SSID list did appear and stick. I selected my only SSID and after a few seconds it asked me for the network key, which I entered and finished the setup. Seemed like it worked until I tried to use it. The TV wouldn't access the internet at all, and the TV doesn't show up in the routers client list.

So I did another factory reset to try again. Now the SSID list won't come up at all, no matter how many times I do a factory reset. It just stops when the SSID menu should appear and won't go any further. You have to select SKIP to get past the wireless setup to finish the factory reset. Trying to do the setup later with NETWORK -> NETWORK SETTINGS yields the same result. The SSID menu either flashes to briefly to do anything with it, or it hangs and won't display it at all.

So while multiple SSID with a single MAC might be an issue, I can't get the TV to work even with a single secured SSID. There may be multiple issues here that are confusing the symptoms.

Bruce.

Collapse -
Remove AC
by bachastain / September 10, 2013 12:32 AM PDT
In reply to: SSID

In order to get the SSID list back on the screen, I had to combine doing a factory reset with pulling the AC cord.

I was now able to do the setup in the factory reset initial setup. I was able to select the SSID and enter the password. DIdn't help. Still won't work connect or work.

Tried NETWORK -> NETWORK SETTINGS again. Just hangs. Tried pulling the plug again. Now the SSID list just flashes by and never connects or asks for the network key..

So the TV won't work with even a single secured SSID. A single open SSID is all that works, but even there the SSID menu remains flaky. Sometimes it will appear but most often not. The TV will just attach automatically without ever asking you what you want to do.

Bruce.

Collapse -
And WPA2 has limits.
by R. Proffitt Forum moderator / September 10, 2013 12:32 AM PDT
In reply to: SSID

Over in the CNET Network forum I noted this and have found that some can't work withing the limits.

We have many posts and it appears that you must take this up directly with the seller and Samsung. I gave it a try and I'm sorry if this upsets you, you seem to be under the impression that if a PC works, the TV should work too. We wish that was true.
Bob

Collapse -
Can't attach to router
by bachastain / September 10, 2013 2:58 AM PDT
In reply to: And WPA2 has limits.

I very much appreciate your efforts to resolve this Samsung problem.

Bruce,

Collapse -
I see above you can make it work?
by R. Proffitt Forum moderator / September 10, 2013 3:09 AM PDT
In reply to: Can't attach to router
http://forums.cnet.com/7726-13973_102-5496054.html?tag=posts;msg5496054

Hopefully you've chatted with Samsung so they know that a router with a second SSID does not work. My thought is along the lines of why the TP Link failed. It was Samsung coding EXACTLY to the rules and TP Link was able to break their product a little to accommodate STRICT devices.

I know you may not care as a consumer but my background included router coding in the 1990s so I appreciate how you often find yourself programming to a specification and the next device is not up to code.
Bob
Collapse -
Samsung bug
by bachastain / September 10, 2013 5:11 AM PDT

A single secured SSID doesn't work either.

Collapse -
Samsung TV doesn't work right withD-Link either
by bachastain / September 10, 2013 5:20 AM PDT
In reply to: Samsung bug

As an experiment, I dug out my older D-Link DIR-655 and set it up with a single secured SSID. The Samsung fails in the same way. So I tried 2 SSIDs as before, and Samsung also fails on that too. But it's even worse on the D-Link as the single unsecured SSID is difficult to get working at all without using AC plug pulls and factory resets. All the nonsense with the SSID list not coming up is the same as the ASUS router.

Bruce.

Collapse -
True. WPA TKIP may not work.
by R. Proffitt Forum moderator / September 10, 2013 5:31 AM PDT
In reply to: Samsung bug

Sorry but why not go with what works? This is a lot of posts and it's well known there are limitations. These are nothing like a PC when it comes to networking.
Bob

Collapse -
Secured
by bachastain / September 10, 2013 6:14 AM PDT

The TV WiFi is useless to me if I can't get it on my secured network which doesn't; work. Only unsecured networks work, and I'd be nuts to do that.

Bruce.

Collapse -
I was very specific in my last post.
by R. Proffitt Forum moderator / September 10, 2013 6:27 AM PDT
In reply to: Secured

I wrote WPA TKIP may not work.

I didn't write much more because I had hope you would exclaim you were trying to use WPA2 TKIP (which may fail too.) I've had fine success with WPA2 AES with simple SSID and passwords. Again the password and SSID must be alphanumeric and not too long.

And then we have outdated advice about hiding the SSID. That fails too.

-> All these posts and I learned one thing and that's the new routers with dual or more SSID are going to be problematic and I can see why. But I can't see your choices here so I can't write if it should have worked.
Bob

Collapse -
Answer
Forum bottomed out again.
by R. Proffitt Forum moderator / September 10, 2013 6:35 AM PDT

This is a lot of posts and I hope we are getting closer.
Bob

Collapse -
TKIP is problematic on many -> things <-
by R. Proffitt Forum moderator / September 10, 2013 6:42 AM PDT

Noted widely so I won't dredge up much.
http://forum.xda-developers.com/showthread.php?t=961692

In short, if you find a client that insists on TKIP you put on your best face and find an exit. There are many that want everything that connects on a PC to connect on Android, BD players and Smart TVs. Those folk may take time, seasoning or visits to the return counter to catch on that all is not worked out in this area.

A few will shout bug and demand it get fixed but that is nothing I can do here for them. I don't mind working this rat's maze of issues but we must want it to work and it appears that you did have it working.

---> I completely forgot how to tell you how to make a Samsung forget an old connection. The method I use is to use it's network setup and tell it to use Ethernet. OK that then go back to the WiFI setup.
Bob

Popular Forums
icon
Computer Help 49,613 discussions
icon
Computer Newbies 10,349 discussions
icon
Laptops 19,436 discussions
icon
Security 30,426 discussions
icon
TVs & Home Theaters 20,308 discussions
icon
Windows 10 360 discussions
icon
Phones 15,802 discussions
icon
Windows 7 7,351 discussions
icon
Networking & Wireless 14,641 discussions

Tech Tip

Stuck without Internet and want to watch movies?

CNET shows you how to download movies and TV shows onto your device using Amazon Prime so you'll always be entertained.