Samsung forum


Samsung HT-BD1250 stuck on "Load"

by mtdaniele / February 17, 2012 10:23 AM PST

I have the Samsung HT-BD 1250 home theater system and about 2 months after the original warranty expired the blue ray player stopped working and red light would come on. We sent it back and paid the fee to have it fixed and now about 16 months later it is not working again. This time the DVD player keeps saying LOAD and will not get past this screen. Any suggestions? Don't want to waste our money again sending it back?

Post a reply
Discussion is locked
You are posting a reply to: Samsung HT-BD1250 stuck on "Load"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung HT-BD1250 stuck on "Load"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Samsung HT-BD1250 stuck on "Load"
by Samsung_HD_Tech Samsung staff / February 17, 2012 2:11 PM PST

mtdaniele -

Collapse -
Same Problem
by FierstArter / March 4, 2012 9:20 AM PST

I've got the same problem. When I select Bluray play back it just gets stuck on "load." I can use the other functions like AUX and sound still comes out, but when I try and play a disc it just says "Load."

Also, I can't see anything on the screen at all. It's just white with the HDMI output.

Popular Forums
Computer Help 49,613 discussions
Computer Newbies 10,349 discussions
Laptops 19,436 discussions
Security 30,426 discussions
TVs & Home Theaters 20,308 discussions
Windows 10 360 discussions
Phones 15,802 discussions
Windows 7 7,351 discussions
Networking & Wireless 14,641 discussions

CNET Holiday Gift Guide

Looking for great gifts under $100?

Trendy tech gifts don't require a hefty price tag. Choose from these CNET-recommended useful and high-quality gadgets.